×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Apr 2008
    Posts
    5

    Which Flash version to base application on?

    Hello there!

    I'm just starting up development of a Flash Lite application. I'm not really sure which version of Flash Lite to go with though.

    These are some of the things we need to solve in order for the app to work:

    - Communicate with web server (not on mobile phone, read external server) to send and receive XML to/from database and receive binary data (read SWF files)
    - Save text and binary data persistently on mobile phone
    - Main SWF has to be able to read local persistent SWFs
    - The application is designed to run offline (apart from send/receive at startup and shutdown)
    - Perhaps create an installation package which bundles both Flash Lite player and the application itself

    We are building the first version for early adopters in Sweden and I'm trying to steer it towards Symbian S60 phones, but it would be a superb bonus if it could run on new models of Sony Ericsson cell phones as well. The app is planned to be released in August this year.

    Which version would you guys suggest - 1.1 or 2.0, 2.1 or even 3?

    Thanks a lot, really appreciate your time guys.

    Alrighty then, Andreas

  2. #2
    Regular Contributor
    Join Date
    Feb 2007
    Posts
    89

    Re: Which Flash version to base application on?

    Hi,

    You can do those with FL2.0. But I would suggest you to try using 1.1 to reach most phones out there.

    If you target only S60, there are many packagers out there, if you want to get it to Series 40 also, there is Jarpa to pack it up.

    Ugur.-
    Follow me on Twitter [url]www.twitter.com/ugurkaner[/url]

    Create sexiest Symbian apps faster & easier [url]www.kunerilite.net[/url]
    Turn your Joomla! website into a mobile site instantly [url]www.mobilejoomla.com[/url]

  3. #3
    Registered User
    Join Date
    Apr 2008
    Posts
    5

    Re: Which Flash version to base application on?

    Hello again!

    Do you think I could solve the functionality I listed with Flash Lite 1.1? I would love to go with that version, just scared I will fall short of this rather specific specifications...

    /a n d i

  4. #4
    Product Specialist
    Join Date
    Jun 2003
    Location
    UK
    Posts
    191

    Re: Which Flash version to base application on?

    Hi Andi,

    At the moment the penetration of FL1.1 is slightly higher than FL2.x or FL3. In 2008 this will change somewhat and considering your launch is in August I would target FL2.

    Flash Lite does not support saving of persistent data as a feature. There are some 3rd party tools that enable this but using these will limit you to S60.

    We recently published some data on the Swedish market here.
    http://www.adobe.com/devnet/devices/...b_jan_2008.pdf

    Mark
    Mark Doherty
    Developer Evangelist
    Adobe Systems, Mobile and Devices EMEA

Similar Threads

  1. Nokia N95 8GB adds Flash Lite 3 support
    By biskero in forum [Archived] Flash Lite on Nokia Devices
    Replies: 17
    Last Post: 2008-02-15, 21:59
  2. Flash Lite Application Charset Problem
    By D.Luciani in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 3
    Last Post: 2007-03-07, 14:30
  3. Replies: 1
    Last Post: 2002-05-14, 15:45
  4. Replies: 1
    Last Post: 2002-05-14, 15:31
  5. Replies: 1
    Last Post: 2002-05-14, 15:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×