×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    May 2006
    Location
    Budapest
    Posts
    21

    RSendAs panics on cleanup (after sending email with attachment)

    I'm using RSendAs to send emails with file attachments. Everything works fine (the message is sent) until it comes to cleanup. If I try to close the RSendAsMessage (by calling RSendAsMessage::Close()), the SendAsServer crashes with a KERN-EXEC 3... Even stranger is that if I try to close the RSendAs (server session handle), the server also crashes. Let me emphasize that it is not my application that crashes but the SendAsServer. Here is the entry from epocwind.out:

    Thread !SendAsServer::Main Panic KERN-EXEC 3

    I got the error both on the emulator and on the device (N95).

    I managed to figure out that the problem relates to the attachment. If I don't attach anything to the email, then I can close the resources after I sent it. I tried both RSendAsMessgae::AddAttachment and RSendAsMessgae::AddLinkedAttachment (and again: sending the mail with the attachment works fine, only the cleanup is problematic).

    One more thing I tried is to let the RSendAs sessions remain open all the time, never closing it (yes, possible memory leak). It's fine until the app is running, but the SendAsServer crashes at the moment I exit...

    So this is it. Has anybody run into something like this? Looks like a bug to me...
    Imre Kelényi

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: RSendAs panics on cleanup (after sending email with attachment)

    Does it also happen on the other devices?

    (Edit: according to other posts, it will...)
    Last edited by wizard_hu_; 2008-04-25 at 13:45.

  3. #3
    Registered User
    Join Date
    Feb 2010
    Posts
    17

    Question Re: RSendAs panics on cleanup (after sending email with attachment)

    Quote Originally Posted by wizard_hu_ View Post
    Does it also happen on the other devices?

    (Edit: according to other posts, it will...)
    hi
    i am using rsendas api to send my message ,everything goes fine my application run on emulator but the emulator exit after it ask to press any key when i press any key it start connecting to server and says connetion sucessful and then the application exit ,kindly help me and tell me where the problem actually ppersist

    thanks & regards
    pushpankar

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: RSendAs panics on cleanup (after sending email with attachment)

    You have a panic. The panic message can be displayed (http://wiki.forum.nokia.com/index.ph...ded_panic_code), then it will also appear at the end of the Output window, and the logfile (http://wiki.forum.nokia.com/index.php/Epocwind.out).
    The emulator is closing with your application, because it was launched by your application. If you launch the emulator instead via epoc.exe, it will survive the panic: http://wiki.forum.nokia.com/index.ph...arbide.c%2B%2B

Similar Threads

  1. Replies: 1
    Last Post: 2006-08-18, 09:03
  2. Replies: 4
    Last Post: 2006-08-17, 10:05
  3. How to set default access point for sending email using RSendAs?
    By xhsoldier in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2006-08-15, 09:07
  4. Ask again about sending email using RSendAs and RSendAsMessage
    By xhsoldier in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2006-07-20, 13:14
  5. open email attachment in Series60?
    By bcchong in forum Symbian
    Replies: 0
    Last Post: 2002-07-09, 00:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×