×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Jan 2008
    Posts
    11

    application fails on s60 devices

    HI,
    I have tried some simple midlets such as the HelloWorld,and it works well on the s60 emulator.But when i want to test it on the s60 devices,it can be installed but can't be executed.The application just stays at a still phase,you can do nothing but to delete the application.
    could anyone tell me why this happens?
    Thanx!

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: application fails on s60 devices

    don't know too much about Java too be honest, but usually application do not just stay idle if you click the icon, but they actually crash during the launch. Thus you could try checking if you could catch the crash event and error code from it, here's a bit of help: http://wiki.forum.nokia.com/index.ph...ded_panic_code

  3. #3
    Super Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,557

    Re: application fails on s60 devices

    And which device models did you try it on, and what firmware version?

  4. #4
    Registered User
    Join Date
    Jan 2008
    Posts
    11

    Re: application fails on s60 devices

    Hello, my IDE is eclipse 3.3,and SDK is S60 3rd Edition FP2 SDK.
    I have tried my application on N95 which was bought in HongKong ,also tried it on 6120c,both failed.
    As to the firmware version,I am not sure about it.

  5. #5
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: application fails on s60 devices

    you, maybe you could try cathing the error code as I suggested earlier...

    Or try FP1 SDK.

  6. #6
    Registered User
    Join Date
    Dec 2004
    Posts
    369

    Re: application fails on s60 devices

    yeliya : we can best help you if you link the jar & jad of your app.

    at the top of my head i can think of some reasons why it will "hang"
    wrong midlet name/path at the jad?
    exception is being thrown at startApp() method?
    deadlock?
    infinite loop?

    so post your code and jar & jad and we can help you better

    BR

  7. #7
    Registered User
    Join Date
    Jan 2008
    Posts
    11

    Re: application fails on s60 devices

    Hello,thanks for your attention.
    My problem has been solved.I reinstalled all the softwares and then the generated jar can be executed on the s60 devices.So i think it's just because i had installed one of the softwares in wrong directory.
    Thanks again.

Similar Threads

  1. .sis file installs but will not run on some S60 3rd devices.
    By rlang@onetel.net.uk in forum Symbian
    Replies: 8
    Last Post: 2007-10-19, 12:39
  2. Replies: 6
    Last Post: 2006-09-12, 06:19
  3. Replies: 0
    Last Post: 2006-07-26, 19:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×