×

Discussion Board

Results 1 to 9 of 9

Thread: loadMovie

  1. #1
    Registered User
    Join Date
    Apr 2008
    Posts
    9

    loadMovie problem on Flash Lite 3.0

    Hi all,

    I am havnig problems using loadMovie on Flash Lite 3.0 (N95 8GB)

    I created 2 files for testing:

    1. main.swf (only one line of code at the 1st frame)

    Code:
    loadMovie("test.swf","mc")
    (movieClip mc exist)

    2. test.swf (picture only)

    When I run it on PC, it works fine. However when I upload those two files to the phone (c:\Data\Others\), movie is not loaded.

    I also used another path (C:\Data\Others\Trusted\). Still no luck.

    When i do the same with Flash Lite 1.1 Phone with the same files, it works fine.

    I also tried both relative path and absolute path, both works for Flash Lite 1.1, but neither works in FL3.0!

    Any ideas?

    Thanks a lot!

    Kevin
    Last edited by xiaolvren; 2008-05-09 at 13:29. Reason: language problem

  2. #2
    Nokia Developer Champion
    Join Date
    Nov 2007
    Location
    Rome, Italy
    Posts
    2,405

    Re: loadMovie problem on Flash Lite 3.0

    Just guessing here, but have you tried with both "Access network only" and "Access local files only" publishing settings?

    Pit

  3. #3
    Regular Contributor
    Join Date
    Feb 2007
    Posts
    89

    Re: loadMovie

    Do you think it would matter in 'trusted' folder? I think both are ignored there.

    Ugur.-
    Follow me on Twitter [url]www.twitter.com/ugurkaner[/url]

    Create sexiest Symbian apps faster & easier [url]www.kunerilite.net[/url]
    Turn your Joomla! website into a mobile site instantly [url]www.mobilejoomla.com[/url]

  4. #4
    Nokia Developer Champion
    Join Date
    Feb 2005
    Location
    Karachi, Pakistan
    Posts
    277

    Re: loadMovie

    It works for me. On FL3 Adobe (E50) as well as on FL3 Nokia (N95).

    Would you like to share a sample?

    // chall3ng3r //
    Faisal Iqbal (skype: chall3ng3r)
    Flash Mobile Specialist | Orison Technologies
    _____________________________________
    blog: F·L·A·S·H·I·S·M
    swf2go: www.swf2go.com

  5. #5
    Nokia Developer Champion
    Join Date
    Apr 2005
    Location
    Boston
    Posts
    517

    Re: loadMovie

    Ciao

    did you try this:

    loadMovie("test.swf", mc);

    Alessandro

  6. #6
    Registered User
    Join Date
    Apr 2008
    Posts
    9

    Re: loadMovie

    Hi,
    Thanks all above.

    i had tried both of them Jappit,not work.Thanks for advice.

    And i had tried mc without "" as well, Alessandro.No luck.Thanks for advice.

    Thanks chall3ng3r.
    I am not able to upload files in this forum yet.However, i think the samples are exactly the same as what i have described.But since it is working in your case,there are must be something wrong with my files but not FL3.0, i will check everything all again .

    Thanks for all of your replies

    Kevin

  7. #7
    Registered User
    Join Date
    Apr 2008
    Posts
    9

    Re: loadMovie

    Hi,

    Here i have new testing results, when i run the swf files from y-browser and file manager,it dosen't load the movie, but if i run from FlashLite player, it loads pretty well.

    Is this a new feature of FL3.0? since it works in other versions.


    Kevin.

  8. #8
    Registered User
    Join Date
    Oct 2008
    Posts
    11

    Re: loadMovie

    Hi,

    I'm having exactly the same problem - when I use loadMovie inside of a browser it doesn't work at all. Only a startup of the flash file through the pre installed flash program seems to work. Did you find a solution for that?

    Thank you in advance!

  9. #9
    Nokia Developer Champion
    Join Date
    Jul 2008
    Location
    Pakistan
    Posts
    1,065

    Smile Re: loadMovie

    Quote Originally Posted by Networx View Post
    Hi,

    I'm having exactly the same problem - when I use loadMovie inside of a browser it doesn't work at all. Only a startup of the flash file through the pre installed flash program seems to work. Did you find a solution for that?

    Thank you in advance!
    Firstly, if u r using FLash Lite 3.0 , there is a security sandbox that if u export ur swf as "Access network Only" then it wont access Local Swf Files and vice versa.
    Remember: if u r using Flash Lite 1.1 to 2.1 or 3.1 , then this security issue is ignored
    Secondly, Try to give absolute path in your loadMovie parameter i.e like file:\\//e://others//external_swf_file.swf . M sure we already discussed such issues before.Please, search this dibo.Hope it helps u..

    Best Regards,
    SajiSoft

Similar Threads

  1. How to read 6650 MSISDN? SDK 3.0 Phonebook Component does not work.
    By peterhar in forum PC Suite API and PC Connectivity SDK
    Replies: 2
    Last Post: 2007-04-04, 21:02
  2. PC Suite + SDK 3.0
    By alexander.stoyan in forum PC Suite API and PC Connectivity SDK
    Replies: 11
    Last Post: 2007-02-05, 12:46
  3. How to install Nokia SDK 3.0 on Windows 2003?? HELP
    By s.piadlowski in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2006-04-13, 17:55
  4. sdk 2.1 to sdk 3.0 compatibility
    By veciofio in forum PC Suite API and PC Connectivity SDK
    Replies: 2
    Last Post: 2003-11-25, 21:55
  5. SDK 3.0 and C#
    By rtoews in forum PC Suite API and PC Connectivity SDK
    Replies: 2
    Last Post: 2003-09-02, 15:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •