×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Registered User
    Join Date
    Apr 2008
    Posts
    17

    Unable to install ...

    im trying to install an application on device but it is giving an error "Unable to install" please if anyone can tell me what is the problem; here is my pkg file;

    ; MyApplication.pkg

    ; Languages
    &EN

    ; Header
    #{"MyApplication"},(0x20013ACE), 02, 50, 38

    ; Platform compatibility
    [0x101F7961], *, *, *, {"Series60ProductID"}

    ; vendor
    %{"MyApplication"}
    :"Vendor Name"

    ; Target

    "C:\Symbian\9.1\S60_3rd\Epoc32\release\gcce\UREL\ServiceWatch.exe"-"!:\sys\bin\ServiceWatch.exe"

  2. #2
    Registered User
    Join Date
    Apr 2008
    Posts
    17

    Re: unable to install SIS

    here is the output:

    * Running build action: build
    epocroot =
    * C:\Nokia\Tools\Carbide_vs\make.bat -f C:\Symbian9Code\PX25\MyApplication\group\MyApplication.GCCE UREL
    C:\Symbian9Code\PX25\MyApplication\group\MyApplication.GCCE:21444: target `\Symbian\9.1\S60_3rd\EPOC32\DATA\Z\Resource\Apps' given more than once in the same rule.
    make: *** No rule to make target `\Symbian\9.1\S60_3rd\EPOC32\INCLUDE\MyApplication.rsg', needed by `\Symbian\9.1\S60_3rd\EPOC32\DATA\Z\private\10003a3f\import\apps\MyApplication_reg.RSC'. Stop.
    ERROR: RCMake failed: (Make): make command exited with result 2. (Reason: The system cannot find the file specified.)

  3. #3
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: unable to install SIS

    Quote Originally Posted by CatherineJ View Post
    im trying to install an application on device but it is giving an error "Unable to install" please if anyone can tell me what is the problem; here is my pkg file;

    ; MyApplication.pkg

    ; Languages
    &EN

    ; Header
    #{"MyApplication"},(0x20013ACE), 02, 50, 38

    ; Platform compatibility
    [0x101F7961], *, *, *, {"Series60ProductID"}

    ; vendor
    %{"MyApplication"}
    :"Vendor Name"

    ; Target

    "C:\Symbian\9.1\S60_3rd\Epoc32\release\gcce\UREL\ServiceWatch.exe"-"!:\sys\bin\ServiceWatch.exe"
    Could it be that the ServiceWatch.exe already exists on the phone. The recommended best practice is to use the following naming convention: <project_name>_<project_UID3>.<extension> so that the file name clash is avoided.

    Quote Originally Posted by CatherineJ View Post
    here is the output:

    * Running build action: build
    epocroot =
    * C:\Nokia\Tools\Carbide_vs\make.bat -f C:\Symbian9Code\PX25\MyApplication\group\MyApplication.GCCE UREL
    C:\Symbian9Code\PX25\MyApplication\group\MyApplication.GCCE:21444: target `\Symbian\9.1\S60_3rd\EPOC32\DATA\Z\Resource\Apps' given more than once in the same rule.
    make: *** No rule to make target `\Symbian\9.1\S60_3rd\EPOC32\INCLUDE\MyApplication.rsg', needed by `\Symbian\9.1\S60_3rd\EPOC32\DATA\Z\private\10003a3f\import\apps\MyApplication_reg.RSC'. Stop.
    ERROR: RCMake failed: (Make): make command exited with result 2. (Reason: The system cannot find the file specified.)
    Here's the output of what? According to your first message the sis file gets gnerated thus all the needed content is available for being shipped to the phone.

    The output shows that you have problems compiling the resources but I fail to see how the two problems are related.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,684

    Re: unable to install SIS

    Quote Originally Posted by ltomuta View Post
    Could it be that the ServiceWatch.exe already exists on the phone.
    That is usually an "Update error".

    My guess would be the *,*,* as version number for the pre-requisite. Though it seems familiar, I can not remember if it actually works or not.

  5. #5
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: unable to install SIS

    Quote Originally Posted by wizard_hu_ View Post
    That is usually an "Update error".
    True. Is just that the file name looks so ... clash prone.

    The *,*,* looks good to me and so does everything else. I wonder if we are seeing everything that is to be seen here.

    BTW, the SDK choice is questionable though most likely irrelevant, at least for the installation issue.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  6. #6
    Registered User
    Join Date
    Feb 2005
    Location
    Bangalore
    Posts
    11

    Exclamation Re: Unable to install ...

    abld reallyclean
    bldmake clean
    bldmake bldfiles
    abld build < target >

    Delete manually your private folder files in EPOC and try.
    Ram
    India

  7. #7
    Regular Contributor
    Join Date
    Sep 2010
    Location
    India
    Posts
    75

    Re: Unable to install ...

    I tried installing an app with No capabilties and got error as "Unable to install".
    I'm not self signing it nd got it signed from SymbianSigned.com;My UID is withing the required range.

    Here's my Pkg File:

    ; Installation file for Nisha application
    ;
    ; This is an auto-generated PKG file by Carbide.
    ; This file uses variables specific to Carbide builds that will not work
    ; on command-line builds. If you want to use this generated PKG file from the
    ; command-line tools you will need to modify the variables with the appropriate
    ; values: $(EPOCROOT), $(PLATFORM), $(TARGET)
    ;
    ;Language - standard language definitions
    &EN

    ; standard SIS file header
    #{"Nisha"},(0xE47EE06A),1,0,0

    ;Localised Vendor name
    %{"Vendor-EN"}

    ;Unique Vendor name
    :"Vendor"

    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}

    ;Supports S60 release 5.0
    [0x1028315F], 0, 0, 0, {"Series60ProductID"}

    ;Files to install
    ;You should change the source paths to match that of your environment
    ;<source> <destination>
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\Nisha_0xE47EE06A.exe" -"!:\sys\bin\Nisha_0xE47EE06A.exe"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\Nisha_0xE47EE06A.rsc" -"!:\resource\apps\Nisha_0xE47EE06A.rsc"
    ;"$(EPOCROOT)Epoc32\data\z\private\10003a3f\apps\Nisha_0xE47EE06A_reg.rsc" -"!:\private\10003a3f\import\apps\Nisha_0xE47EE06A_reg.rsc"
    "$(EPOCROOT)Epoc32\data\Nisha_0xE47EE06A_reg.rsc" -"!:\import\apps\Nisha_0xE47EE06A_reg.rsc"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\Nisha_0xE47EE06A.mif" -"!:\resource\apps\Nisha_0xE47EE06A.mif"


    Any clue..??any thing else???

  8. #8
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Unable to install ...

    At least you could maybe explain on why you did think it is a good idea to change the target folder for the registration resource file.. that path propably wont work, o just change it back to the original.

    Then check the platform & target, sometimes it might be good idea to just hard code those for the actual target.

  9. #9
    Regular Contributor
    Join Date
    Sep 2010
    Location
    India
    Posts
    75

    Re: Unable to install ...

    i read somewhr tht..."Unable to install"message may come up when your installation file (.sis/.sisx) copies files to other application's private folder....

    so tried copying to another location...kinda hit nd trial....

    This is how my PKG file luks now::\

    ; Installation file for Nissan application
    ;
    ; This is an auto-generated PKG file by Carbide.
    ; This file uses variables specific to Carbide builds that will not work
    ; on command-line builds. If you want to use this generated PKG file from the
    ; command-line tools you will need to modify the variables with the appropriate
    ; values: $(EPOCROOT), $(PLATFORM), $(TARGET)
    ;
    ;Language - standard language definitions
    &EN

    ; standard SIS file header
    #{"Nisha"},(0xE47EE06A),1,0,0

    ;Localised Vendor name
    %{"Vendor-EN"}

    ;Unique Vendor name
    :"Vendor"

    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}

    ;Supports S60 release 5.0
    [0x1028315F], 0, 0, 0, {"Series60ProductID"}

    ;Files to install
    ;<source> <destination>
    "\S60\devices\S60_5th_Edition_SDK_v1.0\Epoc32\release\armv5\udeb\Nisha_0xE47EE06A.exe" -"!:\sys\bin\Nisha_0xE47EE06A.exe"
    "\S60\devices\S60_5th_Edition_SDK_v1.0\Epoc32\data\z\resource\apps\Nisha_0xE47EE06A.rsc" -"!:\resource\apps\Nisha_0xE47EE06A.rsc"
    "\S60\devices\S60_5th_Edition_SDK_v1.0\Epoc32\data\z\private\10003a3f\apps\Nisha_0xE47EE06A_reg.rsc" -"!:\private\10003a3f\import\apps\Nisha_0xE47EE06A_reg.rsc"
    "\S60\devices\S60_5th_Edition_SDK_v1.0\Epoc32\data\z\resource\apps\Nisha_0xE47EE06A.mif" -"!:\resource\apps\Nisha_0xE47EE06A.mif"

    But I'm still unable to install with the same msg. I'm making the sis file thru carbide UI,with dont sign sis option and then uploading it to online symbian signed nd i build with target as "Phone Debug". Using N97 as my target device.


    Any clue?
    Last edited by Megh; 2011-01-04 at 09:59. Reason: .

  10. #10
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Unable to install ...

    ok then, try commenting lines out with ; and see which line is then causing the problem. Sofar it looks ok to me, if you really take care that you are using the target builds for teh executables.

  11. #11
    Regular Contributor
    Join Date
    Sep 2010
    Location
    India
    Posts
    75

    Re: Unable to install ...

    Thnks symbianyucca. Thnx for the clue.

    The problem was though i was building the sis for armv5 it was still taking the the excutables created for windows somehow.
    Manually deleting all the generated files did it this time.

  12. #12
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Unable to install ...

    you could also hardcode the platform & target, that way you would always get teh target builds for the sis files..

Similar Threads

  1. Unable to Install. Constrained by the certificate.
    By manjunaths in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 18
    Last Post: 2009-05-06, 10:47
  2. Unable to install. Constrained by the certificate
    By anhquan in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 2
    Last Post: 2007-10-17, 10:29
  3. Replies: 1
    Last Post: 2007-04-16, 11:05
  4. unable to install jar
    By stevenpannell in forum Mobile Java General
    Replies: 5
    Last Post: 2006-11-10, 17:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×