×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    May 2008
    Posts
    2

    Question Problems about maemo 4.0.1 SDK installation.

    Dear all,

    I try to install maemo SDK 4.0.1 on Ubuntu 8.0.4 according document http://repository.maemo.org/stable/chinook/INSTALL.txt. The scratch box can be installed on my pc without any problem. However when I am installing the SDK, there are some errors as below. Do you have any ideas on that? Thanks in advance.

    Code:
    .......
    dpkg: error processing libhildonwm0 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libhildondesktop0:
     libhildondesktop0 depends on libhildonwm0 (>= 1:2.0.6-1); however:
      Package libhildonwm0 is not configured yet.
     libhildondesktop0 depends on libosso-gnomevfs2-0; however:
      Package libosso-gnomevfs2-0 is not configured yet.
    dpkg: error processing libhildondesktop0 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libhildon-thumbnail0:
     libhildon-thumbnail0 depends on libosso-gnomevfs2-0; however:
      Package libosso-gnomevfs2-0 is not configured yet.
    dpkg: error processing libhildon-thumbnail0 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of osso-gnomevfs-extra:
     osso-gnomevfs-extra depends on libosso-gnomevfs2-0; however:
      Package libosso-gnomevfs2-0 is not configured yet.
    dpkg: error processing osso-gnomevfs-extra (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of hildon-thumbnail:
     hildon-thumbnail depends on libhildon-thumbnail0 (>= 0.14); however:
      Package libhildon-thumbnail0 is not configured yet.
     hildon-thumbnail depends on libosso-gnomevfs2-0; however:
      Package libosso-gnomevfs2-0 is not configured yet.
     hildon-thumbnail depends on libhildon-thumbnail0 (= 0.14); however:
      Package libhildon-thumbnail0 is not configured yet.
    dpkg: error processing hildon-thumbnail (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of hildon-thumbnail-libid3:
     hildon-thumbnail-libid3 depends on libhildon-thumbnail0 (>= 0.14); however:
      Package libhildon-thumbnail0 is not configured yet.
     hildon-thumbnail-libid3 depends on libosso-gnomevfs2-0; however:
      Package libosso-gnomevfs2-0 is not configured yet.
     hildon-thumbnail-libid3 depends on hildon-thumbnail (>= 0.4); however:
      Package hildon-thumbnail is not configured yet.
    dpkg: error processing hildon-thumbnail-libid3 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libhildondesktop-dev:
     libhildondesktop-dev depends on libhildondesktop0 (= 1:2.0.6-1); however:
      Package libhildondesktop0 is not configured yet.
    dpkg: error processing libhildondesktop-dev (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libhildonwm-dev:
     libhildonwm-dev depends on libhildondesktop0 (= 1:2.0.6-1); however:
      Package libhildondesktop0 is not configured yet.
    dpkg: error processing libhildonwm-dev (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of hildon-desktop-dev:
     hildon-desktop-dev depends on libhildondesktop-dev; however:
      Package libhildondesktop-dev is not configured yet.
     hildon-desktop-dev depends on libhildonwm-dev; however:
      Package libhildonwm-dev is not configured yet.
    dpkg: error processing hildon-desktop-dev (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of maemo-mmf-runtime:
     maemo-mmf-runtime depends on gstreamer0.10-gnomevfs; however:
      Package gstreamer0.10-gnomevfs is not configured yet.
    dpkg: error processing maemo-mmf-runtime (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of maemo-mmf-dev:
     maemo-mmf-dev depends on maemo-mmf-runtime (= 0.9); however:
      Package maemo-mmf-runtime is not configured yet.
    dpkg: error processing maemo-mmf-dev (--configure):
     dependency problems - leaving unconfigured
    Setting up sysklogd (1.4.1-17.osso1) ...
    mmap: Permission denied
     
    Setting up libesd0 (0.52-14) ...
     
    Setting up osso-esd (0.52-14) ...
     
    Setting up libgconf2-6 (2.16.0-1osso9) ...
     
    Setting up gconf2 (2.16.0-1osso9) ...
    /scratchbox/tools/bin/chown: `messagebus:messagebus': invalid user
    dpkg: error processing gconf2 (--configure):
     subprocess post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of fontconfig:
     fontconfig depends on gconf2 (>= 2.6.0); however:
      Package gconf2 is not configured yet.
    dpkg: error processing fontconfig (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libpango1.0-common:
     libpango1.0-common depends on fontconfig (>= 2.1.91); however:
      Package fontconfig is not configured yet.
    dpkg: error processing libpango1.0-common (--configure):
     dependency problems - leaving unconfigured
    Setting up libpango1.0-0 (1.16.4-1osso5) ...
     
    Setting up libgtk2.0-common (2.10.12-0osso32.1) ...
    Setting up libconic0 (0.13-0.10) ...
     
    Setting up alarmd (0.5.18) ...
    mmap: Permission denied
     
    Setting up clipboard-manager (0.6.8-1) ...
    Setting up libedataserver (1.4.2.1-20070926) ...
     
    Setting up libebook (1.4.2.1-20070926) ...
     
    Setting up libedata-book (1.4.2.1-20070926) ...
     
    Setting up evolution-data-server-addressbook (1.4.2.1-20070926) ...
    dpkg: dependency problems prevent configuration of libgconf2-dev:
     libgconf2-dev depends on gconf2 (>= 2.16.0-1osso9); however:
      Package gconf2 is not configured yet.
    dpkg: error processing libgconf2-dev (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libedataserver-dev:
     libedataserver-dev depends on libgconf2-dev; however:
      Package libgconf2-dev is not configured yet.
    dpkg: error processing libedataserver-dev (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libedata-book-dev:
     libedata-book-dev depends on libedataserver-dev (= 1.4.2.1-20070926); however:
      Package libedataserver-dev is not configured yet.
    dpkg: error processing libedata-book-dev (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of evolution-data-server-dev:
     evolution-data-server-dev depends on libedata-book-dev (= 1.4.2.1-20070926); ho                                              wever:
      Package libedata-book-dev is not configured yet.
    dpkg: error processing evolution-data-server-dev (--configure):
     dependency problems - leaving unconfigured
    dpkg: too many errors, stopping
    Errors were encountered while processing:
     sudo
     osso-af-startup
     desktop-file-utils
     shared-mime-info
     libosso-gnomevfs2-common
     hildon-update-category-database
     libhildonmime0
     libhildonfm2
     hildon-initscripts
     maemo-launcher
     osso-app-killer
     hildon-control-panel
     hildon-desktop
     libosso-gnomevfs2-samba
     osso-af-sb-startup
     hildon-application-manager
     hildon-application-framework-packages
     hildon-application-framework
     libosso-gnomevfs2-dev
     osso-gnomevfs-extra-dev
     libhildonmime-dev
     libhildon-thumbnail-dev
     libhildonfm2-dev
     hildon-application-framework-dev
     osso-games-startup
     maemo-application-interface-dev
     maemo-core-runtime
     maemo-core-dev
     maemo-sdk-runtime
     maemo-sdk-dev
     libosso-gnomevfs2-0
     gnome-vfs-filechooser-backend
     gstreamer0.10-gnomevfs
     libhildonwm0
     libhildondesktop0
     libhildon-thumbnail0
     osso-gnomevfs-extra
     hildon-thumbnail
     hildon-thumbnail-libid3
     libhildondesktop-dev
     libhildonwm-dev
     hildon-desktop-dev
     maemo-mmf-runtime
     maemo-mmf-dev
     gconf2
     fontconfig
     libpango1.0-common
     libgconf2-dev
     libedataserver-dev
     libedata-book-dev
     evolution-data-server-dev
    Processing was halted because there were too many errors.
    E: Sub-process /scratchbox/devkits/debian-etch/bin/dpkg returned an error code (                                              1)
    E: Unable to install maemo-sdk-dev on CHINOOK_ARMEL target.
    E: Please check the sources.list for errors.
    E: Scratchbox login returned error 100.
    Last edited by ltomuta; 2008-05-18 at 08:38.

  2. #2
    Registered User
    Join Date
    May 2008
    Posts
    1

    Re: Problems about maemo 4.0.1 SDK installation.

    Try

    echo 4096 > /proc/sys/vm/mmap_min_addr

    as a root.

  3. #3
    Registered User
    Join Date
    Oct 2008
    Posts
    2

    Re: Problems about maemo 4.1.1 SDK installation.

    Quote Originally Posted by ajsmythe View Post
    Try

    echo 4096 > /proc/sys/vm/mmap_min_addr

    as a root.
    This is not doing it for me. I'm stuck, stuck, stuck.
    I think that this is my problem: "/scratchbox/tools/bin/sh: line 1: /usr/sbin/dpkg-preconfigure: No such file or directory"
    but I'm not certain.

    Here's the error I'm getting.

    Code:
    [sbox-DIABLO_ARMEL: ~] > fakeroot apt-get install maemo-sdk-runtime
    Reading package lists... Done
    Building dependency tree... Done
    The following NEW packages will be installed:
      maemo-sdk-runtime
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    27 not fully installed or removed.
    Need to get 0B/1890B of archives.
    After unpacking 32.8kB of additional disk space will be used.
    WARNING: The following packages cannot be authenticated!
      maemo-sdk-runtime
    Install these packages without verification [y/N]? y
    /scratchbox/tools/bin/sh: line 1: /usr/sbin/dpkg-preconfigure: No such file or directory
    Selecting previously deselected package maemo-sdk-runtime.
    (Reading database ... 16920 files and directories currently installed.)
    Unpacking maemo-sdk-runtime (from .../maemo-sdk-runtime_1.0_all.deb) ...
    Setting up gconf2 (2.16.0-1osso14) ...
    /scratchbox/tools/bin/chown: `messagebus:messagebus': invalid user
    dpkg: error processing gconf2 (--configure):
     subprocess post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of fontconfig:
     fontconfig depends on gconf2 (>= 2.6.0); however:
      Package gconf2 is not configured yet.
    dpkg: error processing fontconfig (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libosso-gnomevfs2-common:
     libosso-gnomevfs2-common depends on gconf2 (>= 2.6.0); however:
      Package gconf2 is not configured yet.
    dpkg: error processing libosso-gnomevfs2-common (--configure):
     dependency problems - leaving unconfigured
    ... (more of same with other packages)...
    dpkg: error processing maemo-system-sw-runtime (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     gconf2
     fontconfig
     libosso-gnomevfs2-common
     osso-gwconnect
     libosso-gnomevfs2-samba
     hildon-application-framework-packages
     hildon-application-framework
     libpango1.0-common
     maemo-connectivity-runtime
     maemo-sdk-runtime
     libosso-gnomevfs2-0
     gnome-vfs-filechooser-backend
     gstreamer0.10-gnomevfs
     libhildonwm0
     libhildondesktop0
     libhildon-thumbnail0
     libhildonmime0
     osso-gnomevfs-extra
     libhildonfm2
     maemo-launcher
     hildon-control-panel
     hildon-desktop
     hildon-thumbnail
     hildon-thumbnail-libid3
     hildon-application-manager
     hildon-plugins-settings-cpa
     maemo-mmf-runtime
     maemo-system-sw-runtime
    E: Sub-process /scratchbox/devkits/debian-etch/bin/dpkg returned an error code (1)
    Any ideas?

  4. #4
    Registered User
    Join Date
    Oct 2008
    Posts
    2

    Re: Problems about maemo 4.1.1 SDK installation.

    OK, problem solved now. Here are ALL the things that I did to get this working...

    Let us start with /etc/sysctl.conf
    add the lines

    Code:
        vm.mmap_min_addr = 4096
        net.ipv4.ip_local_port_range = 1024 65535
        vm.vdso_enabled = 0

    to this file. I recommend doing a search for each of those setting before you add the new lines. If you have the settings in there, comment them out, and then put the changed setting directly underneath with a comment about WHY you are doing this. (That's to save you heartache later if it breaks something else.)

    Next, I ran apt-get install -f in both my normal shell and in the scratchbox. I used apt-get autoremove to get rid of some no-longer-needed packages in my regular shell.

    Gnuton reported several problems and fixes and although I didn't have his 'messagebus:messagebus': invalid user problem I still did

    Code:
        cd /var/cache/apt/archives
        fakeroot dpkg -i *dbus*

    in the scratchbox, just in case.

    Finally, I followed his advice and did

    Code:
        cp /usr/sbin/dpkg-preconfigure /scratchbox/users/lisha/targets/DIABLO_ARMEL/usr/sbin

    and finally the &$%#! fakeroot apt-get install maemo-sdk-runtime worked.

Similar Threads

  1. SDK Installation/Verification Problems
    By beoweulf in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-12-22, 05:33
  2. Having Problems with .Net installation (S80 SDK)
    By lpinguin in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2006-11-28, 09:48
  3. Problems with NDS_symbian_ vs 1.1, cannot complied examples in SDK
    By dc-huang in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2006-11-22, 10:15
  4. sdk installation freezes on "3510i midp sdk 1.0.lnk"
    By dica_455 in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2005-08-29, 14:05
  5. 7710 SDK emulator browser problems
    By kipokipo in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2005-04-20, 12:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •