×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    May 2008
    Posts
    4

    Red face Problem with permission prompts!!

    Hello!

    I´m using the javax.microedition.location API to get GPS-positions. I want my application to get a new position each second. The problem is that each time the application tries to get a position I get a prompt asking if I want to give the program permission to get locations. I would want to be asked about this only once (or not at all).

    I have tried to instanciate all objects in the classes constructor, so this is done only once, but it seems that it is the methods that needs the permission and not the creation of the objects.

    I have also added the line:
    MIDlet-Permissions: javax.microedition.location.Location to both the .jad- and manifest-files and then signed the midlet using Sun Java Wireless Toolkit without any result.

    Is there a way to accomplish this? Any help would be greatly appreciated!

    /Oskar

  2. #2
    Nokia Developer Champion
    Join Date
    Nov 2007
    Location
    Rome, Italy
    Posts
    2,406

    Re: Problem with permission prompts!!

    Hi Oscar,

    Which certificate have you used to sign your midlet? On which phone are you testing? On some Nokias you need to manually change permission access level from application settings.

    Pit

  3. #3
    Registered User
    Join Date
    May 2008
    Posts
    4

    Re: Problem with permission prompts!!

    Thank you for your reply.
    However I figured the problem out.
    It was an uncaught SUE (StupidUserException).

    /Oskar

Similar Threads

  1. Problem with CAknDoubleStyleListBox with a CAknSearchField
    By jjig in forum Symbian User Interface
    Replies: 2
    Last Post: 2009-09-17, 00:58
  2. Problem with eglSwapBuffers and heap corruption
    By greatape in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-05-24, 03:35
  3. netcards - Problem with opening adapter
    By kernj in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-01-10, 08:56
  4. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36
  5. 7210 Silent Problem
    By MarkMckim in forum Mobile Java General
    Replies: 1
    Last Post: 2003-03-18, 12:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×