×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Apr 2008
    Posts
    12

    ensymble and pyc installation problem

    I wrote some code to test python modules on S60. One module is in compiled version module2.pyc format the other is pure script module1.py. When running in script shell it works ok.
    After packing into sis file (with ensymble) only module1.py module is visible. The module2.pyc file doesn't install at all. I tried to put it in resource folder manually using X-plore but it raises an error.

    Here is my ensymble file structure:

    Code:
    moduletest--|
                |-resource-|
                |          |-module2.pyc
                |-default.py
                |-module1.py
    Nokia E90 Symbian OS

  2. #2
    Super Contributor
    Join Date
    Oct 2007
    Location
    Deva, Romania
    Posts
    3,471

    Re: ensymble and pyc installation problem

    I've tried on my E90, PyS60 1.4.2, and it seems to work. The files are there.
    I used the exact same file structure you said, and made a sis of the folder containing the 3 files using Ensymble's simplesis. Is that what you did too?
    Last edited by bogdan.galiceanu; 2008-05-25 at 18:05.

  3. #3
    Registered User
    Join Date
    Apr 2008
    Posts
    12

    Re: ensymble and pyc installation problem

    In my case the problem is solved.
    I put all the files in single folder "moduletest" and after installation it works fine.
    When building sis files in the future I will put pyc libraries in both places.

Similar Threads

  1. Odd "needs to boot" problem 3rd
    By big_pig in forum Symbian
    Replies: 0
    Last Post: 2007-02-15, 15:36
  2. Ensymble and packaging 2 sis-files
    By big_pig in forum Symbian
    Replies: 4
    Last Post: 2007-01-27, 10:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×