×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    23

    getSpanshot(encoding=jpeg) does not work on series 40 phones

    We can click photos only on Nokia 60 series phones, on Nokia series 40 (2nd edition as well as 3rd edition) and Sony Ericsson and other makes we are only able to get the view finder but unable to click a photo. getSpanshot(...) method throws an exception

  2. #2
    Nokia Developer Champion
    Join Date
    Nov 2007
    Location
    Rome, Italy
    Posts
    2,406

    Re: getSpanshot(encoding=jpeg) does not work on series 40 phones

    As pointed out also on these threads:

    http://discussion.forum.nokia.com/fo...ad.php?t=99650
    http://discussion.forum.nokia.com/fo...d.php?t=133677

    on S40 you should use a different locator for capturing images (capture://image instead of capture://video that you use on S60).

    Pit

  3. #3
    Nokia Developer Expert
    Join Date
    May 2007
    Location
    Mexico D.F
    Posts
    351

    Re: getSpanshot(encoding=jpeg) does not work on series 40 phones

    Hello, try with this:

    locator: "capture://image" ...
    encoding: "enconding=image/jpg" (will not work on Wireless toolkit emulator... try s40 3ed emulator)

    you can know the allowed encodings by making a very simple midlet

    ----
    String s = System.getProperty("video.snapshot.encodings");
    Form f=new Form("codificacion");
    f.append(s);
    Display.getDisplay(this).setCurrent(f);

  4. #4
    Super Contributor
    Join Date
    Feb 2006
    Posts
    689

    Re: getSpanshot(encoding=jpeg) does not work on series 40 phones

    Hi,
    Check for another image formats.wich phone are u using
    thanks
    Thomas

Similar Threads

  1. Series 40 phones not responding to sendin SMS (WMAPI)
    By lekkie in forum Mobile Java Networking & Messaging & Security
    Replies: 2
    Last Post: 2007-06-01, 14:19
  2. Textfield bug in Series 60 phones?
    By seah_ky in forum Mobile Java General
    Replies: 1
    Last Post: 2005-10-25, 15:16
  3. Weird problems with Series 60 phones
    By TTSoB in forum Mobile Java General
    Replies: 1
    Last Post: 2005-01-21, 16:45
  4. "Application Error" on various Series 40 phones
    By BurakBayburtlu in forum Mobile Java General
    Replies: 3
    Last Post: 2004-08-27, 11:38
  5. Nokia series 40 phones: cctivating provisioned settings
    By seancronin in forum OMA DM/DS/CP
    Replies: 7
    Last Post: 2004-01-07, 17:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×