×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Feb 2008
    Posts
    21

    bug in camera.py?

    hello,
    I had several times the following error:

    Mod_python error: "PythonHandler AskinAjaxServer"

    Traceback (most recent call last):
    File "c:\resource\mod_python\apache.py", line 395, in HandlerDispatch
    result = object(req)
    File "C:/Data/Web server/htdocs/AskinAjaxServer/AskinAjaxServer.py", line 26, in handler
    result = hrh.handler(req)
    File "C:/Data/Web server/htdocs/AskinAjaxServer/AskinAjaxServer.py", line 55, in handler
    take_photo()
    File "C:/Data/Web server/htdocs/AskinAjaxServer/AskinAjaxServer.py", line 7, in take_photo
    img = camera.take_photo(size = (640,480))

    File "c:\resource\camera.py", line 101, in take_photo
    position))

    SymbianError: [Errno -5] KErrNotSupported

    after restarting the phone (N95) it worked fine! I have already read something about this error here in the forum, but I can`t find it at the moment! seems to be a bug!

    best regards,
    Askin

  2. #2
    Nokia Developer Moderator
    Join Date
    May 2007
    Location
    21.46 N 72.11 E
    Posts
    3,796

    Re: bug in camera.py?

    Quote Originally Posted by _Askin_ View Post
    hello,
    I had several times the following error:

    Mod_python error: "PythonHandler AskinAjaxServer"

    Traceback (most recent call last):
    File "c:\resource\mod_python\apache.py", line 395, in HandlerDispatch
    result = object(req)
    File "C:/Data/Web server/htdocs/AskinAjaxServer/AskinAjaxServer.py", line 26, in handler
    result = hrh.handler(req)
    File "C:/Data/Web server/htdocs/AskinAjaxServer/AskinAjaxServer.py", line 55, in handler
    take_photo()
    File "C:/Data/Web server/htdocs/AskinAjaxServer/AskinAjaxServer.py", line 7, in take_photo
    img = camera.take_photo(size = (640,480))

    File "c:\resource\camera.py", line 101, in take_photo
    position))

    SymbianError: [Errno -5] KErrNotSupported

    after restarting the phone (N95) it worked fine! I have already read something about this error here in the forum, but I can`t find it at the moment! seems to be a bug!

    best regards,
    Askin
    May be the camera was being used by other application(May be the default camera application that launched when you open the lens cover) at that time. And hence the error.

    This is just my opinion.

    Best Regards,
    Croozeus
    Pankaj Nathani
    www.croozeus.com

  3. #3
    Registered User
    Join Date
    Feb 2008
    Posts
    21

    Re: bug in camera.py?

    nope, the N95 has no lense cover and no other application was running! maybe its a problem of the N95 itself!

    regards,
    Askin

  4. #4
    Nokia Developer Moderator
    Join Date
    May 2007
    Location
    21.46 N 72.11 E
    Posts
    3,796

    Re: bug in camera.py?

    Quote Originally Posted by _Askin_ View Post
    nope, the N95 has no lense cover and no other application was running! maybe its a problem of the N95 itself!

    regards,
    Askin
    If you believe that its a Bug, you can report it here

    Best Regards,
    Croozeus
    Pankaj Nathani
    www.croozeus.com

  5. #5
    Registered User
    Join Date
    May 2008
    Posts
    8

    Re: bug in camera.py?

    You tried Run Camera.py in Your WebSite Host
    Master Coder!

  6. #6
    Registered User
    Join Date
    Feb 2008
    Posts
    21

    Re: bug in camera.py?

    Quote Originally Posted by cw2ebm View Post
    You tried Run Camera.py in Your WebSite Host
    I don`t know what you mean ...
    making photos via MWS environment works!

    @croozeus: you are right... the error occurs if camera is in use by an other application. BUT what application it is I don´t really know. maybe its when my application crashes etc. the camera application doesn´t exit correct...something like that I guess

    best regards,
    Askin

Similar Threads

  1. RecordStore bug on Series 60
    By ncerezo2 in forum Mobile Java General
    Replies: 21
    Last Post: 2009-11-26, 10:12
  2. Serious BUG in Nokia phones!!!
    By bartekn in forum Mobile Java Media (Graphics & Sounds)
    Replies: 10
    Last Post: 2004-03-28, 22:09
  3. A bug: setColor with offscreen graphics - PLEASE, REPLY THIS TIME
    By palmcrust in forum Mobile Java General
    Replies: 11
    Last Post: 2003-12-04, 12:43
  4. Firmware bug or code bug displaying list on 3650
    By blackjack75 in forum Mobile Java General
    Replies: 2
    Last Post: 2003-09-24, 19:52
  5. Replies: 8
    Last Post: 2003-07-11, 12:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×