×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    Registered User
    Join Date
    Mar 2006
    Posts
    107

    "Menu: feature not supported" caused by mediaclientaudio.lib??

    Hi, I'm having a lot of trouble getting a C++ application to work - on most phones we tried, trying to install the .sisx file would immediately display a "Menu: Feature not supported" message. I've now narrowed down the cause of the error to including mediaclientaudio.lib in the application. Without this library, the app installs fine. As soon as it is added to the MMP file the feature not supported message reappears.

    Strangely, it always installs with no problems on the two N95s I've got (one is 1st gen, the other is a new 8GB version), but it's also been tried on a 3250, 6120, 5500, plus a Samsung i550 and an LG KS10, all of which give "Feature not supported". I'm hoping to try it on an N76 later today and an N91 tomorrow, but I'd really like to get this fixed ASAP. Does anyone know what can be causing this, and why it doesn't seem to affect the N95s?

    I'm using Carbide 1.3 with the 3rd Edition MR SDK.

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,689

    Re: "Menu: feature not supported" caused by mediaclientaudio.lib??

    I do not have the other devices you mentionedhave , but "mediaclientaudio.lib" works for me on a 3250 - at least CMdaAudioPlayerUtility and CMdaAudioToneUtility.

  3. #3
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: "Menu: feature not supported" caused by mediaclientaudio.lib??

    You might want to make sure you have compiled the project with the 3rd Ed MR SDK, and not FP1 SDK.

  4. #4
    Registered User
    Join Date
    Mar 2006
    Posts
    107

    Re: "Menu: feature not supported" caused by mediaclientaudio.lib??

    Quote Originally Posted by symbianyucca View Post
    You might want to make sure you have compiled the project with the 3rd Ed MR SDK, and not FP1 SDK.
    Yes, I'm definitely using the MR SDK and not FP1. I wanted it to run on both MR and FP1 devices so I thought that was the right thing to do. It certainly works fine on both types of N95.

  5. #5
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,689

    Re: "Menu: feature not supported" caused by mediaclientaudio.lib??

    Quote Originally Posted by andrew_ramsay View Post
    Yes, I'm definitely using the MR SDK and not FP1. I wanted it to run on both MR and FP1 devices so I thought that was the right thing to do.
    Jukka has not questioned your intents, he suggested that you should make sure that you have really used the MR SDK.
    It certainly works fine on both types of N95.
    Those are FP1 devices.

  6. #6
    Registered User
    Join Date
    Mar 2006
    Posts
    107

    Re: "Menu: feature not supported" caused by mediaclientaudio.lib??

    Quote Originally Posted by wizard_hu_ View Post
    Jukka has not questioned your intents, he suggested that you should make sure that you have really used the MR SDK.
    Yes, I understand. I've doublechecked that the 3rd ED MR SDK is the only one selected in Carbide, the only build configurations for the app are 3rdEDMR configurations, there are no FP1 SDK directories in my path, "devices" shows 3rd ED MR as the default...I don't know what else I can do to make sure!

    Quote Originally Posted by wizard_hu
    Those are FP1 devices.
    So are some of the other phones the app has refused to install on, that's why I'm so confused about this. There doesn't seem to be any pattern to when it works and when it doesn't.

  7. #7
    Registered User
    Join Date
    Mar 2006
    Posts
    107

    Re: "Menu: feature not supported" caused by mediaclientaudio.lib??

    Just tried it on an N76, no problems. Hoping to try an N91 tomorrow which I believe is a 3rd Ed MR device. If anyone has any suggestions before then I'll be glad to try them out.

  8. #8
    Registered User
    Join Date
    Mar 2006
    Posts
    107

    Angry Re: "Menu: feature not supported" caused by mediaclientaudio.lib??

    Well, it worked fine on the N91 as well. I have no idea what the hell is going on

  9. #9
    Super Contributor
    Join Date
    Nov 2004
    Location
    Wiltshire, UK
    Posts
    3,644

    Re: "Menu: feature not supported" caused by mediaclientaudio.lib??

    As a matter of interest have you enabled extended error codes?
    http://wiki.forum.nokia.com/index.ph...ded_panic_code
    Download Symbian OS now! [url]http://developer.symbian.org[/url]

  10. #10
    Registered User
    Join Date
    Mar 2006
    Posts
    107

    Re: "Menu: feature not supported" caused by mediaclientaudio.lib??

    I saw that but didn't think it was worth trying as the error appears right at the start of the installation process. Still, I might as well try it. I'll post again with the results.

  11. #11
    Registered User
    Join Date
    Mar 2006
    Posts
    107

    Re: "Menu: feature not supported" caused by mediaclientaudio.lib??

    All that did was change the error from "Menu: feature not supported" to "Menu: feature not supported (-5)", and since -5 is KErrNotSupported that really doesn't help much :/

  12. #12
    Super Contributor
    Join Date
    Nov 2004
    Location
    Wiltshire, UK
    Posts
    3,644

    Re: "Menu: feature not supported" caused by mediaclientaudio.lib??

    I suggest you post your pkg file as I believe the problem is there
    Download Symbian OS now! [url]http://developer.symbian.org[/url]

  13. #13
    Registered User
    Join Date
    Mar 2006
    Posts
    107

    Re: "Menu: feature not supported" caused by mediaclientaudio.lib??

    Actually we decided to try a version compiled using the 3rd Ed FP1 SDK, and it now works normally on at least one of the phones where it previously failed (the LG KS10). No idea why.

    Here's the pkg file anyway, minus the comments. It was entirely autogenerated by Carbide 1.3 using the project creation wizard. The only thing I changed was to add the extra line for the defpm.mbm image file at the end, and that didn't seem to make any difference to whether it installed or not:
    Code:
    &EN
    #{"myapp"},(0xEA0D44CC),1,0,0
    %{"Vendor-EN"}
    :"Vendor"
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\myapp.exe"		-"!:\sys\bin\myapp.exe"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\myapp.r01"		-"!:\resource\apps\myapp.r01"
    "$(EPOCROOT)Epoc32\data\z\private\10003a3f\apps\myapp_reg.r01"	-"!:\private\10003a3f\import\apps\myapp_reg.r01"
    "$(EPOCROOT)epoc32\data\z\resource\apps\myapp_aif.mif" -"!:\resource\apps\myapp_aif.mif"
    "$(EPOCROOT)epoc32\data\z\resource\apps\myapp.mbm" -"!:\resource\apps\myapp.mbm"
    "$(EPOCROOT)epoc32\data\z\resource\apps\defpm.mbm" -"!:\resource\apps\defpm.mbm"
    I did do some reading about the pkg file format in case there was something wrong with it, but it looked OK as far as I could tell, and as I've said it installed fine on 3 different N-series phones.

  14. #14
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: "Menu: feature not supported" caused by mediaclientaudio.lib??

    if i am not wrong "Menu: feature not supported" cased when you try to load a DLL which is not available or some entry point in that DLL is not available on device.

  15. #15
    Registered User
    Join Date
    Mar 2006
    Posts
    107

    Re: "Menu: feature not supported" caused by mediaclientaudio.lib??

    That's what I thought, but most of the search results I could find about that error message described situations where it only appeared when you were actually running the installed application.

    In my situation it was appearing at the start of the installation process, presumably before any application code was executed.

    I didn't use any non-Symbian libraries - apart from the default set Carbide adds to a project, I only added edbms, mediaclientaudio and flogger, all of which should be available on every 3rd Edition device AFAIK.

Similar Threads

  1. Python S60 Emulator
    By NAYSAMBO in forum Symbian
    Replies: 25
    Last Post: 2009-04-08, 10:22
  2. "Menu: Feature not supported" message with N95
    By akhalaj in forum Symbian Tools & SDKs
    Replies: 6
    Last Post: 2008-05-23, 12:06
  3. "Menu: Feature not supported" on the device
    By janekw_ in forum Symbian
    Replies: 2
    Last Post: 2007-10-05, 12:10
  4. Replies: 0
    Last Post: 2006-10-21, 14:17
  5. Replies: 1
    Last Post: 2006-04-16, 12:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×