×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Regular Contributor
    Join Date
    Nov 2007
    Posts
    159

    WebService cancelling problem

    Hi,

    I have used the wsdl2cpp tool to create a Web Service class.
    I'm calling the generated class's asynchronous method. It works fine when server replies and when server refuses connection.

    Problem starts when server doesn't reply at all (timeout). In this case I never get a response. So I've placed a timer, and when it pops up, I'm deleting the generated class. Then the generated class gets stuck when its destructor tries to delete the CSenServiceConnection member:

    Code:
    CLoginConnectService::~CLoginConnectService()
    {
        if (iOwnsConnection)
        {
        	delete iConnection; // <== This line never returns
        }    
        Xsd::SenOps::DestroySanyi();
    }
    I've tried also calling iConnection->Cancel() before deleting, but then it gets stuck on the Cancel() line:

    Code:
    CLoginConnectService::~CLoginConnectService()
    {
        if (iOwnsConnection)
        {
        	iConnection->Cancel(); // <== This line never returns
        	delete iConnection;
        }    
        Xsd::SenOps::DestroySanyi();
    }
    Also tried calling iConnection->TransactionCompleted(), but this got stuck too:

    Code:
    CLoginConnectService::~CLoginConnectService()
    {
        if (iOwnsConnection)
        {
        	iConnection->TransactionCompleted(); // <== This line never returns
        	delete iConnection;
        }    
        Xsd::SenOps::DestroySanyi();
    }
    Can this be fixed?

    Thanks,
    Nadav

  2. #2
    Regular Contributor
    Join Date
    Nov 2007
    Posts
    159

    Re: WebService cancelling problem

    Guys, anyone knows the answer? There must be one, because this is so basic. Surely Nokia wouldn't have published a communication package that cannot handle timeout, right?

  3. #3
    Registered User
    Join Date
    Mar 2008
    Posts
    1

    Re: WebService cancelling problem

    Bump. I have same problem.

  4. #4
    Regular Contributor
    Join Date
    Jul 2008
    Posts
    120

    Re: WebService cancelling problem

    Quote Originally Posted by niko.v View Post
    Bump. I have same problem.
    Hi Niko,

    The only way I've managed to solve it was to implement WebServices myself. I've written a macro-based infrastructure that instead of automatically using the WSDL, requires the user to define the WebService in a special header file. The infrastructure then defines the required classes, and takes care of serialization, deserialization and transport (which uses an asynchronous method).

    Cheers,
    Nadav (the same as person as nadav70, only using my company's email)
    Last edited by nadav_smilansky; 2008-08-01 at 11:47.

  5. #5
    Regular Contributor
    Join Date
    Jul 2008
    Posts
    120

    Re: WebService cancelling problem

    And one thing more:

    Eventually, we've decided not to use WebServices, because it is very wasteful (it sends a lot of overhead data). Still I have the infrastructure, so if you like it, you can leave me an email and I will send you the source code.

    Cheers,
    Nadav

  6. #6
    Registered User
    Join Date
    Jun 2008
    Posts
    15

    Re: WebService cancelling problem

    Nadav,

    As we spoke, i am having this exact problem, but i realized that only happens in one of my phones: E61. Somehow i dont get any of these problems with other devices or the emulator.

    I tried to catch the error with a HandleError in my GUI, and nothing, no error, just hanging there...waiting for the connection to be closed/deleted.

  7. #7
    Regular Contributor
    Join Date
    Jul 2008
    Posts
    83

    Re: WebService cancelling problem

    I aslo met the same problem

    when I cancel the iConnection,it still send a message to the Server,how do you solve this problem? My email is s3922731@126.com

    Thanks,
    s3920209.

Similar Threads

  1. Webservice framework authentication problem
    By niemin78 in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2007-08-22, 10:57
  2. Replies: 0
    Last Post: 2007-08-20, 13:59
  3. Problem with eglSwapBuffers and heap corruption
    By greatape in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-05-24, 03:35
  4. netcards - Problem with opening adapter
    By kernj in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-01-10, 08:56
  5. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×