×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    May 2007
    Location
    Poland
    Posts
    606

    Camera Application Engine API vs sdk Camera API

    Hello,
    I need to use camera in my application. Actually i m using Camera Application Engine API which i have found on Wiki. I have no problem with it , seems to work properly. Problem is that it is not supported by the emulator so i can t check memory leaks on it.
    My question are:
    -Have you ever tried to check memory leaks in this API?
    -Which of these APIs would you recommend to use and why?

    Thanks in advance

    Nuker
    Last edited by nuker85; 2008-06-04 at 11:05.

  2. #2
    Regular Contributor
    Join Date
    Jan 2007
    Location
    Bangalore
    Posts
    285

    Re: Camera Application Engine API vs sdk Camera API

    In ImageReady() Function there is a parameter HBufC8* aData,you need to delete this after use. Other than this check for objects or Heap Variables that have been created and Destroy them.


    Regards
    Shashi Kiran G M

  3. #3
    Regular Contributor
    Join Date
    Jan 2008
    Location
    Edinburgh, UK
    Posts
    100

    Re: Camera Application Engine API vs sdk Camera API

    Quote Originally Posted by gmsk19 View Post
    In ImageReady() Function there is a parameter HBufC8* aData,you need to delete this after use. Other than this check for objects or Heap Variables that have been created and Destroy them.


    Regards
    Shashi Kiran G M
    I believe this was corrected for the latest version, along with a couple more mem leaks.

    Edit: Related post

    Andy.
    Did I just say that out loud?

  4. #4
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: Camera Application Engine API vs sdk Camera API

    No, you still need to delete the pointer - the API hasn't been changed it's the example code that has been fixed.

    Sorcery

  5. #5
    Registered User
    Join Date
    Sep 2007
    Posts
    29

    Question Re: Camera Application Engine API turning camera ON bt not showing any frames on main

    HI I am using same camera engine API actually i have integrated this application with Helloworld applcation from examples of series 60 3rd Edition. Now camera is getting turned on but it is not showing any frames on screen (screen is blank but camera light is turned ON) what to do in this scenario??
    Please Help me

  6. #6
    Registered User
    Join Date
    May 2007
    Location
    Poland
    Posts
    606

    Re: Camera Application Engine API vs sdk Camera API

    hello,
    have you called InitL function of cam engin?
    you could also try the new-fileservice API, which is included in the API plug-in (you can find it on wiki)

    good luck

Similar Threads

  1. PC Suite error: (Code: Init IMediaControl2) HELP?!
    By chunkyspudmonkey in forum General Development Questions
    Replies: 29
    Last Post: 2008-06-30, 11:47
  2. Replies: 2
    Last Post: 2008-04-03, 19:02
  3. Replies: 2
    Last Post: 2006-09-13, 09:04
  4. Is it possible to develop camera application with sdk v2.0
    By ckt in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2006-09-13, 08:07
  5. BUG IN 7650 Camera API???
    By jjclose in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2003-09-28, 16:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×