×

Discussion Board

Results 1 to 13 of 13
  1. #1
    Registered User
    Join Date
    Jun 2008
    Posts
    3

    Unhappy Problems with Carbide.ui for 5th edition LT

    Carbide doesn't seem to produce correct themes for S40 phones with 5th Edition LT platforms like the 2630.

    My 2630 is a (S40 5th Ed LT) capable of using v3.0 themes with a few exceptions like solid colors instead of images for "Menu Item Highlight"(MIH) and "Select Form Item Highlight"(SFIH). However when I create a v3.0 theme, it reverts to the default color for the "MIH" but keeps my custom colors for the "SFIH". IF I create a v2.0 theme it keeps my custom colors for the "MIH" and reverts to default colors for the "SFIH".

    There are a few other problems like the clock color is custom in the Idle Screen but reverts to default colors in the Main Menu. This happens in both v2.0 and V3.0 themes.

    Is there a way to fix these problems or at least merge the working parts for the "MIH, SFIH" problem from the v3.0 and v2.0 theme?

  2. #2
    Registered User
    Join Date
    Nov 2007
    Posts
    39

    Re: Problems with Carbide.ui for 5th edition LT

    3.0 and 2.0 formats are different. There is no way to merge these in the tool.

    The SFIH is a image skinnable item. How did you colorize it? Did you select an image of a single color?

    Also, which Menu Item Highlight did you skin? For example, I see grid, list, tab etc., in the tool.

    On the resources view, you may look at "Colors" option and skin the elements there. This should help you colourize the text elements.

    As for the clock is concerned, there are known issues with only the idle screen. It seems to be working on other screens.
    Last edited by vvtesh; 2008-06-06 at 12:47.

  3. #3
    Registered User
    Join Date
    Jun 2008
    Posts
    3

    Re: Problems with Carbide.ui for 5th edition LT

    Thanks for your reply,
    In General my 2630 does not render any custom images I set for Form Highlights, List View Highlights or Grid View Highlights. It instead renders a color which I can set under the Color Options. However only the Form and Grid View has the option to set that custom color. The List View does not allow me to change the highlight color.

    For the Select Form Item Highlight (SFIH):
    Under Resources, Apps, Forms, Colors I can set the color for "Un/Selected Form Item Color". The phone highlights the forms using these colors rather than rendering any custom images I set for the "Selected Form Item Highlight" item.

    Likewise, in Grid View there is a "Grid Menu Highlight Color" and so my phone renders that custom color for Grid View Highlights.

    However in List View there is no such Color option for setting a "List Menu Highlight color". I can only change the Font Colors and so the Nokia renders the highlight with a default blue color.

    I'm guess that the 2630 doesn't render images for highlights because its listed on the nokia site as "S40 5th ed LT"; the operative word there being "LT". Or should the 2630 actually be able to render images for highlights and my phone is actually slightly broken.

    If my phone isn't broken then shouldn't Carbide.ui at least let me set the color for my list view highlight. (Assuming there isn't a option i have missed some where)

  4. #4
    Regular Contributor
    Join Date
    Sep 2006
    Posts
    214

    Re: Problems with Carbide.ui for 5th edition LT


    What happens if you save your theme as "Series 40 Theme v3.0 light" in CarbideUI 3.2.1.0? Does that make any difference?
    (To be honest, I'm curious myself if this is the correct option for LT phone themes but I haven't got the appropriate phone to test that, I hope you don't mind.)

  5. #5
    Registered User
    Join Date
    Nov 2007
    Posts
    39

    Re: Problems with Carbide.ui for 5th edition LT

    Some phones allow for further optimizations (for example, the bmp, jpg images are converted to a proparietary format) through the 3.0 light format. Hence this option is present in the tool.

    In the case of 2630, I am not sure if the 3.0 light format can help. It's just that only limited elements are skinnable (those that are available on the resources view). In this case, list view highlight is only image skinnable in the tool. There are no options to associate a color. I have not personally tested the image skinning on 2630 and assume from this discussion that it is not working for 2630.

  6. #6
    Registered User
    Join Date
    Jun 2008
    Posts
    7

    Re: Problems with Carbide.ui for 5th edition LT

    Hello,

    I'm facing the exact same problem with my 2630 - though creating a package using the "v.3.0 LT" option results in a theme which is only 1 kb in size (?) and does not include any custom content (?) - so it seems this is not the right option to choose...

    It simply seems as if carbide.ui does not support the more simple s40 5th light themes...

    Furthermore, why doesn't carbide.ui include the standard screensavers (analog/digital clocks)? They are simply not there - i.e. activating them within the display options is possible - yet nothing happens after the time ran out...

    Kind regards,
    Sebastian

  7. #7
    Regular Contributor
    Join Date
    Sep 2006
    Posts
    214

    Re: Problems with Carbide.ui for 5th edition LT


    Hmmm, it seems that there's something wrong with your CarbideUI. When I try to create a v3.0 light theme, the size of the theme file is ok and the theme includes all components I inserted. Perhaps reinstallation could solve the prob.

  8. #8
    Registered User
    Join Date
    Jun 2008
    Posts
    7

    Re: Problems with Carbide.ui for 5th edition LT

    Hello,

    reinstallation did not solve the problem with the LT themes - well I should say I'm currently running version 3.2 of the tool - I will download/install and try the whole thing using version 3.2.1 - whoever this will not solve the initial problem with the highlight components - the question is: how did Nokia set the colours for the highlight-elements in the themes that come with my phone ? (for example in the dandelion.nth they are all green...) - so there must be a way - somehow...

    Still no solution for the missing clocks...

    Kind regards,
    Sebastian
    Last edited by theiss2003; 2008-06-09 at 20:10.

  9. #9
    Registered User
    Join Date
    Jun 2008
    Posts
    7

    Re: Problems with Carbide.ui for 5th edition LT

    Update: Sorry - my fault - yes the screensavers are there and working ;-)
    The timout was set to 10:00 instead 01:00 - my fault ;-)

    Beeing the highlight elements the last problem to solve.

    Kind regards,
    Sebastian

  10. #10
    Registered User
    Join Date
    Jun 2008
    Posts
    3

    Re: Problems with Carbide.ui for 5th edition LT

    Is there a way to pull the dandelion.nth off the phone so at least we can open it to see what elements they are setting for the list highlight color? At least then we might be able to set the colors manually ourselves.

    Also the 2630 cannot seem to handle the image format used by v3.0 light themes.

    btw thesis2003 if you create a v2.0 theme using Theme Studio 2.2, you can set the list and grid view highlight colors but not for the forms highlight colors. At best it is a give and take.

  11. #11
    Registered User
    Join Date
    Jun 2008
    Posts
    7

    Re: Problems with Carbide.ui for 5th edition LT

    Hi there,
    sorry - there's no way to pull the dandelion theme off the phone - as it is copy protected (like all the default themes)

    But anyway:

    I HAVE FOUND THE SOLUTION:

    I simply went trough all the elements in the tree and changed ALL colors which show the default bright blue to the one I want to have for the highlight elements - exported to v.2.0
    - and it works - all highlight elements now have the same color - list, grid, list-reorder....
    (even including the small one in the calendar which highlights the current day) ;-)
    The form can also be edited - hence carbide.ui does not offer a live-preview of those changes.

    Kind regards,

    Sebastian

  12. #12
    Regular Contributor
    Join Date
    Sep 2006
    Posts
    214

    Thumbs up Re: Problems with Carbide.ui for 5th edition LT


    theiss2003, thanks for sharing this result of your CarbideUI experiments.

  13. #13
    Registered User
    Join Date
    Jul 2008
    Posts
    1

    Re: Problems with Carbide.ui for 5th edition LT

    Quote Originally Posted by theiss2003 View Post
    there's no way to pull the dandelion theme off the phone
    MobiMB (http://www.logomanager.co.uk/php/products.php?id=51) can do it with easy.

    Quote Originally Posted by theiss2003 View Post
    I HAVE FOUND THE SOLUTION ... even including the small one in the calendar which highlights the current day
    No need to change ALL of colors: List View Highlight Color determined through "Calendar Highlight Color" property.

Similar Threads

  1. Problems about maemo 4.0.1 SDK installation.
    By fgg_maemo in forum General Development Questions
    Replies: 3
    Last Post: 2008-10-07, 14:26
  2. Carbide.ui S60 Theme Edition 3.1
    By kman888 in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 3
    Last Post: 2008-05-04, 09:40
  3. Icon problems in 3rd edition
    By rihoe in forum Symbian
    Replies: 1
    Last Post: 2006-09-05, 15:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •