×

Discussion Board

Results 1 to 11 of 11
  1. #1
    Registered User
    Join Date
    Apr 2008
    Posts
    11

    rtsp streaming!!! receieve packet but can't play????

    m trying to implement the rtsp protocol using j2me.. m using quicktime streaming server in MacOS as server.... also m using S60 3rd edition fp2 beta emulator....

    I got the packets from the server... but the display isn't startin.... is it the beta emulator problem??? i've created the form to display the video but still no luck... IF ANYONE HAS WORKED IN THIS FIELD... ANY SUGGESTION WOULD BE APPRECIATED...

    PEACE

  2. #2
    Nokia Developer Champion
    Join Date
    Nov 2007
    Location
    Rome, Italy
    Posts
    2,406

    Re: rtsp streaming!!! receieve packet but can't play????

    Try posting some relevant code, so it'll be easier to find out possible issues with it.

    Pit

  3. #3
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: rtsp streaming!!! receieve packet but can't play????

    RTSP streaming did not work correctly on S60 3rd Edition and 3rd Edition FP1 emulators. I have not tested on S60 3rd Edition FP2 emulator, though...

    Hartti

  4. #4
    Registered User
    Join Date
    Apr 2008
    Posts
    11

    Re: rtsp streaming!!! receieve packet but can't play????

    Sorry had exams so couldn't be in touch.....

    To: jappit

    Thnx, And ya m using the tutorial given from

    http://today.java.net/pub/a/today/20...g-java-me.html

    which tells us how to write a rtsp protocol handler...
    if u come to know where the bug lies plz let me know..

    To : Hartti

    Thnx, i tried it in Nokia E51, but still no video... m still working on it... plz if u come to know anything about plz do let me know...

  5. #5
    Registered User
    Join Date
    Apr 2008
    Posts
    11

    Re: rtsp streaming!!! receieve packet but can't play????

    Hartti... thnx a lot... it worked with the E51.... ur link worked too.. that finnish video....

    PEACE

  6. #6
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: rtsp streaming!!! receieve packet but can't play????

    Just to update this thread with a tidbit. I just read the S60 3rd Edition FP2 SDK release notes and it stated that RTSP is not supported on that SDK either.

    Hartti

  7. #7
    Registered User
    Join Date
    Jun 2008
    Posts
    3

    Unhappy Re: rtsp streaming!!! receieve packet but can't play????

    I have a similar problem with my application: when the midlet was trying to open a rtsp streaming file, the player only showed a frame and the played failed.

    I would like to know what is the possible reason of this situation, because the application runs perfect a 3gp file when the file is called fron a http web address "http://www.xxx.com/somefile.3gp"

    a part of the code is:



    myPlayer = Manager.createPlayer(videoName);
    myPlayer.addPlayerListener(this);
    myPlayer.realize();
    myPlayer.prefetch();
    myPlayer.start();

    vc = (VideoControl)myPlayer.getControl("VideoControl");
    if (vc != null) {
    mainForm.deleteAll();
    mainForm.append((Item)vc.initDisplayMode(vc.USE_GUI_PRIMITIVE, null));
    vc.setDisplaySize(176, 144);
    myDisplay.setCurrent(mainForm);
    }

  8. #8
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: rtsp streaming!!! receieve packet but can't play????

    WHich phone are you running this on?
    Have you configured the RealPlayer default access point?
    If you have threads in the MIDlet, are you using yields or sleeps?

    Hartti

  9. #9
    Registered User
    Join Date
    Jun 2008
    Posts
    3

    Re: rtsp streaming!!! receieve packet but can't play????

    Quote Originally Posted by hartti View Post
    WHich phone are you running this on?
    Have you configured the RealPlayer default access point?
    If you have threads in the MIDlet, are you using yields or sleeps?

    Hartti
    I had proved the midlet over a nokia 3500,nokia 6500 and a sony sericsson s500i; the default access point had been configurated by the mobile operator, and the threads use yields

  10. #10
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: rtsp streaming!!! receieve packet but can't play????

    Could you try with lower bitrate (lower framerate and resolution)?

    Hartti
    Last edited by hartti; 2008-07-07 at 23:39. Reason: typo

  11. #11
    Registered User
    Join Date
    Jun 2008
    Posts
    3

    Re: rtsp streaming!!! receieve packet but can't play????

    Quote Originally Posted by hartti View Post
    Could you try with lower bitrate (lower framerate and resolution)?

    Hartti
    I don´t think that the lower bitrate could be the problem because the video can watch on the default multimedia and it has a low bitrate(64kbps). It could be the player tries to keep open a rtsp connection and when the connection fail, the player finish.

Similar Threads

  1. j2me streaming
    By FLO334 in forum Mobile Java Media (Graphics & Sounds)
    Replies: 80
    Last Post: 2010-10-13, 10:36
  2. Handsets that support rtsp Video Streaming
    By dodsworthtx in forum Streaming and Video
    Replies: 3
    Last Post: 2008-04-22, 04:28
  3. RTSP video streaming issue on 6280
    By olivier_irac in forum General Development Questions
    Replies: 0
    Last Post: 2006-12-04, 15:11
  4. Problem with rtsp streaming
    By b3orn in forum Mobile Java Media (Graphics & Sounds)
    Replies: 1
    Last Post: 2006-11-03, 18:38
  5. Realone RTSP streaming and NAT traversal
    By fugocheng in forum Streaming and Video
    Replies: 0
    Last Post: 2005-06-17, 07:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×