Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Mar 2006
    Location
    Romania
    Posts
    13

    Loading HTTPFilter issue

    Hello,

    I am writing a HTTPFilter, and I want to load it only if some condition are meet.

    How can I do this? Is this possible?

    Thanks!

  2. #2
    Registered User
    Join Date
    Feb 2007
    Location
    Tampere
    Posts
    370

    Smile Re: Loading HTTPFilter issue

    Regards

    - MVP
    "Dare To Dream" - A.P.J.Kalam

  3. #3
    Registered User
    Join Date
    Mar 2006
    Location
    Romania
    Posts
    13

    Re: Loading HTTPFilter issue

    Thanks for your answer!

    I already looked over that link. I'm using:

    "HTTP/-FILTERNAME: The filter is not loaded unless the client adds it", in the resource file of the HTTPFilter.

    But how can I load it now?

    How to "add it" from the client(my application in this case)?

    I don't want the filter to be always loaded into a http transaction.

  4. #4
    Super Contributor
    Join Date
    Nov 2004
    Location
    Wiltshire, UK
    Posts
    3,644

    Re: Loading HTTPFilter issue

    You must have an http session somewhere, so add it to the FilterCollection of the http session object.

    See RHttpSession.FilterCollection().AddFilterL
    Download Symbian OS now! [url]http://developer.symbian.org[/url]

Similar Threads

  1. MovieClipLoader loadClip: issue while loading images
    By jappit in forum [Archived] Flash Lite on Nokia Devices
    Replies: 2
    Last Post: 2008-04-21, 10:12
  2. Compilation series 60 3rd edition
    By asmobease in forum Symbian Tools & SDKs
    Replies: 32
    Last Post: 2006-09-13, 09:46
  3. Compilation series 60 3rd edition
    By asmobease in forum Symbian
    Replies: 3
    Last Post: 2006-09-10, 14:08
  4. Replies: 2
    Last Post: 2003-04-21, 01:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×