×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Regular Contributor
    Join Date
    Jun 2008
    Posts
    59

    Problems with the update.

    Hello,

    The game 4 in a row dose not work after the site and client update. I tried to to publish the newer version (Ver 1.2) which also dose not work. Both versions lock after entering the game. I could not test it properly as I don't have two phones. I will try to get another one today and give you some more details about the fault.

    Have you got any suggestions? I am using Chanel API and some other standard interfaces in the game.

    Another thing is that the game also dose not have a Beta sicker on it while in the minimized view and that I can not unpublish my widgets.

    Error: $("unpublish_confirm") has no properties
    Source File: javascript:alert('TODO: FIXME')
    Line: 0


    Thanks for your help.

    Klen

  2. #2
    Regular Contributor
    Join Date
    Jun 2008
    Posts
    59

    Re: Problems with the update.

    Seams like I fixed the problem. It was a null pointer exception that occurred when you clicked the Back option. Still need to test it with two phones before I upload the new version.

    Klen

  3. #3
    Regular Contributor
    Join Date
    Jun 2008
    Posts
    59

    Re: Problems with the update.

    Got another phone and tried it out. The game 4 in a row dose not work on the new client 3.0 .

    The first problem is that the player.stop() function call results in an exception error. Before the player is stopped it is checked for not being null. However it might be called even though it is not playing at the moment. The 2.0 client did not have problems with this. I temporarily removed all game sounds and solved this exception error but the game still dose not work because of the Channel API problems.

    The messages don't get delivered to the destination. The hack of sending empty messages dose not work on 3.0 version. With the messages the memberCallback's also don't get called when a member leaves or joins the channel.

    Were there any big changes made to the Channel API? I only tested this using the our university WLAN network that has a very complicated configuration and might also play a role, but it worked fine before. Looking forward to getting the new SDK on Monday to hopefully solve these problems. If you have any suggestions about the reasons for theses problems, please share them with me.

    I will change the icon of the game to notify the users that the game only works with the client 2.0.

    Thx for any suggestions.

    Klen

  4. #4
    Regular Contributor
    Join Date
    Jun 2008
    Posts
    59

    Re: Problems with the update.

    Me again,

    Tried to fix the problem with the new SDK, but it seams like the new client dose not support Channel API properly. When the message is sent to only one member, the log suggests that such service is not supported.

    18:09:14.451: handleRequest: mango.a/11a49973bf5 channel/push/msg
    18:09:14.451: NoSuchService: channel/push/msg


    Is it really so?

    Hoping for any suggestions.

    Klen

  5. #5
    Registered User
    Join Date
    Nov 2004
    Location
    Finland, Espoo
    Posts
    5

    Re: Problems with the update.

    Yeah,

    Unfortunately the channel support broke (read: was forgotten) during the client refactoring. Being more like alpha feature it's not part of our usual test cases. Blame me!

    Fixed today.

    --jkl

    PS. Really nice widget!

  6. #6
    Registered User
    Join Date
    Nov 2004
    Location
    Finland, Espoo
    Posts
    5

    Re: Problems with the update.

    By the way, there is potential (subtle) bug on the widget:

    When channel is initially opened using openChannel() you pass 1 second timeout as channel grace period argument.

    However, since opening and joining channel is separate operation it is possible the server decides to remove the channel before the first player has a chance to join the channel.

    I'd recommend increasing the channel timeout, e.g. to 60 seconds.

    Added note about this to API docs.

    --jkl

  7. #7
    Super Contributor
    Join Date
    May 2008
    Location
    Helsinki, Finland
    Posts
    1,100

    Re: Problems with the update.

    Hi all,

    Klen - Thank you for your email to me earlier, regarding this issue.

    After I had discussed with Render, I noticed that JKL (both
    currently work within WidSets) had made a fix and posted a reply, so a big Cheers! to them guys both.

    The main thing here was that we had now pinpointed the problem, made a fix and noted this for the testing of future SDK releases.

    Happy Midsummer, wherever You are

    http://virtual.finland.fi/netcomm/ne...ntNWSAID=26052

  8. #8
    Super Contributor
    Join Date
    May 2008
    Location
    Helsinki, Finland
    Posts
    1,100

    Re: Problems with the update.

    *duplicate message* sorry.
    Last edited by Maveric; 2008-06-20 at 08:41.

  9. #9
    Regular Contributor
    Join Date
    Jun 2008
    Posts
    59

    Re: Problems with the update.

    Hello guys,

    Thank you all for having a look into my problem. Is the update already available? I am planning to merge both version of the game into one soon.

    Jklehtim thanks for the bug report and feedback. I've set the timer to 60 seconds now.

    bye

    Klen

  10. #10
    Super Contributor
    Join Date
    May 2008
    Location
    Helsinki, Finland
    Posts
    1,100

    Re: Problems with the update.

    Quote Originally Posted by Klen View Post
    Hello guys,

    Thank you all for having a look into my problem. Is the update already available? I am planning to merge both version of the game into one soon.

    Jklehtim thanks for the bug report and feedback. I've set the timer to 60 seconds now.

    bye

    Klen

    Hi Klen,

    I have to consult Mr. JKL for the update and how/when that will be available. Today is the Midsummer holiday in Finland, so even I am writing this from home ...

    I will get the latest of this when JKL and others have returned from holidays on Monday. I guess we just have to wait until that. Sorry for the inconvenience.

    Have a nice weekend though!

    Regards,
    Marko
    [FONT="Comic Sans MS"][COLOR="Blue"][/COLOR][I]Marko Lumivuori
    Technical Support
    +358 40 8019330
    [email]marko.lumivuori@nokia.com[/email][/I][/FONT]

  11. #11
    Registered User
    Join Date
    Jun 2008
    Location
    Ostrava, Czech Republic
    Posts
    7

    Re: Problems with the update.

    Hi all,

    I would just add that there's one more widget waiting for the patch of Channel API. It is my multiplayer Tetrinet game here: http://www.widsets.com/widget/240181...=/widgets/beta.

    Well, I sincerely hope it will be fixed soon. Please let me know after it is done so that I could do some testing, too.

    Thanks!

    Jerry

  12. #12
    Regular Contributor
    Join Date
    Jun 2008
    Posts
    59

    Re: Problems with the update.

    Hello,

    Is the Channel API fixed in the new release? I tried it with the new SDK and it still is not working. I am again getting the NoSuchService in the log and the messages are not sent. It also dose not work on the phone client.

    Klen


    22:19:02.812: execute: T/11ae5a47a0e 2377345 dabo/getwidget
    22:19:02.875: handleResponse: T/11ae5a47a0e
    22:19:02.890: execute: T/11ae5a47a0f 2377345 dabo/getresources
    22:19:03.171: handleResponse: T/11ae5a47a0f
    22:19:03.265: Local code for four_in_a_row.hx
    22:19:03.734: 2
    22:19:03.796: execute: T/11ae5a47a10 2377345 channel/create/4_in_a_row
    22:19:03.843: handleResponse: T/11ae5a47a10
    22:19:03.859: execute: T/11ae5a47a11 2377345 channel/join/4_in_a_row
    22:19:03.937: handleResponse: T/11ae5a47a11
    22:19:13.937: execute: T/11ae5a47a12 2377345 channel/send/4_in_a_row
    22:19:13.984: handleRequest: mango.a/11ac8e2de06 channel/push/msg
    22:19:13.984: NoSuchService: channel/push/msg
    22:19:23.937: execute: T/11ae5a47a13 2377345 channel/send/4_in_a_row
    22:19:24.078: handleRequest: mango.a/11ac8e2de07 channel/push/msg
    22:19:24.078: NoSuchService: channel/push/msg

Similar Threads

  1. Problems about maemo 4.0.1 SDK installation.
    By fgg_maemo in forum General Development Questions
    Replies: 3
    Last Post: 2008-10-07, 14:26
  2. Problems after firmware update with Permissions
    By federico2929 in forum Symbian
    Replies: 1
    Last Post: 2007-07-14, 19:22
  3. Problems after software update....
    By iNdiSoUL in forum General Development Questions
    Replies: 1
    Last Post: 2007-04-11, 18:31
  4. Several problems with NMIT 4.1 MMS
    By jtalviva in forum General Messaging
    Replies: 0
    Last Post: 2006-03-10, 11:03
  5. Update on 6600 midi playback problems
    By marcpalmer in forum Mobile Java General
    Replies: 2
    Last Post: 2004-09-22, 17:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •