×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Regular Contributor
    Join Date
    Sep 2007
    Location
    BeiJing
    Posts
    52

    The issue of "Label not found"

    In the sample project "Helloworldbasic",I only added script codes about submenu as below
    RESOURCE MENU_PANE r_helloworldbasic_submenu
    {
    item =
    {
    MENU_ITEM
    {
    command = EHelloWorldBasicSB1;
    txt = "sub menu1";
    },
    MENU_ITEM
    {
    command = EHelloWorldBasicSB2;
    txt = "sub menu2";
    }
    };
    }
    Then,I run abld command "abld makefile vc6" and compiled entire project again in VC IDE.
    But it failed to compile.In output window,There was one compiling error "Label not found" in rss file and pointed to
    the code line 'RESOURCE MENU_PANE r_helloworldbasic_submenu'.Why and how to resolve it?Thanks for your time

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,748

    Re: The issue of "Label not found"

    Your code snippet has nothing wrong in itself. Can it happen that it accidentally appears inside an other resource (typically the preceding one)?
    Also note that if you apply [CODE ] and [/CODE ] tags (with removing the space after the closing bracket) in the post, your formatting of the code will be displayed.

  3. #3
    Nokia Developer Champion
    Join Date
    Oct 2006
    Location
    Bangalore, India
    Posts
    1,572

    Re: The issue of "Label not found"

    have you included all the resource basic files ?

    Code:
    #ifdef EKA2
    #include <appinfo.rh>
    #else
    #include <avkon.loc>
    #endif	//EKA2
    
    #include <eikon.rh>
    #include <avkon.hrh>
    #include <avkon.rsg>
    #include <avkon.rh>
    #include <avkon.mbg>
    #include "eikon.rsg"
    also given the name and charset ?

    Code:
    NAME ABCD
    CHARACTER_SET UTF8
    hope this helps !
    Amit Kankani
    Nokia Developer Champion

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,748

    Re: The issue of "Label not found"

    Amit: HelloWorldBasic already has a menu, so it should not need any new #include-s.

  5. #5
    Nokia Developer Champion
    Join Date
    Oct 2006
    Location
    Bangalore, India
    Posts
    1,572

    Re: The issue of "Label not found"

    thanks for the correction wizard_hu_

    well then my recommendation is try removing the MENU you have added and try the compilation once... if it succeeds, then the problem is right there in the code added, else it is elsewhere...
    Amit Kankani
    Nokia Developer Champion

  6. #6
    Super Contributor
    Join Date
    Nov 2004
    Location
    Wiltshire, UK
    Posts
    3,644

    Re: The issue of "Label not found"

    The compiler is correct, the label is not found.
    If you look in eikon.rh you will find the definition for MENU_PANE which defines.
    RESOURCE MENU_PANE r_helloworldbasic_submenu
    {
    item =

    should read
    RESOURCE MENU_PANE r_helloworldbasic_submenu
    {
    items =
    Download Symbian OS now! [url]http://developer.symbian.org[/url]

  7. #7
    Regular Contributor
    Join Date
    Sep 2007
    Location
    BeiJing
    Posts
    52

    Re: The issue of "Label not found"

    It was my mistake!Thanks for all of u.
    It indeed should be ITEMS not ITEM

Similar Threads

  1. Using Bluetooth serial port in MIDlets (nokia 9500 issue)
    By orsteglasy in forum Mobile Java Networking & Messaging & Security
    Replies: 11
    Last Post: 2007-10-07, 21:49
  2. issue with at+cusd over bluetooth link
    By hbanks in forum General Messaging
    Replies: 2
    Last Post: 2007-09-25, 21:21
  3. RTSP video streaming issue on 6280
    By olivier_irac in forum General Development Questions
    Replies: 0
    Last Post: 2006-12-04, 15:11
  4. Image Scaling/Sizing issue on the N70
    By sameet in forum Symbian Media (Closed)
    Replies: 0
    Last Post: 2006-07-24, 12:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×