×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Nov 2007
    Posts
    3

    xml2wbxml OTA problem

    Hi,

    My goal is to send a syncml ota sms setting to devices for auto config.

    I've managed to do the following:
    - create the syncml.xml file
    - convert it to syncml.wbxml using xml2wbxml
    - sending it over sms to my devices (nokia 6021,6085,n73)
    - saving and activating syncml-sms on my devices

    my problem is that when I try to sync I get an error that complain about invalid contact URI.
    I've looked into the sync profile (which was created my the received ota) in my n73 and found that the 'Remote Contact DB' is set to './contacts' instead of 'card'.

    my syncml.xml below define URI='./contact' and NAME='card'
    seems that the xml2wbxl encoder puts NAME='./contact'
    if I put URI='card' then the device sync profile shows 'Remote Contact DB'=card and the sync operation is running without any problem.
    But this fix-around is wrong and should NOT be like that.

    Any help is welcome

    <?xml version="1.0"?>
    <!DOCTYPE wap-provisioningdoc PUBLIC "-//WAPFORUM//DTD PROV 1.0//EN" "http://www.wapforum.org/DTD/prov.dtd">
    <wap-provisioningdoc version="1.0">
    <characteristic type="BOOTSTRAP">
    <parm name="NAME" value="test"/>
    </characteristic>
    <characteristic type="APPLICATION">
    <parm name="APPID" value="w5"/>
    <parm name="NAME" value="test"/>
    <parm name="TO-NAPID" value="INTERNET" />
    <parm name="ADDR" value="http://x.x.x.x" />
    <characteristic type="RESOURCE">
    <parm name="URI" value="./contacts"/>
    <parm name="NAME" value="card"/>
    <parm name="AACCEPT" value="text/x-vcard"/>
    </characteristic>
    <characteristic type="APPAUTH">
    <parm name="AAUTHNAME" value="test"/>
    <parm name="AAUTHSECRET" value="1234"/>
    </characteristic>
    </characteristic>
    </wap-provisioningdoc>

    * I get the same problem when using nowsms on XP

    Regards

    Assaf

  2. #2
    Registered User
    Join Date
    Jul 2008
    Posts
    14

    Re: xml2wbxml OTA problem

    Hi Adahary,
    I have same like issue . i have creates syncml.xml and then converted eith xml2wbxml and trnasfer to cell(N6600) but nothing happend only a white scree displyed on mobile seems browser...io also tryied with your xml file u mentioned below
    can you please explain how u transfer wbxml to mobhile (i am using bluetooth device)
    i dont know whats the problem ...please help

    i will be thankful to you.

Similar Threads

  1. Replies: 1
    Last Post: 2005-12-04, 12:01
  2. OTA Midlet-Install-Notify Problem
    By beyondtron@hotmail.com in forum Digital Rights Management & Content Downloading
    Replies: 0
    Last Post: 2005-05-16, 06:25
  3. OTA Message Reception Problem with Nokia 30
    By bjaags in forum Nokia M2M
    Replies: 0
    Last Post: 2003-08-03, 19:45
  4. OTA provisioning problem
    By baruchs in forum WAP Servers
    Replies: 2
    Last Post: 2002-10-11, 11:51
  5. Replies: 2
    Last Post: 2002-07-12, 08:19

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×