×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    11

    EAIF Emulator sockets

    I just wanted to verify that the Java EAIF emulator version 1.1 doesn't use SSL does it? I ask because when I send from the emulator to my application I seem to receive a stream of gibberish and when I send from my application to the emulator it completely ignores me.

    I've tested my application with my own test harness so I'm confident it's sending valid HTTP1.1 messages using plain ordinairy sockets.

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Location
    Texas, USA
    Posts
    260

    RE: EAIF Emulator sockets

    Hello

    You are correct, the Nokia MMSC EAIF Emulator version 1.1 does not use SSL. It accepts messages sent over HTTP1.1.

    Have you looked in the "MMSC EAIF User's Guide.pdf" which comes with the emulator? It has step-by-step instructions on how to set-up the EAIF.

    Some things you can do to troubleshoot:
    -Check that the settings in the "eaifem.properties" file match with your application address and port number.

    -Look for what the problem might be in log file at
    <MMSC EAIF Emulator directory>\bin\com\nokia\eaifem\eaifem.log

    -Make sure that the EAIF Emulator is set-up for "Originating Application" when you want to send MMS from your application.

    -Make sure that the EAIF Emulator is set-up for "Terminating Application" when you send to your application.

    Where are you getting the gibberish? In your application? What does the "Message Log" and "Message Details" of the EAIF say?

    If you still have a problem, you can post the errors from the Logs so that we can better help you.

    Good Luck and have fun!
    ~quyen

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×