×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Regular Contributor
    Join Date
    Jan 2007
    Location
    Bangalore
    Posts
    285

    WLAN Access point problem??

    Hi all,

    I am fetching the List of access points for the user to select an appropriate one before he logs into a server. This works fine with both WLAN and GPRS IAPs except that there is one minor glitch in WLAN IAPs i.e when i select a WLAN IAP it takes 3or 4 seconds for the dialog to disappear where as it takes only 1 sec for GRPS. Normally it should take only 1 sec for WLAN IAP selection too

    I am using RConnection and RSocketServ to fetch the access point list. Am i missing something??
    Regards
    Shashi Kiran G M

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: WLAN Access point problem??

    Quote Originally Posted by gmsk19 View Post
    ...
    Normally it should take only 1 sec for WLAN IAP selection too ...
    "Normally"? Where is this timing issue defined?

    Maybe if you would show some code and explain which dialog is not showing it would be more clear.

    Also, is the WLAN active (scanning for networks) at the time of testing or do you have to wait for the hardware to be powered-up, find the network and then connect?
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Regular Contributor
    Join Date
    Jan 2007
    Location
    Bangalore
    Posts
    285

    Re: WLAN Access point problem??

    Yes the WLAN is very much active. i dont have to wait for the hardware to start up. Here is the code that i use:

    RSocketServ sockserver;
    sockserver.Connect();
    RConnection connection;
    connection.Open(sockserver);
    TInt err = connection.Start();
    if(err != KErrCancel)
    {
    TUint actv;
    connection.EnumerateConnections(actv);
    TConnectionInfoBuf infBuf;
    err = connection.GetConnectionInfo(actv, infBuf);
    TUint selectedIAP = infBuf().iIapId;
    }
    connection.Stop();
    connection.Close();
    sockserver.Close();
    Regards
    Shashi Kiran G M

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: WLAN Access point problem??

    What is this code supposed to do and which dialog are we talking about?

    Why do you start -> enumerate -> stop the connection and where is the WLAN specific part?
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Regular Contributor
    Join Date
    Jan 2007
    Location
    Bangalore
    Posts
    285

    Re: WLAN Access point problem??

    The Code displays the IAP selection List Dialog consisting of both WLAN and GPRS IAP access point Names. When i select the WLAN Access point , there is some delay...

    selectedIAP gives me the selected Access point IAP number.
    Regards
    Shashi Kiran G M

  6. #6
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: WLAN Access point problem??

    Hmm, long time since I've looked into RConnection, but I was sure that there's an easier way to get to the IAP setting.

    Anyhow, you're not doing any filtering of the IAPs, nor can you in anyway impact the speed through which the code executes in various IAP selection scenarios. My advice is to ignore this delay issue.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  7. #7
    Regular Contributor
    Join Date
    Jan 2007
    Location
    Bangalore
    Posts
    285

    Re: WLAN Access point problem??

    hmm okies.. i wonder if there is way to filter out inactive IAPs??
    is there any??
    Regards
    Shashi Kiran G M

Similar Threads

  1. Error in Creating an WLAN access point
    By primal in forum Symbian Networking & Messaging (Closed)
    Replies: 3
    Last Post: 2008-01-16, 10:35
  2. WLAN WEPKey problem in firmware?
    By mikewen in forum OMA DM/DS/CP
    Replies: 0
    Last Post: 2006-12-28, 01:28
  3. Access Point Problem on Emulator
    By IlyaEck in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2004-09-06, 01:32
  4. Why is client code to CSocketEngine hanging at Access Point dialogue?
    By nawkboy in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2003-03-11, 11:16
  5. Replies: 0
    Last Post: 2003-02-24, 04:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×