×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Regular Contributor
    Join Date
    Feb 2008
    Posts
    52

    [moved] Single line text problem

    Hi,
    I want to create the single line numeric textbox in S60 3rd edition FP2.I wrote the following code in .RSS file but it is displaying
    multi line text box .Plz suggest me what change i should do i n the code.

    asap

    ///////////////////////////////////////////////////////////////////

    RESOURCE EDWIN r_MinuteMinder1_email_edwin
    {
    width = 0;
    lines = 1;
    maxlength = 2;
    allowed_input_modes = EAknEditorNumericInputMode;
    default_input_mode = EAknEditorNumericInputMode;
    }

    ///////////////////////////////////////////////////////////////

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,689

    Re: [moved] Single line text problem

    I am not sure if "lines" matter in this context (note that if it would matter, "width" would probably also matter, and you would get a 0 pixel wide invisible editor).
    What do you pass to SetSize/SetRect/SetExtent of your editor?

  3. #3
    Regular Contributor
    Join Date
    Feb 2008
    Posts
    52

    Re: [moved] Single line text problem

    Plz give me code for text box that will work for S60 3rd edition...

    Text box with just one line...

    Plz reply ASAP...

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,689

    Re: [moved] Single line text problem

    I do not have one here and now, though you have not really answered how you set the size of the editor. Note that many controls override CCoeControl::MinimumSize, thus you can try getting this from the editor control itself.

Similar Threads

  1. Error while making sis file
    By lalitjadiya in forum Symbian
    Replies: 9
    Last Post: 2008-05-20, 17:18
  2. Problem with ensymble_python2.5-0.26.py in linux
    By tansualpcan in forum Symbian
    Replies: 2
    Last Post: 2008-04-15, 10:12
  3. carbide c++ can't find headers.!!
    By nokia_maniac in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 29
    Last Post: 2007-12-19, 12:54
  4. carbidec++ helloworld project problem
    By akhin in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 0
    Last Post: 2007-03-11, 12:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×