×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    May 2008
    Posts
    22

    Question [moved] Exception in series 60 while running bluetooth application

    I have got an exception while trying to run my application on series 60 emulator. The exception is SymbianOS error = -5 : System:\nFeature is not supported. And the application is bluetooth application.So what I have to do to avoid this problem.

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: [moved] Exception in series 60 while running bluetooth application

    Well, there's nothing much you can do if a "Feature is not supported". The question is however what were you trying to do (i.e. which API call leaved with -5), on which SDK and were you really expecting for that thing to work? For example, have you installed the SDK BT driver and are able to otherwise activate the Bluetooth from within the emulator?
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    May 2008
    Posts
    22

    Question Re: [moved] Exception in series 60 while running bluetooth application

    I am working using S60_2nd_FP2_MIDP_SDK. And exception is showing when it runs throgh the codes ie localdevice = LocalDevice.getLocalDevice();
    discAgent = localdevice.getDiscoveryAgent();
    ie when we are starting to work with bluetooth then exception will occure....

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,675

    Re: [moved] Exception in series 60 while running bluetooth application

    Two things to note:
    - Lucian has already pointed out that if you are getting a "Feature not supported" message, the feature is not supported
    - you are apparently using a MIDP SDK, and you are apparently "speaking" Java. This section is called "Symbian C++", but if you click a few steps back on the top of this page, you will find "Mobile Java"

    Anyway, S60 2nd edition emulators are requiring rather special BT hardware (like a Casira module from CSR). The more recent emulators are less picky, you should check the possibilities in the documentation, the release_notes.txt, and perhaps on the SDK-download page.

Similar Threads

  1. Two bluetooth devices connecting same application
    By searchsid in forum Bluetooth Technology
    Replies: 2
    Last Post: 2007-05-21, 05:25
  2. Replies: 7
    Last Post: 2006-03-26, 18:25
  3. Unhandled Exception Error When Starting (MyView) application
    By mubx2000 in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2006-03-25, 10:33
  4. Replies: 0
    Last Post: 2004-10-31, 13:13
  5. Bluetooth Application Identifier Tool before Application is Installed on Series 60
    By asabagh in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2004-10-31, 13:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×