×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jun 2008
    Posts
    39

    My menus keep dissapearing

    Hi everyone,

    I am trying to build a simple UI for a s60 application,
    for example I am trying to display a simple menu to
    the user and everything goes OK, except when I load the emulator
    and click on the select sofkey the menu shows up as it is supposed to but if a select one of the options that show-up the
    emulator closes. I am using HandleCommandL(TInt aCommand)
    to deal with the various selections I just don't understand
    why the emulator closes.
    Which brings me to my second question.
    How do I debug applications for mobile phones.
    I am used to using GDB from eclipse but i have no idea what to do
    here, I am assuming you can't really use a debugger.
    Can someone give any suggestions or point out some tutorial
    somewhere.

    Thanks,
    Burim

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Re: My menus keep dissapearing

    Quote Originally Posted by Burim View Post
    ...
    How do I debug applications for mobile phones.
    I am used to using GDB from eclipse but i have no idea what to do
    here, I am assuming you can't really use a debugger.
    Can someone give any suggestions or point out some tutorial
    somewhere.

    Thanks,
    Burim
    You can of course use debugger within Carbide.c++. Put breakpoint on HandleCommandL() and start debugging.

    PS: I guess you are using Carbide.c++, aren't you?

    Kiran.
    Nokia Developer Wiki Moderation team

  3. #3
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,559

    Re: My menus keep dissapearing

    Quote Originally Posted by Burim View Post
    ..... and everything goes OK, except when I load the emulator
    and click on the select sofkey the menu shows up as it is supposed to but if a select one of the options that show-up the
    emulator closes. I am using HandleCommandL(TInt aCommand)
    to deal with the various selections I just don't understand
    why the emulator closes....
    Apart from Kirans advise of debugging, check if you have enabled extended panic code to get more info regarding the reason for crash. http://wiki.forum.nokia.com/index.ph...ded_panic_code

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,740

    Re: My menus keep dissapearing

    Quote Originally Posted by an other thread of yours
    - visit FN main site (www.forum.nokia.com), there are a lot of documents, Symbian documentation is under Documentation/Symbian C++ (on the left panel), there will also be a Getting started section.
    you can encounter "On-device debugging with Carbide.c++ Screencast v1.1", the second article on that page. It also shows debugging in the emulator as a starter.

Similar Threads

  1. 2 menus in 1 app
    By cfirpo in forum Symbian
    Replies: 4
    Last Post: 2007-04-20, 13:12
  2. svg menus
    By Larry101 in forum Mobile Java General
    Replies: 0
    Last Post: 2007-03-06, 08:44
  3. 7650 - looped menus
    By geran in forum Symbian User Interface
    Replies: 0
    Last Post: 2003-02-19, 08:25
  4. Replies: 1
    Last Post: 2002-05-29, 20:07
  5. Dynamic menus
    By lape07 in forum Bluetooth Technology
    Replies: 1
    Last Post: 1970-01-01, 02:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×