Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Jun 2008
    Posts
    4

    Can't locate the com/nokia/wtk/emulator/Emulator class

    Trying to install the S40 SDK with Eclipse, my MIDLet compiles fine, but when it tries to run the emulator I get "Can't locate the com/nokia/wtk/emulator/Emulator class". Can someone give me a hand? Thanks.

  2. #2
    Nokia Developer Expert
    Join Date
    Aug 2007
    Posts
    1,595

    Re: Can't locate the com/nokia/wtk/emulator/Emulator class

    Hello timnelson,

    here's a suggestion as a workaround: launch the emulator as a standalone and install the MIDlet using emulator's File->Open.. (=browsing the MIDlet's file path)

    Regards,
    r2j7
    [URL="http://library.forum.nokia.com/java"][B] >>> Java Developer's Library <<<[/B][/URL]
    [URL="https://www.developer.nokia.com/Resources/Support/Technical_support.xhtml"] [B]>>> Technical Support for Java ME development <<<[/B][/URL]
    [URL="https://publish.ovi.com/info/"][B]>>> Nokia Publish: reach millions of Nokia users worldwide through Nokia Store <<<[/B][/URL]

  3. #3
    Registered User
    Join Date
    Oct 2010
    Posts
    2

    Re: Can't locate the com/nokia/wtk/emulator/Emulator class

    我的英语不太好,我的也是出现Can't locate the com/nokia/wtk/emulator/Emulator class,这是怎么回事呀!谢谢!

  4. #4
    Registered User
    Join Date
    Oct 2010
    Posts
    2

    Re: Can't locate the com/nokia/wtk/emulator/Emulator class

    这个问题你怎么解决的呀,我是新手,说详细点,可以吗?

  5. #5
    Super Contributor
    Join Date
    Mar 2008
    Location
    The Capital of INDIA
    Posts
    4,328

    Re: Can't locate the com/nokia/wtk/emulator/Emulator class

    Quote Originally Posted by timnelson View Post
    Trying to install the S40 SDK with Eclipse, my MIDLet compiles fine, but when it tries to run the emulator I get "Can't locate the com/nokia/wtk/emulator/Emulator class". Can someone give me a hand? Thanks.
    Which emulator is this?

    I guess you are trying to run your application on the Sun Java WTK, in addition you can also tryintg to re-install the WTK and check the same.
    I guess you have install the WTK inside the SDK path of the Nokia SDK..
    Thanks with Regards,

    R a j - The K e r n e l


    Join Delhi-NCR Nokia Developer's Community,

Similar Threads

  1. locate phones through frequency
    By minky03 in forum Symbian Networking & Messaging (Closed)
    Replies: 11
    Last Post: 2007-08-20, 15:08
  2. Locate Me Service using GPS
    By rchaudhary in forum General Development Questions
    Replies: 1
    Last Post: 2006-12-23, 01:10
  3. Replies: 2
    Last Post: 2006-03-17, 20:20
  4. AIFBuilder: Unable to locate configuration files
    By jupitersp in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2003-04-27, 18:32
  5. unable to locate wsini.ini on device
    By abhishekmishra in forum Symbian
    Replies: 1
    Last Post: 2002-06-06, 09:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×