×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    May 2007
    Location
    India
    Posts
    197

    Thumbs down CVideoPlayerUtility:: OpenDesL Returns -5 error code

    Hello,

    When I try to play the video using buffer, i am getting -5 error code in MvpuoPrepareComplete.

    I am able to open the same file using OpenFileL() method and able to play that 3gp file. In that scenario I am not getting any such error.

    Here is the code snippet for OpenDesL() method which is not working:
    Code:
    RFile lFile;
    RFs lFileSession;
    TBuf<128> lFilename(KFileName);
    lErrCode = lFileSession.Connect();
    LOG(_L("Filesession open err = %d"),lErrCode);
    lErrCode = lFile.Open(lFileSession,lFilename,EFileRead);
    LOG(_L("File open err = %d"),lErrCode);
    TInt lFileSize(0);
    lFile.Size(lFileSize);
    LOG(_L("File Size = %d"),lFileSize);
    if(lFileSize < 20000)
    	{
    	TBuf8<20000> iVideoBuffer;
    	lFile.Read(iVideoBuffer);
    	iPlayer->OpenDesL(iVideoBuffer);
    	TRAPD(unsupported, iPlayer->OpenDesL(iVideoBuffer));
    	LOG(_L("Opening buffer err = %d: %S"),unsupported, &(iMediaFile->Des()));
    	lErrCode = unsupported;
    	}
    	else
    	{
    	LOG(_L("File too large to open")));
    
            }


    Please help me whats wrong and why I am getting that KErrNotSupported(-5) error code

    Thanks,
    Digish

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,336

    Re: CVideoPlayerUtility:: OpenDesL Returns -5 error code

    Nokia Developer Wiki Moderation team

  3. #3
    Registered User
    Join Date
    May 2007
    Location
    India
    Posts
    197

    Smile Re: CVideoPlayerUtility:: OpenDesL Returns -5 error code

    Thanks kiran,

    Thanks for the reply.
    But The problem I am receiving is for CVideoPlayerUtility not CVideoRecorderUtility for which you have linked me.

    Thanks as I was planning to check Recording now. The link's information is helpful because I am planning to look it next.

    There is no workaround for URL/Buffer case in KB. Can you provide some?

    Also in KB its written as its for 3rd ED. But i am testing on emulator for s60 3rd Ed FP1 devices.

    Thanks,
    Digish
    Last edited by Digish; 2008-07-01 at 06:22.

Similar Threads

  1. multiple videos with CVideoPlayerUtility
    By balanikas in forum Symbian Media (Closed)
    Replies: 1
    Last Post: 2008-04-07, 09:05
  2. Replies: 2
    Last Post: 2007-11-19, 15:45
  3. Video Streaming over HTTP, CVideoPlayerUtility can work ?
    By leduc in forum Symbian Media (Closed)
    Replies: 0
    Last Post: 2007-01-16, 10:08
  4. ExampleClientEngine ...
    By GeKI in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2005-12-16, 07:12
  5. Personal
    By JSmith77 in forum PersonalJava
    Replies: 4
    Last Post: 2003-07-30, 12:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •