×

Discussion Board

Results 1 to 15 of 60

Hybrid View

  1. #1
    Regular Contributor
    Join Date
    Jun 2008
    Location
    Jordan
    Posts
    213

    Auto Startup Application Signing!

    Hello Everybody,

    one of my tasks is run my application at the mobile startup, i do all the coding regarding this issue (.mmp, .rss, .pkg) and signing my application for Nokia N73 as Open Signed Online ,,, but my application cannot run at the startup,, i dont know why?
    but i still run the application from the menu. but if i trying to restart the mobile the application never appear at the startup

    Any help will greatly appreciated.
    Leonard

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Auto Startup Application Signing!

    You will have to do some debugging and logging as nobody can know what your application does better than you do.

    It could be that it does not start at all (something wrong with the registration file) or that it starts but then exits for some reason.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Regular Contributor
    Join Date
    Jun 2008
    Location
    Jordan
    Posts
    213

    Re: Auto Startup Application Signing!

    Thank you itomuta,

    I am trying now ,, i think there is a wrong with the UID's or file paths, anyways i will keep debugging and logging.

    And i will let you know.

    Regards,
    Leonard

  4. #4
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,344

    Re: Auto Startup Application Signing!

    Nokia Developer Wiki Moderation team

  5. #5
    Regular Contributor
    Join Date
    Jun 2008
    Location
    Jordan
    Posts
    213

    Re: Auto Startup Application Signing!

    Hello Kiran,

    Thank you for your reply, actually i used this article to code my application for running during the startup ,, but it did not worked ,the mobile is starting up then go to the idle screen with out running my application,

    ok, please check the article "how to autostart an app....", point # 4, change the application UID ,, what is that mean?? i have two UID's in mmp file as follows 0x100039CE 0xe4501db0 ??

    Please help,
    Your help will be greatly appreciated,
    Leonard

  6. #6
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,344

    Re: Auto Startup Application Signing!

    As you are using Startup List Management API, you need to sign it with developer certificate. Hence you should use UID3 from protected range. You need to change UID3 value in your case and i.e: 0xe4501db0. Find all the occurrences of this UID in your whole project and replace all with newer UID.
    In Wiki article, it has been taken from range of development purpose. I suggest you to ask protected range UID from www.symbiansigned.com so that you just need to find/replace only once.

    Kiran.
    Nokia Developer Wiki Moderation team

  7. #7
    Regular Contributor
    Join Date
    Jun 2008
    Location
    Jordan
    Posts
    213

    Re: Auto Startup Application Signing!

    Hello Kiran,

    Thanks for your reply, i done an open signed online for this application and install it on N73 mobile device, with no error messages ,,but when i was trying to startup the mobile ,, my application did not appear (run) at the startup, maybe it is UID issue.

    Anyways, below is the mmp, rss, and pkg files for the startup application ,, please check if there is any error regarding this problem.

    1) Here is the mmp file :

    TARGET AmerCE.exe // my application name
    TARGETTYPE exe
    UID 0x100039CE 0xe4502bd0 // two UID's

    // Source path for the rss file

    SOURCEPATH ..\group // file path
    START RESOURCE e4502bd0.rss /* the resource file for auto starting the application */
    END

    2)Here is the pkg file :

    // standard SIS file header
    #{"AmerCE"},(0xe4502bd0),1,0,0

    "E:\Symbian\9.2\S60_3rd_FP1_2\Epoc32\Data\e4502bd0.rsc" -"c:\private\101f875a\import[e4502bd0].rsc"


    3) Here is the rss (Auto startup resource file) :


    #include <startupitem.rh>

    RESOURCE STARTUP_ITEM_INFO AmerCE
    {
    executable_name = "c:\\sys\\bin
    AmerCE.exe" ;
    recovery = EStartupItemExPolicyNone ;
    }


    Please help if there is any error,

    Regards,
    Leonard

  8. #8
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: Auto Startup Application Signing!

    Quote Originally Posted by amerzannouneh View Post
    "E:\Symbian\9.2\S60_3rd_FP1_2\Epoc32\Data\e4502bd0.rsc" -"c:\private\101f875a\import[e4502bd0].rsc"
    A backslash seems to be missing, does it even install?

  9. #9
    Regular Contributor
    Join Date
    Jun 2008
    Location
    Jordan
    Posts
    213

    Re: Auto Startup Application Signing!

    Hello wizard_hu,

    thank you for your reply,

    i am sorry for the missing backslash.
    when i reply to kiran i forgot to type it
    here is the pkg file with the missing backslash:

    "E:\Symbian\9.2\S60_3rd_FP1_2\Epoc32\Data\e4502bd0.rsc" -"c:\private\101f875a\import\[e4502bd0].rsc"

    your help will be greatly appreciated,

    Regards,
    Leonard

  10. #10
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Auto Startup Application Signing!

    Quote Originally Posted by amerzannouneh View Post
    Hello Kiran,

    Thank you for your reply, actually i used this article to code my application for running during the startup ,, but it did not worked ,the mobile is starting up then go to the idle screen with out running my application,

    ok, please check the article "how to autostart an app....", point # 4, change the application UID ,, what is that mean?? i have two UID's in mmp file as follows 0x100039CE 0xe4501db0 ??

    Please help,
    Your help will be greatly appreciated,
    Leonard
    Who, that page scared me too See the new, simplified and hopefully improved version of the page: http://wiki.forum.nokia.com/index.ph...Management_API
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  11. #11
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,344

    Cool Re: Auto Startup Application Signing!

    Quote Originally Posted by ltomuta View Post
    Who, that page scared me too See the new, simplified and hopefully improved version of the page: http://wiki.forum.nokia.com/index.ph...Management_API
    If i remember correctly i created that page with holy intention in my heart. I could not foresee at that time that it would scare people at some time.

    Kiran.
    Nokia Developer Wiki Moderation team

  12. #12
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Auto Startup Application Signing!

    The backup file most likely )
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  13. #13
    Regular Contributor
    Join Date
    Jun 2008
    Location
    Jordan
    Posts
    213

    Re: Auto Startup Application Signing!

    Hello itomuta,

    Thank you for your quick reply.

    i discover that in my mmp file there is :
    SECUREID 0xe4502bd0 // the old UID
    if i leave this code without replacing it with the new UID.

    the application will install without any problem , but when i trying to click on it from the application icon in user menu ,,,Nothing happened , i mean the application will never run!!!
    and like usual the application will not started at the mobile startup....

    but if i change the old UID with the new one (protected),, through the installation process the message will appear and said that (unable to install).

    really this is very strange.

    Please help, please help.

    Regards,
    Leonard

Similar Threads

  1. Replies: 4
    Last Post: 2007-06-24, 22:42
  2. Problem After Auto Start Application.
    By Tanya in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2007-06-08, 10:02
  3. Application on startup
    By silviuccia in forum Symbian
    Replies: 12
    Last Post: 2007-04-27, 08:58
  4. signing application
    By ktubail in forum Mobile Java General
    Replies: 1
    Last Post: 2006-08-05, 19:42
  5. Replies: 5
    Last Post: 2006-03-10, 09:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×