×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Mar 2008
    Posts
    140

    The application crashes with a glint when being launched on device.

    Hello everybody,

    I am experiencing the problem: I finished an application which can work well on emulator and it also work normally on a device just when be installed. But after long time, it can not be launched again. and when I click the icon of application on the device, there is not any change except a glint. but when I reinstall it on the device. it can work again.

    The possible and impossible causes that I can think out are described as follows.

    1) It is impossible that some a lib or file are not installed into the device, because most of time it can work well on the device.

    2) Some a function with an 'L' at the end causes the problem when initializing the UI.

    3) There is memory leak in my application, which causes the launch unsuccessful after long time when being installed. I think it is the most possible cause!


    4) The capabilities required by my application will not be the cause, because it can be installed on a device, and most time it can work normally.

    Can anybody give me any more advice?

    Thanks and regards!
    Sophie
    Last edited by yfw1966; 2008-07-11 at 05:14.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165

    Re: The application crashes with a glint when being launched on device.

    first thing to check would be the actual error code returned when your application crashes when launched, see this for help : http://wiki.forum.nokia.com/index.ph...ded_panic_code

  3. #3
    Registered User
    Join Date
    Mar 2008
    Posts
    140

    Re: The application crashes with a glint when being launched on device.

    Thanks for your help,

    but I did not get any error code, the application can not be opened,just with a glint.

    now I found the only way to open the application:

    Select the icon of my application, then hold on the middle-key, then it will be opened and work normally.

  4. #4
    Registered User
    Join Date
    Mar 2008
    Posts
    140

    Re: The application crashes with a glint when being launched on device.

    I think there are two causes:

    1) I use the middle-key to start the main function after opening the application on a device. I record if the middle-key is pressed with a bool flag in the UI::HandleKeyEventL() after launched. Maybe I should move the segment code into HandleCommandL();

    2) There is something wrong with the system driver installed in N95-2, known as s60 3rd SDK with FP1. I mean there is a bug in the system. Is it possible? After all, opening an application in the phone is the task of the system driver.

    Can anybody give me any advice? Thanks first.

    Best regards!
    Sophie

  5. #5
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165

    Re: The application crashes with a glint when being launched on device.

    There is always return code from a process, so try the Y-Tasks approach.

    if it says Kill-0-Kill, its sort-of-normal exit. And in start up can be caused by many different reasons, one being a missing library.

  6. #6
    Registered User
    Join Date
    Mar 2008
    Posts
    140

    Re: The application crashes with a glint when being launched on device.

    Hello symbianyucca,

    Thanks for your help first, I have not come here for a long time, because I have been looking for the solution and complete a project.

    I have posted the problem in another thread titled as "Please help me: "Already in use(-14)" error when double click app icon in N95!", Now I am happy to say I have found the solution and described it there. Hope it can help others!

    Best regards!
    Sophie

Similar Threads

  1. Unable to delete the application once launched by PushRegistry
    By mmdfarook in forum Mobile Java Networking & Messaging & Security
    Replies: 0
    Last Post: 2008-06-12, 11:14
  2. Is there any way to find application launched by user or push registry.
    By mmdfarook in forum Mobile Java Networking & Messaging & Security
    Replies: 3
    Last Post: 2008-06-11, 12:54
  3. WLAN Connection from Emulator
    By capri07 in forum Mobile Java Networking & Messaging & Security
    Replies: 4
    Last Post: 2007-12-13, 05:13
  4. Bluetooth Security: What exactly is an untrusted device?
    By rahulmcs in forum Bluetooth Technology
    Replies: 1
    Last Post: 2005-12-02, 06:26
  5. application does not install on 7650 device
    By asangamneheri in forum Symbian Tools & SDKs
    Replies: 4
    Last Post: 2002-07-08, 12:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×