×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jul 2007
    Posts
    1

    Unhappy E90 SIP Debugging

    Hello,

    I am currently setting up a voip-related project, part of which are sip-enabled mobile phones. A few months ago I have purchased Nokia E60 and E90, for both personal and development purposes.

    Yesterday I upgraded my E90 to 210.34.75 (hoping to solve BT problems with my Audi set), and today I wanted to use it as a SIP client that connects to my network.

    I did everything exactly the same as a year ago on E60. I've downloaded your SIP wizard. I've been messing around for 4 (four) hours trying various advices from different parts of the Internet and I simply cannot make it work.

    This E90 has two WiFi connections defined. Both use static internal IP, one is not secured at all. I tried enabling STUN on one/both of them.

    The thing is - it does not send anything! I've been sniffing at my router's internal interface and when I'd expect it to talk to SIP server/proxy - there is NOTHING. On the other hand, browsing the Web works like a charm, so I wouldn't suspect the connection.

    As soon as I change something in the SIP profile and go back to the menu, for a second it changes to "Not registered" and then instantly to "Registration failed". It doesn't even TRY to communicate with the net.

    What's wrong with it? Guys at Nokia phone support don't know a thing. Is there any way to tell what causes this error?

    Or maybe my E90 is broken and I should try replacing it?

    Thanks you in advance for all suggestions.

  2. #2
    Registered User
    Join Date
    Jul 2008
    Posts
    1

    Re: E90 SIP Debugging

    tompaw,

    No help I'm afraid, but I have *exactly* the same issue. I thought the firmware upgrade might fix this issue, but no... I run my own sip server and I know it is not even trying to hit that. Like you say the E90 makes no attempt to "call out" - It just goes to registration failed.

    Someone must havve got this working??

  3. #3
    Registered User
    Join Date
    Jul 2008
    Posts
    2

    Re: E90 SIP Debugging


    Hello,
    I have the same problem. I didn't upgrade the firmware (still V 07.40.1.2). I can see from the net a couple of ICMPV6 messages. Then the messages from E90 stops. No attempts to start SIP protocol. The registration fails but also the WLAN is not set up. The connection to Internet works fine. With internet calls instead it doesn't send anything for SIP handshake. I don't have a SIM card into the phone so I'm working offline but I also tried working online.

  4. #4
    Registered User
    Join Date
    Jul 2008
    Posts
    2

    Smile Re: E90 SIP Debugging

    Well, I've found!
    You should download SipVoipSettings and open the Firewall for your provider. Otherwise nothing goes out. Bye

Similar Threads

  1. Nokia N95 SIP REGISTER problem
    By bdun in forum VoIP
    Replies: 4
    Last Post: 2009-04-08, 13:50
  2. JAIN SIP and Symbian C++ SIP
    By RyanSantos in forum Symbian Networking & Messaging (Closed)
    Replies: 11
    Last Post: 2008-07-25, 15:44
  3. Replies: 5
    Last Post: 2008-02-20, 09:52
  4. On Device Debugging Blank Error Dialog E90 Carbide
    By aditya4180 in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 0
    Last Post: 2007-08-24, 16:06
  5. SIP: BYE/ 481 (No Dialog Found)!!!!!!!!!!
    By Mini Pillai in forum Symbian Networking & Messaging (Closed)
    Replies: 13
    Last Post: 2007-02-09, 04:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×