×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Jul 2007
    Posts
    6

    Midi playback sped is low

    Im developing a game that uses midi files for sound.
    Its made so it works on most phone manufacturers and resolution, by scaling pictures and so on, but i have problems with the sound on all Nokia phones.

    The playback of the midi is slower than the normal speed, but it works fine on other phones(ie: SE, Moto, etc).

    I tried speeding it up with setRate right after prefetch, but that doesnt work if a specify a faster rate, only for a slower.
    I tried modifying it while playing, increased from 100000 to 160000 by 1000 steps, it speed up a little, but not to full speed, and when i hit ~165000 it stops playing, or plays with a very slow rate.

    How can i make it play at normal speed, as this is pretty important for my game.

  2. #2
    Registered User
    Join Date
    Jul 2007
    Posts
    6

    Re: Midi playback sped is low

    Anyone has any idea?

Similar Threads

  1. Problem with MIDI playback in Nokia 6101
    By Slavenok in forum Audio
    Replies: 9
    Last Post: 2007-01-04, 14:02
  2. Replies: 1
    Last Post: 2006-02-21, 08:41
  3. Update on 6600 midi playback problems
    By marcpalmer in forum Mobile Java General
    Replies: 2
    Last Post: 2004-09-22, 17:20
  4. MIDI playback on s40
    By fwojtek in forum Mobile Java Media (Graphics & Sounds)
    Replies: 6
    Last Post: 2004-04-22, 08:20
  5. MIDI playback broken in S60 emu?
    By marcpalmer in forum Mobile Java Media (Graphics & Sounds)
    Replies: 3
    Last Post: 2003-10-03, 12:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×