×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Jun 2008
    Posts
    53

    Installation failing at end?

    I've got a project that runs fine on the emulator, but has trouble installing the sis file on a phone. I've added some text files for output to let me know where I'm getting to, and it looks like I'm doing everything right, at least up until the point where the instal hangs and then dies. Here are my pkg files:

    sa.pkg
    Code:
    ;Languages
    &EN
    
    ;Header
    #{"Launcher"},(0xEB35D676),*VERSIONNUMBER*,TYPE=SA
    
    ;Localised Vendor name
    %{"Quickoffice"}
    
    ;Unique Vendor name
    :"Quickoffice Inc"
    
    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}
    
    ; install the resources
    "*EPOCROOT*epoc32\DATA\Z\private\10003a3f\apps\Launcher_0xEB35D676_reg.RSC"-"C:\private\10003a3f\import\apps\Launcher_0xEB35D676_reg.RSC"
    "*EPOCROOT*epoc32\data\c\launcher_install2.txt"-"",FT,TC <-- this comes up first
    
    ; install the launcher
    "*EPOCROOT*epoc32\RELEASE\ARMV5\UREL\Launcher_0xEB35D676.exe"-"C:\sys\bin\Launcher_0xEB35D676.exe"
    "*EPOCROOT*epoc32\data\c\launcher_install3.txt"-"",FT,TC <-- this comes up second
    install.pkg
    Code:
    ;Languages
    &EN
    
    ;Header
    #{"Launcher Package"},(0xEB35D676),*VERSIONNUMBER*,TYPE=SA
    
    ;Localised Vendor name
    %{"Quickoffice"}
    
    ;Unique Vendor name
    :"Quickoffice Inc"
    
    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}
    IF NOT package(0xEB35D676)
    ;;
    ;; Launcher 1.0 Application
    ;; This next line will be replaced with the SIS file name created by the sa.pkg package file.
    ;; The sa.pkg in deploy.inf must be listed prior to install.pkg (this pkg file) for this to work.
    ;;
    @"*EPOCROOT*epoc32\SISFILES\DevOnly\*SA_SISFILE*",(0xEB35D676)
    ;;
    ;; Installation Note
    ;;
    "*EPOCROOT*epoc32\data\c\launcher_install.txt"-"",FT,TC <-- this comes up, then it hangs and dies
    ELSE
    "*EPOCROOT*epoc32\data\c\launcher_exists.txt"-"",FT,TE
    ENDIF
    Any help would be appreciated.

    Thanks!
    James

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Installation failing at end?

    Why you say that it is failing as you pkg does not have any thing below that line. are you expecting some thing from installer to do after that ?

  3. #3
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,689

    Re: Installation failing at end?

    If you check the SISX-doc on http://developer.symbian.com/main/do...s/platform.jsp, you will see that the installation is re-ordered in practice, first a decision-making phase occurs (checking everything, and this part includes user-interaction too), then the copying.
    Anyway, if the installation fails, you should describe that better than 'hangs and dies'. There is usually a message: http://wiki.forum.nokia.com/index.ph...roubleshooting and if something really grave happens, there may be a panic message too: http://wiki.forum.nokia.com/index.ph...ded_panic_code

  4. #4
    Regular Contributor
    Join Date
    Jun 2008
    Posts
    53

    Re: Installation failing at end?

    Thanks for the links!

    The message I get is "Unable to Install" (no panic). The wiki gives two reasons that might happen.

    1) Trying to instal a file that is already in ROM. I did a hard reset of the phone prior to installation and the error still comes up, so I don't see how this can be it.

    2) Min EPOCHEAPSIZE greater than max EPOCHEAPSIZE. I wasn't setting these in my mmp. I set EPOCHEAPSIZE to 4096 67108864 and stack size to 0x5000, hard reset and tried to install again, but still got the error.

  5. #5
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,539

    Re: Installation failing at end?

    Quote Originally Posted by James McMurray View Post
    Thanks for the links!

    The message I get is "Unable to Install" (no panic). The wiki gives two reasons that might happen.

    1) Trying to instal a file that is already in ROM. I did a hard reset of the phone prior to installation and the error still comes up, so I don't see how this can be it.

    2) Min EPOCHEAPSIZE greater than max EPOCHEAPSIZE. I wasn't setting these in my mmp. I set EPOCHEAPSIZE to 4096 67108864 and stack size to 0x5000, hard reset and tried to install again, but still got the error.
    http://blogs.forum.nokia.com/blog/an...60-3rd-edition
    This might help you interpret the "unable to install" a little better.

Similar Threads

  1. Troubleshoot failing PA installation
    By olivier_randria in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 1
    Last Post: 2008-01-04, 02:34
  2. Music resources
    By LiveRock in forum Mobile Java General
    Replies: 9
    Last Post: 2007-12-01, 08:15
  3. Problem: 10 Bluetooth Ports simultaneously
    By Alco Fresh in forum Symbian
    Replies: 1
    Last Post: 2006-07-03, 12:05
  4. Series 60 SDK Appwizard on windows xp
    By moonjoor in forum Symbian Tools & SDKs
    Replies: 15
    Last Post: 2003-12-24, 10:22
  5. J2me windows installation failing
    By kmaddocks in forum Mobile Java General
    Replies: 0
    Last Post: 2003-03-21, 11:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×