×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    May 2008
    Posts
    2

    how i can "open" and install this example?

    I try to open in carbide this example:

    (carbide v1.3 whit FP2 SDK and MR api extension files installed)

    http://wiki.forum.nokia.com/index.ph..._characters%29

    so when i load on carbide (file/import/symbian os bld.inf file ...

    i copy the apropiate RM api fileson epoc32/include
    /release/armv5/lib etc

    and build... so, when i try to install simply "certificate error"

    ok, i self signed (because this app have acces to network) and try again, but that error appear:

    "out of date certificate"


    so, i need some help to build and install apropiate to this example to begin with the learn...


    some help is welcome guys.


    cheers

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: how i can "open" and install this example?

    The example apparently requires more capabilities
    Quote Originally Posted by VoipCallHandle.mmp
    CAPABILITY NetworkServices WriteDeviceData ReadUserData ReadDeviceData
    than self-signing could grant.
    So you need some Symbian Signed variant, visit www.symbiansigned.com (do not forget downloading "The Complete Guide To Symbian Signed" from the start page). The free Open Signed Online option should be enough.

  3. #3
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: how i can "open" and install this example?

    Also, when running into errors, switch your phone to English language at least for the duration of the test and then search for information, or post here, using the exact error message, not an approximate translation.

    There's no such error message as "out of date certificate" and you will not find the otherwise obvious solution if you're searching for such expression.
    Last edited by ltomuta; 2008-07-24 at 17:42.

  4. #4
    Super Contributor
    Join Date
    Jan 2007
    Location
    Bhubaneswar, India
    Posts
    1,189

    Re: how i can "open" and install this example?

    Hi,

    If you have date and time problem with certificate then you can change date of your mobile to next day and then try once again.
    -------------------------------------
    Thanks & Regards
    Ram
    Symbian OS 9.2/9.3,S60 3rd FP1/FP2,Carbide.c++v2.0

  5. #5
    Super Contributor
    Join Date
    Nov 2004
    Location
    Wiltshire, UK
    Posts
    3,644

    Re: how i can "open" and install this example?

    Also note that its very dangerous building with the FP2 SDK and the MR partner SDK as this will likely result in nothing working on all phones.

    Either use the MR SDK and and the MR Partnering API so it will work on 3.0 devices or use the FP2 partnering SDK so it will work on FP2 only devices.

    There are binary breaks in the partnering SDK's which means (depending on the API's you have used) that you need to build a specific version for each feature pack

    This works:
    MR SDK + MR Partnering SDK.
    FP1 SDK + FP1 Partnering SDK
    FP2 SDK + FP2 Partering SDK

    This is a recipe for pain:
    MR SDK + FP2 partnering SDK
    FP1 SDK + MR partnering SDK
    .....
    Download Symbian OS now! [url]http://developer.symbian.org[/url]

  6. #6
    Registered User
    Join Date
    May 2008
    Posts
    2

    Re: how i can "open" and install this example?

    Quote Originally Posted by ltomuta View Post
    Also, when running into errors, switch your phone to English language at least for the duration of the text and then search for information, or post here, using the exact error message, not an approximate translation.

    There's no such error message as "out of date certificate" and you will not find the otherwise obvious solution if you're searching for such expression.
    I see, my bad translation cause that confusion


    also, i need read more about partner api, examples and signed symbian i see, so (i'm obsess) i will try to reinstall all and install partner api propertly ... and try again to build and install these example ...


    i'll post here my results soon


    thanks very much guys, those aspects about date, sdk etc help me so much.


    cheers

Similar Threads

  1. Carbide.J 1.5 Vista Install Problem
    By Jimmmeh in forum Mobile Java Tools & SDKs
    Replies: 12
    Last Post: 2008-01-07, 10:32
  2. Replies: 1
    Last Post: 2007-04-16, 11:05
  3. Install, Install, Install :(
    By rolecram in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2007-02-08, 02:02
  4. Notification on completion of sis file install
    By cesparey in forum Symbian
    Replies: 1
    Last Post: 2006-03-14, 00:49
  5. install error in simulator
    By billqu in forum Symbian
    Replies: 4
    Last Post: 2004-10-29, 13:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×