×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Mar 2008
    Posts
    15

    Binary compatibility.

    We know that binary compatibility in s60_3rd edition. But any software compile in s60_3rd_MR edition can run on s60_3rd_fp1 and s60_3rd_fp2.
    What happan if i use Plug-in.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Binary compatibility.

    it might work, but there is no quarantee on that, so you would need to get it tested on each device you want to use it for.

  3. #3
    Registered User
    Join Date
    May 2008
    Posts
    15

    Re: Binary compatibility.

    For Additional info on compatability

    http://www.forum.nokia.com/info/sw.n..._6_en.pdf.html

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Binary compatibility.

    But still remember what the API plug-in say on this:

    PLEASE NOTICE THE FOLLOWING ISSUES WITH THESE APIs:

    1. Nokia is not giving any binary compatibility promise for these APIs; neither between platform versions or within a platform version.
    2. You must test your application with each device that the application can be installed on. This is needed to ensure the best possible user experience. To prevent application installation on other than tested devices, define the Product ID(s) (also known as Machine UID) in the .pkg file. More information can be found in the document S60 Platform: Identification Codes available on the Forum Nokia Web site.

  5. #5
    Regular Contributor
    Join Date
    Jul 2012
    Posts
    82

    Re: Binary compatibility.

    Hi,

    Is the binary of app devloped on s60 3rd edition is compatiable with the Nokia X6, Because i tried to install the same application on e71 & X6. It is running fine on e71 But giving system error on x6.

    What could be the cause for the same.

    Do i have to use the binary of s605th edition.

  6. #6
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Binary compatibility.

    You should debug and see the function call that causes the system error, also you should get the actual panic reason: http://www.developer.nokia.com/Commu...ded_panic_code

  7. #7
    Super Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,553

    Re: Binary compatibility.

    Quote Originally Posted by akki123 View Post
    Hi,

    Is the binary of app devloped on s60 3rd edition is compatiable with the Nokia X6, Because i tried to install the same application on e71 & X6. It is running fine on e71 But giving system error on x6.

    What could be the cause for the same.

    Do i have to use the binary of s605th edition.
    It depends on how it was written/created (what the app/binary does); the X6 is using a display resolution that did not exist (was not available) when S60 3rd Ed. existed (app might depend on QVGA display resolution and unble to handle others), and the X6 has a touch-screen display, which an S60 3rd Ed. app might not be able to handle either (all S60 3rd Ed. devices have a keypad or QWERTY-keyboard, or both, but no touch), and as there has been multple S60 3rd Ed. releases, there might be also APIs missing or changed on the X6 (S60 5th Ed.)

Similar Threads

  1. Binary Compatibility Analysis Tools
    By navjotsingh1979 in forum Symbian
    Replies: 3
    Last Post: 2008-02-01, 08:29
  2. e32db binary compatibility?
    By qno670713 in forum Symbian
    Replies: 0
    Last Post: 2006-10-05, 17:02
  3. Replies: 2
    Last Post: 2004-09-15, 22:47
  4. PbkEng.lib binary compatibility
    By cvz in forum Symbian
    Replies: 0
    Last Post: 2003-07-11, 16:00
  5. Loading images from byte array on 6130i
    By enlightment in forum Mobile Java General
    Replies: 2
    Last Post: 2002-06-05, 19:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×