×

Discussion Board

Results 1 to 4 of 4

Hybrid View

  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    33

    Partial upgrade installer problem

    I have created what I believe to be a valid installer created as package type of partialupgrade. It specifies the UID of the already installed target of the upgrade in the header and contains all other required directives. On some Series60 and some UIQ devices, installation of this fails with "Install error". The failing devices are OS 9.1, but the installer works on a 9.1 E62 that I have. I have seen the failure myself on a SonyEricsson 990i and a Nokia N95, and it has been reported by others on a N80.

    The odd thing is that if I remove a particular file from the upgrade, the install works.Only removing that file makes the install work. That file was installed with the same name and SID by the original installer.

    The only other out of the ordinary thing I can think of here is that the original installer contained several nested installers, and the upgrade installer targets one of those nested installers.

    Any suggestions?

    Thanks,

    Mark Peters

    P.S. - I posted this issue on the Symbian Developer Network, and tech support there passed the failing test case on to Symbian development, who said they saw nothing wrong with the base installer or the upgrade installer. I gave them all the binaries needed to recreate the installers and sign them themselves, so I can do the same here if necessary if Nokia tech support requests them.

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: Partial upgrade installer problem

    Hi Mark,

    Yes, the binaries might be required so that one would have an understanding if whatever it is that goes on.

    However, please understand that this forum is in fact a community discussion board and it is only in special cases that Forum Nokia's Technical Support would pick cases from here for further investigation (the reason is obviously lack of bandwidth).

    If you think that you can share enough information here so that the community can help you it is great. Otherwise, you should really consider using Forum Nokia's Technical Support service, either for requesting technical assistance or for notifying about a possible platform bug.

  3. #3
    Super Contributor
    Join Date
    May 2003
    Location
    Vancouver, Canada
    Posts
    985

    Re: Partial upgrade installer problem

    It's difficult to say with the information that you gave. If you could copy and paste the .pkg file for base + update packages, that would be better.
    Antony Pranata
    http://www.antonypranata.com/
    http://www.s60tips.com/

  4. #4
    Registered User
    Join Date
    Apr 2008
    Posts
    4

    Re: Partial upgrade installer problem

    Thanks for the responses.

    Since developers over at Symbian have blessed the .pkg files, submitting them here probably wouldn't be productive.

    Based on their feedback, I will submit a bug report, and most likely a tech support case.

    Regards,

    Mark

Similar Threads

  1. Lock Code Problem after FW upgrade E61
    By stone4x4 in forum General Development Questions
    Replies: 0
    Last Post: 2006-09-14, 12:22
  2. About 6230 Bt Problem
    By eerkek in forum Bluetooth Technology
    Replies: 17
    Last Post: 2005-02-08, 12:33
  3. problem with emulator upgrade
    By trishift in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2004-11-08, 03:40
  4. 7210 Silent Problem
    By MarkMckim in forum Mobile Java General
    Replies: 1
    Last Post: 2003-03-18, 12:36
  5. Application Installer problem
    By tubeman in forum Mobile Java General
    Replies: 0
    Last Post: 2002-09-11, 12:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •