×

Discussion Board

Results 1 to 15 of 19

Thread: mbm missing

Hybrid View

  1. #1
    Registered User
    Join Date
    Jul 2008
    Posts
    10

    mbm missing

    hi all,,


    presently am working on symbian c++ s60 3rd edition applications. Now we hav switched our ide to carbide.c++ version.1.3. while trying to create mbm using its mmp editor,,, mbm was missing even if following code was updated into the mmp editor..

    [code - inside mmp file ]

    START BITMAP test.mbm
    TARGETPATH resource\apps
    HEADER
    SOURCEPATH ..\testimg
    SOURCE c8,1 sampl.bmp sampl_mask.bmp
    END

    but couldn't find mbm file and mbg file ..
    waiting for ur speedy reply.

    thnx
    aswathy.
    Last edited by sheenaj; 2008-07-29 at 12:00.

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: mbm missing

    Refresh, then clean the project. Build again and look for the file or for some error message in the console.

  3. #3
    Registered User
    Join Date
    Jul 2008
    Posts
    10

    Re: mbm missing

    hi ltomuta ,,

    thnx 4 ur speedy reply .. i hav done all the steps mentioned above.. Also no error was showing in the console window topoo,,, .Still these files r missng. checked the epoc32/include path ,, which was set as default for mbg file..
    still the files r missing.. any help frm ur part wud be appreciated.

    thnx,
    aswathy.
    Last edited by sheenaj; 2008-07-29 at 11:59.

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: mbm missing

    I would try one of the following:
    - use of Carbide.c++'s add MBM entry wizard (right click on .MMP or .MK file to get access to it)
    - use of hand made extension makefiles
    - command line build with "-v" added to all commands and a careful inspection of the output

  5. #5
    Regular Contributor
    Join Date
    Jul 2008
    Posts
    179

    Re: mbm missing

    Hi,

    I see some problem at this line.
    SOURCE c8,1 sampl.bmp sampl_mask.bmp

    just remove ,1

    use something like as follows:
    START BITMAP my.mbm
    HEADER
    TARGETPATH \Resource\Apps //Target path of .mbm file
    SOURCEPATH ..\images // Source path for icons to buil dmbm file
    SOURCE c24 MyImg_Small.bmp
    SOURCE 8 MyImg_Small_mask.bmp
    SOURCE c24 MyImg_Large.bmp
    SOURCE 8 MyImg_Large_mask.bmp
    END

  6. #6
    Registered User
    Join Date
    Jul 2008
    Posts
    10

    Re: mbm missing

    NevePankaj,,

    thnx 4 ur reply . as per ur code ,, i hav edited the mmp file (even if am using default mmp editor)..still failed to generate files..

    pls find the code below .. i hav bmp files in app's gfx folder.

    START BITMAP test.mbm
    HEADER
    TARGETPATH \resource\apps
    SOURCEPATH ..\gfx
    SOURCE c8 sampl.bmp .bmp
    SOURCE 1 sampl.bmp_mask.bmp
    END

    is that anything to do with compiler. once again thnx 4 ur help.

    aswathy.
    Last edited by sheenaj; 2008-07-29 at 11:59.

  7. #7
    Regular Contributor
    Join Date
    Jul 2008
    Posts
    179

    Re: mbm missing

    Try doing like...
    insted of 1 bit for mask image use 8 bit.

  8. #8
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: mbm missing

    The addition of the following statements to the MMP file
    Code:
    START BITMAP Test.mbm
    	TARGETPATH resource\apps
    	HEADER
    	SOURCEPATH ..\gfx
    	SOURCE c24,1 b.bmp b_msk.bmp
    END
    has the following result

    Code:
    ***Invoking abld command
    perl.exe -S ABLD.PL \Work\Test\group\ resource winscw udeb  
      make -r  -f "\Symbian\9.3\S60_3rd_FP2_SDK\EPOC32\BUILD\Work\Test\group\WINSCW.make" RESOURCE CFG=UDEB VERBOSE=-s
    Created \Symbian\9.3\S60_3rd_FP2_SDK\epoc32\include\Test.mbg
    Created \Symbian\9.3\S60_3rd_FP2_SDK\epoc32\release\WINSCW\udeb\z\resource\apps\Test.mbm
    make -s  -C \Work\Test\group -f "ICONS_SCALABLE_DC.MK" TO_ROOT=..\..\.. EPOCBLD=..\..\..\Symbian\9.3\S60_3rd_FP2_SDK\EPOC32\BUILD\Work\Test\group\ICONS_SCALABLE_DC\WINSCW TO_BLDINF=..\..\..\Work\Test\group PLATFORM=WINSCW CFG=UDEB RESOURCE
    make -s  -C \Work\Test\HELP -f "BUILD_HELP.MK" TO_ROOT=..\..\.. EPOCBLD=..\..\..\Symbian\9.3\S60_3rd_FP2_SDK\EPOC32\BUILD\Work\Test\group\BUILD_HELP\WINSCW TO_BLDINF=..\..\..\Work\Test\group PLATFORM=WINSCW CFG=UDEB RESOURCE
    make -s  -r -f "\Symbian\9.3\S60_3rd_FP2_SDK\EPOC32\BUILD\Work\Test\group\TEST\WINSCW\TEST.WINSCW" RESOURCEUDEB

  9. #9
    Registered User
    Join Date
    Jul 2008
    Posts
    10

    Re: mbm missing

    hi all,,


    there was no mbm file creation command in the console window but not showing any errors . Also tried giving 8 bit image mask instead of 1 bit mask. Still not working . wat could be the reason.. am using carbide.c++ version .v.1.3 . is there any thind to do with compiler/build settings ??? plsss advice..

    thnx ,
    aswathy.
    Last edited by sheenaj; 2008-07-29 at 11:59.

  10. #10
    Regular Contributor
    Join Date
    Dec 2007
    Location
    Banglore,India
    Posts
    156

    Re: mbm missing

    as you are using carbide ide, its easy to create mbm

    1st step- create a folder under your project path
    and put all your image there.
    2nd step - open ur .mmp file, and click source tab.
    then look at right side ,
    right there one Bitmaps folder'll be there,
    3rd step- click Add button , then one MBM/MIF editor'll open
    write there target folder name otherwise click default.
    then go for AddFromProject button(click)
    4th step- you can see your image there what you have put in your project/Folder path.

    select and ok..
    Save and compile
    it'll be created automatically

  11. #11
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: mbm missing

    Quote Originally Posted by NevePankaj View Post
    Hi,
    I see some problem at this line.
    SOURCE c8,1 sampl.bmp sampl_mask.bmp
    No problem there I'm afraid...

Similar Threads

  1. carbide-error
    By upendersolanki in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 5
    Last Post: 2008-02-06, 11:09
  2. S60 2nd to 3rd/ PlatformSecurity / Capabilities
    By jarkoos in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 4
    Last Post: 2007-04-14, 14:08
  3. Problem with Cabride.c++ v1.1
    By markovuksanovic in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 3
    Last Post: 2007-01-24, 20:05
  4. cannot draw mbm, am i missing something?
    By xersmith in forum Symbian
    Replies: 19
    Last Post: 2007-01-16, 12:01
  5. missing mbm file
    By vyom_garg in forum Symbian
    Replies: 2
    Last Post: 2003-04-29, 09:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •