Is it possible to upgrade an older WAP-phone to enable use of the wallet?