×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 20
  1. #1
    Super Contributor
    Join Date
    Jun 2008
    Posts
    593

    Smile Image not displayed in application

    hi..

    i want to display an image in my view..
    i added the image from the UI Design...
    wen i run it on N80 .. the application exits..

    how to do it..??
    plz guide me..

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Image not displayed in application

    Did you included the image in your PKG file ?

  3. #3
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Image not displayed in application

    You could check the reason for the exit by checking the error code for crash. See this for help on how to do it: http://wiki.forum.nokia.com/index.ph...ded_panic_code

    And the error code descriptions could be also found from the Wiki: http://wiki.forum.nokia.com/index.ph...OS_Error_Codes

  4. #4
    Super Contributor
    Join Date
    Jun 2008
    Posts
    593

    Unhappy Re: Image not displayed in application

    i have included in the pkg file..

    i checked it in Emulator debug.. the image is successfully displayed..
    but in N80 it is not displayed.. & i feel Extended Panic Code doesnt work with N80..

    wat else cud b the reason..??
    my file demo2_aif.mif is also created in
    C:\Symbian\9.1\S60_3rd_MR\Epoc32\Data\z\resource\apps
    den y does it panic??
    Also this is a demo application which only contains the image.. so due to no other reason the Application panics..

  5. #5
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Image not displayed in application

    The panic showing does work. If the normal method does not work, then try the Y-Taks:Crash monitor, it will always tell you the process exit code, even if it is normal exit, so just try it out.

  6. #6
    Regular Contributor
    Join Date
    Aug 2006
    Posts
    182

    Re: Image not displayed in application

    once u restart ur device.

  7. #7
    Super Contributor
    Join Date
    Jun 2008
    Posts
    593

    Re: Image not displayed in application

    Quote Originally Posted by symbianyucca View Post
    The panic showing does work. If the normal method does not work, then try the Y-Taks:Crash monitor, it will always tell you the process exit code, even if it is normal exit, so just try it out.
    wat is Y-Taks:Crash monitor..
    i dnt knw abt it.. can u plz give me the link explaining it..
    i searched 4 it but cud nt find..

  8. #8
    Super Contributor
    Join Date
    Jun 2008
    Posts
    593

    Re: Image not displayed in application

    Quote Originally Posted by pavan View Post
    once u restart ur device.
    i tried rebooting.. but no success

  9. #9
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Image not displayed in application

    I think that the extended error page did mention my Y-Tasks, anyway, you could find it from my home at www.DrJukka.com as well.

  10. #10
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,699

    Re: Image not displayed in application

    Quote Originally Posted by nital_shah View Post
    i have included in the pkg file..
    And what have you included?
    And an other one: how are you trying to load the image?

    i checked it in Emulator debug.. the image is successfully displayed..
    The emulator does not depend on your .pkg file. The device does.
    i feel Extended Panic Code doesnt work with N80..
    What have you tried exactly?
    wat else cud b the reason..??
    my file demo2_aif.mif is also created in
    C:\Symbian\9.1\S60_3rd_MR\Epoc32\Data\z\resource\apps
    That is really nice, however this folder exists on your PC.

  11. #11
    Super Contributor
    Join Date
    Jun 2008
    Posts
    593

    Re: Image not displayed in application

    this is the way in which i loaded the image...

    -> i put the image in aif folder in my project
    -> From the UI design.. i put an image in it..
    -> then frm Properties of that image, i browsed .. & set my image in it from aif folder..
    -> then i ran the application in N80..
    it exits..

  12. #12
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,699

    Re: Image not displayed in application

    I try to rephrase: show your .pkg file, and how you load the image in your .cpp file.
    Have you installed the file behind the 'here' on the page http://wiki.forum.nokia.com/index.ph...ded_panic_code
    Quote Originally Posted by page, "S60 3rd Edition"
    You can obtain a prebuilt sis file from here (file signature updated, valid until 2018)
    ?

  13. #13
    Super Contributor
    Join Date
    Jun 2008
    Posts
    593

    Re: Image not displayed in application

    actually i have already done it the other way and succeeded, but i want the image to be displayed on the whole screen , & so i want to make the size dynamic...
    now that is only possible from LayoutControls() SetExtent()..
    but as i have just added some lines of code to include the image, it does not give me that method for setting Size...

    i have done it as follows:
    void CWelcome::InitializeControlsL()
    {
    iBodyimageBitmap = iEikonEnv->CreateBitmapL(KMultiBitmapFilename,EMbmVaultacall1352x416);
    }

    void CWelcome:raw( const TRect& aRect ) const
    {
    CWindowGc& gc = SystemGc();
    gc.BitBlt(Rect().iTl,iBodyimageBitmap);
    }
    if u just tell me how to adjust image dynamically according to screen size, it wud b helpfull..

  14. #14
    Super Contributor
    Join Date
    Jun 2008
    Posts
    593

    Re: Image not displayed in application

    i have not included anything in my .cpp or .pkg file...
    wen u load an image from the UI design, it automatically includes the required things in your code...

    ; demo2.pkg
    ; This is an auto-generated PKG file by Carbide.
    ; This file uses variables specific to Carbide builds that will not work
    ; on command-line builds. If you want to use this generated PKG file from the
    ; command-line tools you will need to modify the variables with the appropriate
    ; values: $(EPOCROOT), $(PLATFORM), $(TARGET)
    ; Also, the resource file entries should be changed to match the language
    ; used in the build. For example, if building for LANGUAGE_01, change the file
    ; extensions .rsc to .r01.
    ;
    ;Language - standard language definitions
    &EN

    ; standard SIS file header
    #{"demo2"},(0xE54CE0AE),1,0,0

    ;Localised Vendor name
    %{"Vendor-EN"}

    ;Unique Vendor name
    :"Vendor"

    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}

    ;Files to install
    ;You should change the source paths to match that of your environment
    ;<source> <destination>
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\demo2.exe" -"!:\sys\bin\demo2.exe"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\demo2.r01" -"!:\resource\apps\demo2.r01"
    "$(EPOCROOT)Epoc32\data\z\private\10003a3f\apps\demo2_reg.r01" -"!:\private\10003a3f\import\apps\demo2_reg.r01"
    "$(EPOCROOT)epoc32\data\z\resource\apps\demo2_aif.mif" -"!:\resource\apps\demo2_aif.mif"
    "$(EPOCROOT)epoc32\data\z\resource\apps\demo2.mbm" -"!:\resource\apps\demo2.mbm"
    ; Add any installation notes if applicable
    ;"demo2.txt" -"!:\private\0xE54CE0AE\demo2.txt"

  15. #15
    Super Contributor
    Join Date
    Jun 2008
    Posts
    593

    Re: Image not displayed in application

    u r asked me to use Extended Panic Code method..
    but wen the application exits from N80, it doesnt show any alert msg like "Application Closed" or watever.. it simply exits...

    so hw will dat method b useful..??

Similar Threads

  1. How to change application icon displayed on the menu (urgent)?
    By okegame in forum Symbian Tools & SDKs
    Replies: 9
    Last Post: 2010-01-16, 14:14
  2. Svg image as the application background
    By hubbabubba in forum Symbian
    Replies: 3
    Last Post: 2006-07-04, 11:24
  3. Replies: 3
    Last Post: 2005-09-16, 03:37
  4. Can I install my application software into an image phone?
    By huangtx2004 in forum General Development Questions
    Replies: 3
    Last Post: 2004-08-23, 04:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×