×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 21
  1. #1
    Registered User
    Join Date
    Jul 2008
    Posts
    19

    [moved] nmake error

    HI,
    I have installed S60_3rd_FP2_SDK_2 and iam trying to build driver in windows command line using "albd build wins udeb", but iam getting following error:

    NMAKE : fatal error U1073: don't know how to make '"\S60\devices\S60_3rd_FP2_SDK_2\epoc32\release\WINS\udeb\EDLL.LIB"'


    Please let me know what can be done to resolve this error.

    Thanks

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: [moved] nmake error

    you must be running
    albd build winscw udeb

  3. #3
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,168

    Re: [moved] nmake error

    you could maybe try: "albd build winscw udeb" instead, or try building with Carbide.

  4. #4
    Registered User
    Join Date
    Jul 2008
    Posts
    19

    Re: [moved] nmake error

    HI,
    I dont have codewarrior installed. Iam having MS visual studio 6 with Service Pack6.

    May i kno what to be done to build with WINS?

    Regards

  5. #5
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: [moved] nmake error

    from v8.1a S60 SDKs stopped supporting WINS. and now the winscw compiler comes with SDK.

  6. #6
    Registered User
    Join Date
    Jul 2008
    Posts
    19

    Re: [moved] nmake error

    I have installed S60 FP2 SDK from nokia site. when i try to run
    using albd build winscw udeb, i get following error:

    ERROR: Unable to identify a valid CodeWarrior for Symbian OS installation


    Regards

  7. #7
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,168

    Re: [moved] nmake error

    You should install Carbide then, it has also free version, so just go and download it and try with it.

  8. #8
    Regular Contributor
    Join Date
    Nov 2005
    Location
    Aalborg, Denmark
    Posts
    296

    Re: [moved] nmake error

    Hi msgurikar,
    I'm not sure whether it'll work it's been a while since I've used the 2nd edition - but I assume you have Carbide.vs installed for visual studio?

    Try to run:
    C:\Nokia\Tools\Carbide_vs\WINSCW\bin\env_update.exe

    - M

  9. #9
    Registered User
    Join Date
    Jul 2008
    Posts
    19

    Re: [moved] nmake error

    I have also installed carbide, how to build using carbide?

  10. #10
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: [moved] nmake error

    bow try "albd build winscw udeb" from commandline. or Watch Screencasts in wiki and forum.nokia to know more about how to use carbide.c++

  11. #11
    Registered User
    Join Date
    Jul 2008
    Posts
    19

    Re: [moved] nmake error

    There is no bin directory under C:\Nokia\Tools\Carbide_vs\WINSCW .

    Only symbian_support, symbian_tools, and wrapper folders under C:\Nokia\Tools\Carbide_vs\WINSCW folder.

    Please help me.

  12. #12
    Regular Contributor
    Join Date
    Nov 2005
    Location
    Aalborg, Denmark
    Posts
    296

    Re: [moved] nmake error

    If you have installed carbide you can run from the start menu:

    Start -> Programs -> Carbide.c++ 1.3 -> Configure environment for WINSCW command line

    To enable builds from the command line..

    -M

  13. #13
    Registered User
    Join Date
    Jul 2008
    Posts
    19

    Re: [moved] nmake error

    Yes skumar, i did try that, but i get an error:

    ERROR: Unable to identify a valid CodeWarrior for Symbian OS installation

  14. #14
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: [moved] nmake error

    you can use the link "Configure environment for WINSCW command line" in Windows Menu -> "Carbide.c++ v1.3" then try running "albd build winscw udeb"

  15. #15
    Registered User
    Join Date
    Jul 2008
    Posts
    19

    Re: [moved] nmake error

    Ok. I will download Carbide.c++ 1.3 and try.
    Earlier i was mentioning about carbide.vs which gets integrated with visual studio. Now i will try with carbide.c++ 1.3.

    Keep you updated once i try that.

Similar Threads

  1. error including vector
    By Lichtens in forum Open C/C++
    Replies: 5
    Last Post: 2009-04-03, 14:19
  2. i cant build helloworld project
    By akhin in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2008-12-22, 12:38
  3. carbide build problem help please
    By berkcekisbas in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2006-09-26, 19:41
  4. NMAKE : fatal error U1077
    By murmur20 in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2005-10-18, 03:57
  5. S80 Platform SDK and Visual Studio .NET Linking Error
    By jayantjain in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2005-10-07, 22:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×