×

Discussion Board

Results 1 to 14 of 14
  1. #1
    Registered User
    Join Date
    Jun 2008
    Posts
    8

    Unhappy Program running on emulator but don't run on device.

    Hi.
    I'm heaving problem:
    Program works under emulator but on device even don't start. I seted User::Invariant(); in Uid CMyApplication::AppDllUid() for checking. But any error messages are displayed on device.
    What reason of this problem can be? Maybe stack size or something else. Can I view some system log or something else on device? I have N95.

  2. #2
    Super Contributor
    Join Date
    Jan 2007
    Location
    Bhubaneswar, India
    Posts
    1,189

    Re: Program running on emulator but don't run on device.

    -------------------------------------
    Thanks & Regards
    Ram
    Symbian OS 9.2/9.3,S60 3rd FP1/FP2,Carbide.c++v2.0

  3. #3
    Registered User
    Join Date
    Jun 2008
    Posts
    8

    Re: Program running on emulator but don't run on device.

    But on device I don't see any messages. I just running program and that's all. It looks like program even didn't start. I don't need extended panic code. I just wanted to be sure that program runs. But I can't see ane messages. Just nothing heppens after I start program on device.

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Program running on emulator but don't run on device.

    Just check the given link a bit more carefully.

  5. #5
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: Program running on emulator but don't run on device.

    Hi,
    If the panic code does not help,
    take logs and see upto which statement your code executes.

  6. #6
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: Program running on emulator but don't run on device.

    Quote Originally Posted by Super_Max_UA View Post
    But on device I don't see any messages.
    The screenshot in the Wiki comes from the emulator. Devices usually do not show anything by default. Install the file from the Wiki page.

  7. #7
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,533

    Re: Program running on emulator but don't run on device.

    Quote Originally Posted by Super_Max_UA View Post
    But on device I don't see any messages. I just running program and that's all. It looks like program even didn't start. I don't need extended panic code. I just wanted to be sure that program runs. But I can't see ane messages. Just nothing heppens after I start program on device.
    The program doesnt even start, meaning that there might be some panic which the device is not showing, and thats why you need to enable it..and thats the reason you need the above trick of 'Extended Panic Code'. So dismissing it as 'you dont need it' is a little prejudiced. Atleast give a try to what others suggest out of their own experience.

  8. #8
    Registered User
    Join Date
    Mar 2008
    Posts
    12

    Re: Program running on emulator but don't run on device.

    Hi guys, I have same problem with Super_Max_UA
    I read RB_Sahu's link and installed PanicObserver, because i can't create /resource/ErrRd(don't know why, i use E63). then the result is the Panic message box show up:
    thread: Main
    Category: Kill
    reason: 0
    status: -13

    so, What does it mean?
    Tks for advice.

  9. #9
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Program running on emulator but don't run on device.

    Kill-0-Kill is usually indicating normal exit. though if it comes when applciation is being launched, then it could also indicate a missing statically linked library.

  10. #10
    Registered User
    Join Date
    Mar 2008
    Posts
    12

    Re: Program running on emulator but don't run on device.

    Hi symbianyucca, my application use c/c++ plugged-in library and some .h, .c files, but it was built fine with gcce config,do you have some warning about it.

  11. #11
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Program running on emulator but don't run on device.

    Check the library list you have added into your mmp file, and see if there would be anything that might not be available on that device where you are trying to run it in.

  12. #12
    Registered User
    Join Date
    Mar 2008
    Posts
    12

    Re: Program running on emulator but don't run on device.

    There are no libraries strange. I list all here
    Code:
    LIBRARY			euser.lib apparc.lib cone.lib eikcore.lib avkon.lib
    LIBRARY			commonengine.lib efsrv.lib estor.lib eikcoctl.lib eikdlg.lib 
    LIBRARY			eikctl.lib bafl.lib fbscli.lib aknnotify.lib aknicon.lib
    LIBRARY			etext.lib gdi.lib egul.lib insock.lib
    LIBRARY			ecom.lib InetProtUtil.lib bitgdi.lib
    this is my PKG file
    Code:
    ; PokerPlaying.pkg
    ; This is an auto-generated PKG file by Carbide.
    ; This file uses variables specific to Carbide builds that will not work
    ; on command-line builds. If you want to use this generated PKG file from the
    ; command-line tools you will need to modify the variables with the appropriate
    ; values: $(EPOCROOT), $(PLATFORM), $(TARGET)
    ; Also, the resource file entries should be changed to match the language
    ; used in the build. For example, if building for LANGUAGE_01, change the file
    ; extensions .rsc to .r01.
    ;
    ;Language - standard language definitions
    &EN
    
    ; standard SIS file header
    #{"PokerPlaying"},(0xECE85C35),1,0,0
    
    ;Localised Vendor name
    %{"Vendor-EN"}
    
    ;Unique Vendor name
    :"Vendor"
    
    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}
    
    ;Files to install
    ;You should change the source paths to match that of your environment
    ;<source> <destination>
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\PokerPlaying.exe"		-"!:\sys\bin\PokerPlaying.exe"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\PokerPlaying.r01"		-"!:\resource\apps\PokerPlaying.r01"
    "$(EPOCROOT)Epoc32\data\z\private\10003a3f\apps\PokerPlaying_reg.r01"	-"!:\private\10003a3f\import\apps\PokerPlaying_reg.r01"
    "$(EPOCROOT)epoc32\data\z\resource\apps\PokerPlaying_aif.mif" -"!:\resource\apps\PokerPlaying_aif.mif"
    "$(EPOCROOT)epoc32\data\z\resource\apps\PokerPlaying.mbm" -"!:\resource\apps\PokerPlaying.mbm"
    ; Add any installation notes if applicable
    ;"PokerPlaying.txt"					  -"!:\private\0xECE85C35\PokerPlaying.txt"
    and i use another .mbm file that not listed in pkg file.
    are there any error?

  13. #13
    Registered User
    Join Date
    Jul 2007
    Location
    Noida
    Posts
    1,503

    Re: Program running on emulator but don't run on device.

    you should install YTask Crash monitor from drJukka.com and set on the crash monitor, then launch your application, if any crashes comes crah monitor will show the reason to you.

    Or creates log files in your code nad get where application is getting crash.
    Regards,
    Amit


    ****"Putting a Smile on other's faces is the essence of true Happiness"****

  14. #14
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Program running on emulator but don't run on device.

    Yep, I would re-check teh process exit code, those libraries look ok to me, so wouldn't think that they would cause any problems.

Similar Threads

  1. I can't connect to my pc while a device discovery is running on it
    By enjutapeich in forum Bluetooth Technology
    Replies: 3
    Last Post: 2008-07-11, 12:55
  2. how to run jar file in device
    By mobileRock in forum Mobile Java General
    Replies: 2
    Last Post: 2007-11-28, 09:39
  3. Run more than one Python scripts on Device
    By croozeus in forum Symbian
    Replies: 0
    Last Post: 2007-10-13, 13:20
  4. Replies: 0
    Last Post: 2004-03-30, 00:13
  5. Replies: 1
    Last Post: 2002-06-11, 13:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×