×

Discussion Board

Results 1 to 11 of 11
  1. #1
    Registered User
    Join Date
    Aug 2008
    Posts
    11

    Carbide ui 3.2 fuzzy background problem and few others on N78

    Hello,

    I'm new to Carbide ui and the whole theme making thing, but I've so far managed to make pretty good theme. I have few problems though.

    I'm trying to make a background with an image. Once I put the image to carbide (via select the file option) it looks good, but when I install it on my phone N78 the background looks fuzzy, like it has been resized or changed somehow. If you look far it looks okay but when you take a closer look it has weird "lines" in it and the colors change a bit. I have tried to upload the image in 320x320 bmp, jpg, png, and in larger or smaller sizes, always the same result. Same problem with N81 8GB. I made another background image that was only one color red and it looked good. Why does my different colored background look weird, any ideas? Which format and size should it be?

    Also I have changed the text color in the idle screen (the texts that are in the middle, for example "wlan scanning off") to white and in my N78 it looks good. However in N81 8GB the text is still black. How come? N78 is s60 3rd edition FP 2 and N81 8GB FP 1, but I thought the same file should work for both since there's only one option in carbide ui, for feature packs 1 & 2.

    I've also been wondering about something. If you click "colors" in carbide it shows a list of colors right before the categories. If I change a color from this list does it change all the colors using that specific color in my theme? Or what does it change?

    Fourth and last question, how could I take screenshots of my phone screen easily?

    I'd really appreciate some advice

  2. #2
    Regular Contributor
    Join Date
    Sep 2006
    Posts
    214

    Re: Carbide ui 3.2 fuzzy background problem and few others on N78



    Hello jemima06,

    1. As far as possible, the background images used in CarbideUI should have the size that's indicated in the Properties palette when clicking on them.
    In your case, this would be 240x320 pixels for the Background and Idle Background images respectively.



    2. Which text do you mean exactly? The "Operator" text on the Idle Screen? (What's the text called in the CarbideUI's colours section?)

    3. Yes.

    4. See this thread for info.

  3. #3
    Registered User
    Join Date
    Aug 2008
    Posts
    11

    Re: Carbide ui 3.2 fuzzy background problem and few others on N78

    Hello and thank you for your answer.

    Other problems are already solved except the one about the background.

    It looks good and smooth on carbide ui but this is how it looks on the phone:



    The picture is 240x320. Any ideas why does that happen?

  4. #4
    Regular Contributor
    Join Date
    Sep 2006
    Posts
    214

    Re: Carbide ui 3.2 fuzzy background problem and few others on N78



    During the packaging process, all jpeg, gif and png images used in a theme are converted to bmp format which shows this banding effect. You can avoid the effect by using svg images created in a vector graphics program like Adobe Illustrator or the free Inkscape.
    Last edited by Le Pharao; 2008-08-20 at 20:23.

  5. #5
    Registered User
    Join Date
    Aug 2008
    Posts
    11

    Re: Carbide ui 3.2 fuzzy background problem and few others on N78

    Thank you for your reply, again.

    One more question:
    How can I completely remove a theme folder from my workspace? If I simply delete it and try to save another theme by the name of the deleted theme it says it already exists.

    For example, if I had a two themes called White and White2 and I wanted to change the name of White2 to White so that original White would be replaced, how can I do that? And after that completely remove White2.

  6. #6
    Regular Contributor
    Join Date
    Sep 2006
    Posts
    214

    Re: Carbide ui 3.2 fuzzy background problem and few others on N78



    Right-click the "White" theme folder in the Navigator palette and select "Delete":



    Then select "Also delete contents..." from the popup menu.

    Now open "White 2", save it as "White" and delete "White2" as described above.

  7. #7
    Registered User
    Join Date
    Aug 2008
    Posts
    11

    Re: Carbide ui 3.2 fuzzy background problem and few others on N78

    I'm starting to feel really stubid here, but I still can't get the background work.

    I opened the original background in inkscape and saved as .svg and it looks good. When I select the .svg file for background in carbide it gives this weird icon.



    What am I still doing wrong?

    Another question, how do you change the background of S60 3rd edition FP2 landscape mode music player? I can't seem to find the element that changes that. It's white even though I've changed all other backgrounds black.
    Last edited by jemima06; 2008-08-22 at 19:02.

  8. #8
    Regular Contributor
    Join Date
    Sep 2006
    Posts
    214

    Re: Carbide ui 3.2 fuzzy background problem and few others on N78



    Hmmm... does it work when you create a 240x320 svg from scratch in Inkscape, save it to your hard drive and then copy-paste it to the CarbideUI?

    As for the Music Player Background, that seems to be a bug ‒ no matter whether a phone is S60 3d Edition, 3d Edition Feature Pack or 2, the theme always shows the "Music Player 1" Background.

  9. #9
    Registered User
    Join Date
    Aug 2008
    Posts
    4

    Re: Carbide ui 3.2 fuzzy background problem and few others on N78

    I have the same problem with the background image and I've tried with an svg 320x240 image created with inkscape and it doesn't work.
    When I had a N70 I created lots of themes using bmp images and I never had a problem, in addition it was much easier than using .svg images. Now I have a N73, which is supposedly better than N70 and I have the problem of the bmp banding effect. This isn't normal. ¿There isn't any solution?

  10. #10
    Registered User
    Join Date
    Aug 2008
    Posts
    11

    Re: Carbide ui 3.2 fuzzy background problem and few others on N78

    That problem got solved when I created the image from scratch with inkscape, instead of pasting a bmp image to inkscape and saving as .svg. Now all images look good both on carbide and on phone.

  11. #11
    Registered User
    Join Date
    Aug 2008
    Posts
    4

    Carbide ui 3.2 fuzzy background problem and few others on N78

    I don't know how to create a good image by miself, I only can download them form the internet and then use them as bmp images, so I can't create an image with inkscape. I'm sure there is a way to use bmp images as background withouth banding effect. Bmp format supports 24 bits/pixel (true color), I think carbide.ui converts the images in a bad way.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×