×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jul 2008
    Posts
    33

    Failed while linking in CW compiling for GCCE UDEB

    The compiler I'm using is CW for Symbian V3.1. I did a successful compiling and linkage for WINSCW, but when I changed it to GCCE UDEB, I got two linkage ERROR below:

    . Link Error: The Win32 CreateProcess call failed, probably because the command line length exceeds the OS’s limit.There may be too many objects to link, or too many access paths. GetLastError() returned ERROR_INVALID_PARAMETER.
    . Link Error: Unable to call command line tool. Check your PATH environment variable.

    Yes, it is a large project, but I do not know how to solve the problems..
    Thanks!!

  2. #2
    Nokia Developer Expert
    Join Date
    Dec 2004
    Location
    Austin, TX
    Posts
    399

    Re: Failed while linking in CW compiling for GCCE UDEB

    Quote Originally Posted by joe5160 View Post

    Yes, it is a large project, but I do not know how to solve the problems..
    Thanks!!
    Try to 'subst' your SDK drive. It has been discussed on this forum so you should be able to find more info.

    Tim

  3. #3
    Registered User
    Join Date
    Jul 2008
    Posts
    33

    Re: Failed while linking in CW compiling for GCCE UDEB

    The SDK directory is C:\Symbian\9.1\S60_3rd. I did not find any more info.. Please give me a link to the page.. thanks!!

  4. #4
    Nokia Developer Champion
    Join Date
    Oct 2006
    Location
    Bangalore, India
    Posts
    1,572

    Re: Failed while linking in CW compiling for GCCE UDEB

    the problem seems to be that the path length exceeds 255...

    so there are two things to do:

    1. Suppose you have your project like: c:\myname\projects\MYPROJECT\...
    then move it outside like:
    c:\MYPROJECT and try compiling.

    2. If that doesn't work, then other way would be, run this command in the command prompt:
    subst s: C:\Symbian\9.1\S60_3rd"
    and then set epocroot to s:\
    and now you can try compiling again, but by putting your project in the s: drive created.


    NOTE: this is not related to your query, however I have noticed that you are using s30 3rd edition initial sdk. Please use the MR (maintenance release) version of 3rd edition and 3rd edition itself is not recommended.

    hope this helps :)
    Amit Kankani
    Nokia Developer Champion

Similar Threads

  1. S60 2nd to 3rd/ PlatformSecurity / Capabilities
    By jarkoos in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 4
    Last Post: 2007-04-14, 14:08
  2. CreateProcess call failed (winscw udeb)
    By MethodSolutions in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2007-02-27, 09:03
  3. [newbie here] Link error
    By xitpu in forum Symbian
    Replies: 3
    Last Post: 2007-01-24, 16:53
  4. Replies: 2
    Last Post: 2006-10-05, 13:42
  5. could not find thread.mbg and thread.rsg
    By deercrane in forum Symbian
    Replies: 3
    Last Post: 2006-04-18, 09:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×