×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Jan 2008
    Posts
    25

    Eclipse / Proguard Issue

    Hi.

    I'm using Eclipse and Ant to develop a J2ME application, and when I double click on the make-obfuscated-jar target, I get the following error:

    Code:
    [wtkobfuscate] java.lang.NoClassDefFoundError: proguard/ProGuard
    [wtkobfuscate] Exception in thread "main"
    Anyone any idea?

    Thanks
    R
    "I've got Heat on DVD. We could be watching Robert De Niro, and Al Pacino at home right now instead of this stupid play." - Jeremy from Peep Show

    "I'm going to pretend I am watching Heat." Mark from Peep Show

  2. #2
    Registered User
    Join Date
    Jan 2008
    Posts
    25

    Re: Eclipse / Proguard Issue

    Anyone any ideas on this? I really don't know how to fix it.
    "I've got Heat on DVD. We could be watching Robert De Niro, and Al Pacino at home right now instead of this stupid play." - Jeremy from Peep Show

    "I'm going to pretend I am watching Heat." Mark from Peep Show

  3. #3
    Registered User
    Join Date
    Jan 2008
    Posts
    25

    Re: Eclipse / Proguard Issue

    I sorted the error, I actually forgot to set up the Environment Variable for Proguard's root directory, as that is what the build.xml file was looking for when obfuscating, thanks anyway.
    "I've got Heat on DVD. We could be watching Robert De Niro, and Al Pacino at home right now instead of this stupid play." - Jeremy from Peep Show

    "I'm going to pretend I am watching Heat." Mark from Peep Show

Similar Threads

  1. Please HELP. Impossible Eclipse + Carbide.j
    By videador in forum Mobile Java Tools & SDKs
    Replies: 13
    Last Post: 2007-03-22, 06:06
  2. Eclipse 3.1.2 || Eclipse 3.2
    By rolecram in forum Mobile Java Tools & SDKs
    Replies: 8
    Last Post: 2007-03-12, 23:55
  3. Replies: 5
    Last Post: 2007-02-25, 15:10
  4. ProGuard in Carbide.J and Eclipse J2ME
    By BlueLava in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2006-10-27, 21:49
  5. How do you get proguard to work with nokiaui.zip in eclipse?
    By hooble in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2006-06-11, 13:57

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •