×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    Regular Contributor
    Join Date
    May 2008
    Location
    India
    Posts
    172

    Question S60 2nd edn FP2 - sis error - File Corrupt

    Hi All,

    I have been developing apps in S60 3rd edition, now, I need to develope apps for S60 2nd edition FP2 devices. I have created a small application and need to build it. I am using Carbide.c++ v 1.2, S60 2nd edition FP2 CW SDK. I have four options to choose from -

    1. Emulator Debug (WINSCW)[S60_2nd_FP2_CW],
    2. Emulator Release (WINSCW)[S60_2nd_FP2_CW],
    3. Phone Release (ARMI)[S60_2nd_FP2_CW],
    4. Phone Release (THUMB)[S60_2nd_FP2_CW].
    What should I use to build the application for Nokia 6680?

    I used the 2nd option and tried to install the app and got "File Corrupt" error. Where as if I choose, 3 or 4 I get "file not found" error as the .app file is not found.

    My .pkg file has the following Platform ID for S60 2nd Edition FP2 - 0x10200BAB.

    Where exactly am I going wrong?

    Thanks,

    Shanker

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: S60 2nd edn FP2 - sis error - File Corrupt

    Quote Originally Posted by nair.shanker View Post
    Hi All,

    I have been developing apps in S60 3rd edition, now, I need to develope apps for S60 2nd edition FP2 devices. I have created a small application and need to build it. I am using Carbide.c++ v 1.2, S60 2nd edition FP2 CW SDK. I have four options to choose from -



    What should I use to build the application for Nokia 6680?

    I used the 2nd option and tried to install the app and got "File Corrupt" error. Where as if I choose, 3 or 4 I get "file not found" error as the .app file is not found.

    My .pkg file has the following Platform ID for S60 2nd Edition FP2 - 0x10200BAB.

    Where exactly am I going wrong?

    Thanks,

    Shanker
    1. You are getting "File Corrupt" as you are trying to install Emulator version on device, but i really doubt as carbide.c++ does not build a sis for emulator versions.

    2. You are getting "file not found" as your .app file is not build or have some problem.

    Can you tell us how you downgrade your application from v3.x to v2.x

  3. #3
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,539

    Re: S60 2nd edn FP2 - sis error - File Corrupt

    Quote Originally Posted by nair.shanker View Post
    Hi All,

    I have been developing apps in S60 3rd edition, now, I need to develope apps for S60 2nd edition FP2 devices. I have created a small application and need to build it. I am using Carbide.c++ v 1.2, S60 2nd edition FP2 CW SDK. I have four options to choose from -



    What should I use to build the application for Nokia 6680?

    I used the 2nd option and tried to install the app and got "File Corrupt" error. Where as if I choose, 3 or 4 I get "file not found" error as the .app file is not found.

    My .pkg file has the following Platform ID for S60 2nd Edition FP2 - 0x10200BAB.

    Where exactly am I going wrong?

    Thanks,

    Shanker
    Surely 1 and 2 options as they say are for emulator. And when you use the 3 and 4, you get file not found. That indicates that your build is not error free, or one could say that it does not find all the files mentioned in the pkg file to 'package' it. So check the console to see where the problem lies/what file is not getting created/if the path you have given for a particular file is wrong in the pkg.

  4. #4
    Regular Contributor
    Join Date
    May 2008
    Location
    India
    Posts
    172

    Question Re: S60 2nd edn FP2 - sis error - File Corrupt

    Hi,

    Thanks for your quick reply.
    Symbian_Neil, you, were right, I have two errors during build. I have never come across these errors, hope you can help me out with this.

    1. ERROR: Dll 'AppName[02524BC7].APP' has initialised data.
    2. ERROR: Dll 'AppName[02524BC7].APP' has uninitialised data.
    I found an article which says that some static libraries may have been used, that, it could be traced by having look at the .mmp file. I did just that and found no static libraries being used. Then, how do these errors occur? Please help.

    Thanks,

    Shanker

    PS - Answer to skumar_rao's query regarding downgrading the application from v3.x to v2.x. I am recreating the application from the scratch.

  5. #5
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,539

    Re: S60 2nd edn FP2 - sis error - File Corrupt

    Quite honestly I havent come accross an error of that kind, so am not too sure. But my first try would be to do a 'reallyclean' build.

  6. #6
    Regular Contributor
    Join Date
    May 2008
    Location
    India
    Posts
    172

    Re: S60 2nd edn FP2 - sis error - File Corrupt

    Hi Neil,

    Tried that out, but, I still get the error.

    Thanks,

    Shanker

  7. #7
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: S60 2nd edn FP2 - sis error - File Corrupt

    http://www3.symbian.com/faq.nsf/0/ca...2?OpenDocument Will help. I wonder how is your V3.x was working..

  8. #8
    Regular Contributor
    Join Date
    May 2008
    Location
    India
    Posts
    172

    Question Re: S60 2nd edn FP2 - sis error - File Corrupt

    Hi All,

    One basic question. Do I need to sign the .sis file using developer certificate for S60 2nd edition FP 2 devices.
    I have successfully built an application for S60 2nd edition FP 2 devices. I use makesis command to create a sisfile. But, when I try and install the sis file using USB cable and of course Nokia PC Suite, the device shows me an error message - File corrupted. The same application seems to run as required on an emulator. Please help.

    Thanks,

    Shanker

  9. #9
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: S60 2nd edn FP2 - sis error - File Corrupt

    For Pre-V3 SDK/devices signing is optional. make sure you have all the correct paths in pkg file.

    If still you are facing problem, post here your pkg file.

  10. #10
    Regular Contributor
    Join Date
    May 2008
    Location
    India
    Posts
    172

    Post Re: S60 2nd edn FP2 - sis error - File Corrupt

    Hi skumar_rao,

    Herez my .pkg file, this app has been swiped from S60 2nd edition FP 2 SDK, samples -

    Code:
    ; grid.pkg
    
    ; Languages
    &EN
    
    ; Header
    #{"Grid Example"},(0x10005C32),1,0,0
    
    ;Supports Series 60 v 2.0
    (0x10200BAB), 0, 0, 0, {"Series60ProductID FP2"}
    
    ;Localised Vendor name
    %{"Vendor Name-OVS"}
    
    ;Unique Vendor name
    :"OVS"
    
    ; Target
    "C:\Symbian\8.0a\S60_2nd_FP2_CW\epoc32\data\z\system\apps\AknExGrid\AknExGrid.aif"-"!:\system\apps\AknExGrid\AknExGrid.aif"
    "C:\Symbian\8.0a\S60_2nd_FP2_CW\epoc32\release\thumb\urel\AknExGrid.app"-"!:\system\apps\AknExGrid\AknExGrid.app"
    "C:\Symbian\8.0a\S60_2nd_FP2_CW\epoc32\data\z\system\apps\AknExGrid\AknExGrid.mbm"-"!:\system\apps\AknExGrid\AknExGrid.mbm"
    "C:\Symbian\8.0a\S60_2nd_FP2_CW\epoc32\data\z\system\apps\AknExGrid\AknExGrid.rsc"-"!:\system\apps\AknExGrid\AknExGrid.rsc"
    "C:\Symbian\8.0a\S60_2nd_FP2_CW\epoc32\data\z\system\apps\AknExGrid\AknExGrid_caption.rsc"-"!:\system\apps\AknExGrid\AknExGrid_caption.rsc"
    Thanks,

    Shanker

  11. #11
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: S60 2nd edn FP2 - sis error - File Corrupt

    have you tried using armi build ?
    I also suggest you to copy the sis file to you phone memory card and install from there for testing that your USB cable is not the problem.

  12. #12
    Regular Contributor
    Join Date
    May 2008
    Location
    India
    Posts
    172

    Re: S60 2nd edn FP2 - sis error - File Corrupt

    No go!
    It still doesn't work.
    Used ARMI build.
    Copied .SIS to memory card and installed from there.
    Got "File corrupted" error.

    Shanker

  13. #13
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: S60 2nd edn FP2 - sis error - File Corrupt

    also try clean building

  14. #14
    Regular Contributor
    Join Date
    May 2008
    Location
    India
    Posts
    172

    Re: S60 2nd edn FP2 - sis error - File Corrupt

    Tried that too.
    Didn't work.
    Do you think there is something wrong with the device? Unfortunately, I don't have another S60 2nd edition FP2 device, other than the 6680. This device has a history of problems. I have tried formating it but have failed to do so. Is there some facility like the RDA where I could test the application on S60 2nd edition FP2 devices?

    Shanker

  15. #15
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,689

    Re: S60 2nd edn FP2 - sis error - File Corrupt

    Actually what you show is a modified .pkg file.
    - Symbian 9-specific headers appear (vendor, localised vendor), which is wrong
    - you have modified the platform-UID to S60 2nd FP2 (which is OK)

    It is always an option to try the examples in their original form...

Similar Threads

  1. S60 2nd ed FP2 Task List Problem
    By dave-rv in forum Symbian
    Replies: 3
    Last Post: 2007-12-12, 10:09
  2. Get CellId,IMEI,NetworkInfo on S60 2nd FP2
    By Psyve in forum Symbian
    Replies: 8
    Last Post: 2007-09-03, 10:41
  3. S60 2nd Fp2 Microsoft Visual Studio 6 issue
    By sipshakers in forum Symbian
    Replies: 2
    Last Post: 2006-08-23, 05:57
  4. EPOCROOT error in S60 SDK 2nd ed. FP2
    By abolfoooud in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2005-01-25, 22:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×