×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    May 2008
    Posts
    11

    nokia E50 can't send udp data

    hi!
    I prepared code withc active object which perfectly sends data both udp and tcp on the emulator.
    When I start it on my phone (nokia e50), I select IAP, gprs connectoin is established and ... nothing.
    log->packet data shows 0B/0B sent/received and I don't receive any data on my udp/tcp server...

    Any ideas what is happening?

    Best regards,
    Slavomir

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,694

    Re: nokia E50 can't send udp data

    You should provide as much details as you can. Almost all method of RSocket provides some result, either as return code or via the passed TRequestStatus. You should check, and probably log everything you can.
    Networking is non-trivial, especially via GPRS (in case of WLAN, you could capture and log traffic on the wired side of the router).

  3. #3
    Registered User
    Join Date
    May 2008
    Posts
    11

    Re: nokia E50 can't send udp data

    Ok, RSocket.Send method (I change protocol to TCP) return (with iStatus) :
    -46 (what means : KErrPermissionDenied).

    What should I do in this case?

    Regards,
    Slavomir

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,694

    Re: nokia E50 can't send udp data

    In that case you are missing a capability. Since your code runs in the emulator, you can check its logfile (http://wiki.forum.nokia.com/index.php/Epocwind.out), a line starting with platsec warning is going to tell you which is that capability.

  5. #5
    Registered User
    Join Date
    May 2008
    Posts
    11

    Re: nokia E50 can't send udp data

    This is my epoc.ini in epoc32/data :
    PlatSecEnforcement ON
    PlatSecDiagnostics ON
    PlatSecProcessIsolation ON
    PlatSecEnforceSysBin ON
    PlatSecDisabledCaps NONE

    But emulator doesn't show any restriction and notes or security warning...

    I'm starting emulator in debug mode from my carbide.

    Slavomir

  6. #6
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,694

    Re: nokia E50 can't send udp data

    Strange. "PlatSecEnforcement ON" should give the same behaviour on the emulator. Have you specified NetworkServices capability in the .mmp file?

  7. #7
    Registered User
    Join Date
    May 2008
    Posts
    11

    Re: nokia E50 can't send udp data

    Ok, I added NetworkServices in mmp file and my app sends data on the phone finally
    But I still don't get why emulator didn't warn me about this issue...

Similar Threads

  1. Series 60 Concept Emulator (SDK Beta 0.2 Linux) not working
    By mattbee in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2003-06-10, 11:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×