×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    1

    AT Commands via bluetooth serial port on 6310i

    Hi,

    I've written a small program to send AT commands to a 6310i over a virtual serial port via Bluetooth. I can get quite a bit of information across the link but it seems quite unstable. Does anyone know of any protocol or special serial port settings/manipulation that I need to do be using ? My source is in C++. I seem to be getting the results of my command after I send another command, ie the phone seems to be a command behind all of the time. I send AT and intially get no response then I send it again and get OK. If I send another command then I get the OK back for, I suppose, the second AT.

    Any help would be great

    Thanks

    Peter

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    2

    RE: AT Commands via bluetooth serial port on 6310i

    Hi Peter,

    Maybe there is a simple explanation. I suppose you have created a stream to send the 6310i these AT commands. Did you forget to actually "flush" the stream after you send a command? That could explain the symptoms.

    Robert

  3. #3
    Registered User
    Join Date
    Aug 2008
    Posts
    8

    Re: AT Commands via bluetooth serial port on 6310i

    Hmm.. AT Commands,
    via bluetooth?!
    lack of experience

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×