×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Sep 2008
    Posts
    4

    VC2005 error: >Error during set-up building environment:

    Hello!
    I have some error in VC2005 (S60 3.0 Maintenance SDK), i don't know what i shall to do:

    It happens in simply wizard-creating GUI/DLL application..
    Sorry for english =)


    Updating Symbian1Dll.mmp based on Deb_S60_30M_WINSCW
    Update of mmp file not needed
    WINSCW (emulator) build
    Set build parameters for Deb_S60_30M_WINSCW
    1>------ Rebuild All started: Project: Symbian1Dll, Configuration: Deb_S60_30M_WINSCW Win32 ------
    1>Deleting intermediate and output files for project 'Symbian1Dll', configuration 'Deb_S60_30M_WINSCW|Win32'
    1>Performing Pre-Build Event...
    1>* Current build configuration: WINSCW UDEB
    1>Compiling...
    1>epocroot = \Symbian\9.1\S60_3rd_MR\
    1>* mwccsym2.exe -g -O0 -inline off -sym codeview_new -wchar_t off -align 4 -warnings on -w nohidevirtual,nounusedexpr -msgstyle msvs -enum int -ext ms -str pool -nostdinc -d _DEBUG -d _UNICODE -d "__SYMBIAN32__" -d "__SERIES60_30__" -d "__SERIES60_3X__" -d "__SUPPORT_CPP_EXCEPTIONS__" -d "__DLL__" -d "__WINSCW__" -d "__WINS__" -d "__CW32__" -d "_DEBUG" -d "_UNICODE" -d "_WINDLL" -cwd source -i- -i "inc" -i "C:\Symbian\9.1\S60_3rd_MR\\epoc32\include" -i C:\Symbian\9.1\S60_3rd_MR\epoc32\include\variant -include symbian_os_v9.1.hrh -c .\group\symbian1dll.uid.cpp -o "Deb_S60_30M_WINSCW\symbian1dll.uid.obj"
    1>epocroot = \Symbian\9.1\S60_3rd_MR\
    1>* mwccsym2.exe -g -O0 -inline off -sym codeview_new -wchar_t off -align 4 -warnings on -w nohidevirtual,nounusedexpr -msgstyle msvs -enum int -ext ms -str pool -nostdinc -d _DEBUG -d _UNICODE -d "__SYMBIAN32__" -d "__SERIES60_30__" -d "__SERIES60_3X__" -d "__SUPPORT_CPP_EXCEPTIONS__" -d "__DLL__" -d "__WINSCW__" -d "__WINS__" -d "__CW32__" -d "_DEBUG" -d "_UNICODE" -d "_WINDLL" -cwd source -i- -i "inc" -i "C:\Symbian\9.1\S60_3rd_MR\\epoc32\include" -i C:\Symbian\9.1\S60_3rd_MR\epoc32\include\variant -include symbian_os_v9.1.hrh -c .\src\Symbian1Dll.cpp -o "Deb_S60_30M_WINSCW\Symbian1Dll.obj"
    1>Linking...
    1>MSL_All_MSE_Symbian_D.lib(globdest.c.obj) : warning LNK4006: ___register_global_object already defined in edll.lib(uc_dllx.obj); second definition ignored
    1>MSL_All_MSE_Symbian_D.lib(globdest.c.obj) : warning LNK4006: ___destroy_global_chain already defined in edll.lib(uc_dllx.obj); second definition ignored
    1> Creating library C:\Symbian\9.1\S60_3rd_MR\\Epoc32\release\winscw\udeb\Symbian1Dll.lib and object C:\Symbian\9.1\S60_3rd_MR\\Epoc32\release\winscw\udeb\Symbian1Dll.exp
    1>Build log was saved at "file://c:\Users\Игорь\Desktop\Symbian1\Symbian1\Symbian1Dll\Deb_S60_30M_WINSCW\BuildLog.htm"
    1>Symbian1Dll - 0 error(s), 2 warning(s)
    Unset build parameters for Deb_S60_30M_WINSCW
    Updating Symbian1Gui.mmp based on Deb_S60_30M_WINSCW
    Error during set-up building environment: Object reference not set to an instance of an object.
    2>------ Rebuild All started: Project: Symbian1Gui, Configuration: Deb_S60_30M_WINSCW Win32 ------
    2>Deleting intermediate and output files for project 'Symbian1Gui', configuration 'Deb_S60_30M_WINSCW|Win32'
    2>Performing Pre-Build Event...
    2>* Current build configuration: WINSCW UDEB
    2>Building help file
    2>Building help file c:\Users\Игорь\Desktop\Symbian1\Symbian1\Symbian1Gui\help\Symbian1Gui.cshlp
    2>EpocRoot = \Symbian\9.1\S60_3rd_MR\
    2>* C:\Symbian\9.1\S60_3rd_MR\\epoc32\tools\cshlpcmp.bat c:\Users\Игорь\Desktop\Symbian1\Symbian1\Symbian1Gui\help\Symbian1Gui.cshlp
    2>c:\Users\╚уюЁ№\Desktop\Symbian1\Symbian1\Symbian1Gui\help\Symbian1Gui.cshlp is not a recognised command line argument
    2>cshlpcmp Version 011
    2>cshlpcmp projectfile [-lflogfile] [-odoutputdir] [-wdworkingdir]
    2>where
    2> projectfile is the name of the cshlpcmp project file.
    2> The file extension must be given.
    2> logfile is the name of an optional log file
    2> outputdir is an optional override to the <output/> projectfile value
    2> workingdir is an optional override to the <working/> projectfile value
    2>If no arguments are given this help is displayed
    2>This software is based in part on the work of the
    2>Independent JPEG Group.
    2>c:\Users\╚уюЁ№\Desktop\Symbian1\Symbian1\Symbian1Gui\help\Symbian1Gui.cshlp is not a recognised command line argumentcshlpcmp Version 011cshlpcmp projectfile [-lflogfile] [-odoutputdir] [-wdworkingdir]where projectfile is the name of the cshlpcmp project file. The file extension must be given. logfile is the name of an optional log file outputdir is an optional override to the <output/> projectfile value workingdir is an optional override to the <working/> projectfile valueIf no arguments are given this help is displayedThis software is based in part on the work of theIndependent JPEG Group.
    2>CompileItem: error HLP: Could not copy c:\Users\Игорь\Desktop\Symbian1\Symbian1\Symbian1Gui\help\Symbian1Gui_0xe08cc817.hlp to C:\Symbian\9.1\S60_3rd_MR\\Epoc32\winscw\c\resource\help\Symbian1Gui_0xe08cc817.hlp, reason: Файл "c:\Users\Игорь\Desktop\Symbian1\Symbian1\Symbian1Gui\help\Symbian1Gui_0xe08cc817.hlp" не найден.
    2>Project : error PRJ0019: A tool returned an error code from "Building help file"
    2>Build log was saved at "file://c:\Users\Игорь\Desktop\Symbian1\Symbian1\Symbian1Gui\Deb_S60_30M_WINSCW\BuildLog.htm"
    2>Symbian1Gui - 2 error(s), 0 warning(s)
    ========== Rebuild All: 1 succeeded, 1 failed, 0 skipped ==========

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: VC2005 error: >Error during set-up building environment:

    what is the windows version you are using.

  3. #3
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,671

    Re: VC2005 error: >Error during set-up building environment:

    Quote Originally Posted by skumar_rao View Post
    what is the windows version you are using.
    Given the fragments c:\Users\╚уюЁ№ and c:\Users\Игорь, it seems to be Russian Vista. Probably one of the worst possible combinations (non-English OS + Vista).

    Igor: search for Vista in both the Wiki and the Blogs, you will find some ideas, "success story"-es, however you will need luck too.
    The good news is that apparently building of the binaries actually succeeded (however it seems to be a .dll project, personally I would start with a simpler HelloWorld), compilation of the help file is what fails. So you may try removing help-support from the project, and check what happens.

  4. #4
    Registered User
    Join Date
    Sep 2008
    Posts
    4

    Re: VC2005 error: >Error during set-up building environment:

    Quote Originally Posted by skumar_rao View Post
    what is the windows version you are using.
    RUSSIAN VISTA X64 SP1

  5. #5
    Registered User
    Join Date
    Sep 2008
    Posts
    4

    Re: VC2005 error: >Error during set-up building environment:

    Quote Originally Posted by wizard_hu_ View Post
    Given the fragments c:\Users\╚уюЁ№ and c:\Users\Игорь, it seems to be Russian Vista. Probably one of the worst possible combinations (non-English OS + Vista).

    Igor: search for Vista in both the Wiki and the Blogs, you will find some ideas, "success story"-es, however you will need luck too.
    The good news is that apparently building of the binaries actually succeeded (however it seems to be a .dll project, personally I would start with a simpler HelloWorld), compilation of the help file is what fails. So you may try removing help-support from the project, and check what happens.
    Exactly no "success story" for x64 vista.. Very sad

  6. #6
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,671

    Re: VC2005 error: >Error during set-up building environment:

    Well, if a non-English Vista would not be enough, adding x64 really improves the challenge :-)
    Having these three together I would suggest using a Virtual PC.

  7. #7
    Registered User
    Join Date
    Sep 2008
    Posts
    4

    Re: VC2005 error: >Error during set-up building environment:

    Quote Originally Posted by wizard_hu_ View Post
    Well, if a non-English Vista would not be enough, adding x64 really improves the challenge :-)
    Having these three together I would suggest using a Virtual PC.
    But, carbide c++ 3.0.1 with s60 3.0 sdk works without any problems on my computer..

    what about debugging perfomance on virtual pc? Not to slow? (My config: intel Q6700,4GB DDR3,2x500 SATA,MSI X38)
    Last edited by divine108; 2008-09-17 at 17:24.

Similar Threads

  1. How to set environment in .Net 2002 for Series 60 SDK
    By umesh.roy in forum Symbian User Interface
    Replies: 0
    Last Post: 2005-01-25, 10:30
  2. Probelm after building abld file on C++ , Symbian 60 series environment
    By renaissancelabs in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2003-10-21, 09:47
  3. Replies: 0
    Last Post: 2003-02-28, 03:25
  4. now that I set up a CONE environment....
    By pchen4089 in forum Symbian
    Replies: 0
    Last Post: 2002-07-12, 22:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×