×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Oct 2007
    Posts
    80

    HTTP POST is not giving EGotResponseBodyData event

    Hi All,
    I am using the HTTP POST and GET method in my application.In that i found some problems.
    When i give a request via HTTP GET i had received below evets.
    1.Headers Received(EGotResponseHeaders)
    2.Bytes Received (EGotResponseBodyData)
    3.Transaction Complete(EResponseComplete)
    4.Transaction Success(ESucceeded)

    When i give a request via HTTP POST i am not able to received the
    Bytes Received (EGotResponseBodyData)event remaining events are received why?
    I want to receive the EGotResponseBodyData event while POST method also,is there any specific settings?

    please Help me.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: HTTP POST is not giving EGotResponseBodyData event

    For me I think it has worked the same always, so check what your Web service is actually doing.

  3. #3
    Regular Contributor
    Join Date
    Oct 2007
    Posts
    80

    Re: HTTP POST is not giving EGotResponseBodyData event

    Hi symbianyucca,
    Thanks for your reply, i had tried the HTTPclient Example also it also not giving the bodyreceived data event.
    can you please help me.

    Regards,
    Partha.
    Last edited by parthasaradhi6; 2008-09-17 at 10:19.

  4. #4
    Registered User
    Join Date
    Sep 2008
    Posts
    1

    Re: HTTP POST is not giving EGotResponseBodyData event

    I'm having the same problems. After a post, I only get the EGotResponseHeaders, EResponseComplete and ESucceeded responses. What is happening? I checked an ethereal capture file which indicates that the transaction was successful yet the body isn't generated. Even in the EGotResponseHeaders the status code and status text indicates the same. What is happening?

  5. #5
    Regular Contributor
    Join Date
    Dec 2008
    Location
    Prague or Carlsbad in Czech republic
    Posts
    54

    Wink Re: HTTP POST is not giving EGotResponseBodyData event

    I have the same problem ...

Similar Threads

  1. Mutliple HTTP Post Transactions?
    By b0ssY in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2007-07-02, 05:12
  2. HTTP POST multipart/form-data
    By flokyboy2006 in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2006-12-04, 22:35
  3. Series 40 phones HTTP POST problem
    By jessicay in forum Mobile Java Networking & Messaging & Security
    Replies: 0
    Last Post: 2004-06-23, 01:01
  4. 7650 J2ME/MIDP HTTP Post
    By cwalkinshaw in forum Mobile Java General
    Replies: 2
    Last Post: 2002-10-23, 10:12
  5. Replies: 0
    Last Post: 2002-05-09, 12:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×