×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Sep 2008
    Posts
    2

    Problems getting movingball sample to work

    I have been having some major problems getting the movingball sample to compile and link properly. I am using Carbide vs. 3.0 along with Visual Studio 2005 on a Windows Vista Home machine. I have installed the RDAccelerometer libraries as stated in the readme.

    I am using the S60 3.0 FP1 service pack (I am developing for the Nokia n95). I have applied the Vista patch and I am able to build all of the test applications I have tried. I am compiling for gcce using armv5 which I installed along with the SDK.

    Whenever I attempt to build the project, it fails on makesis with result 1. I have made sure the .pkg file is there, and when I remove references to the accelerometer code it compiles and links. I am assuming there is a linker error, but I have been unable to fix it.

    Any ideas?

    Updating MovingBall.mmp based on Deb_S60_31_WINSCW
    Update of mmp file not needed
    Target build using Symbian tool chain
    Set build parameters for Rel_S60_31_GCCE
    1>------ Build started: Project: MovingBall, Configuration: Rel_S60_31_GCCE Win32 ------
    1>Performing Makefile project actions
    1>* Current build configuration: GCCE UREL
    1>Converting multi-icons...
    1>EpocRoot = \Symbian\9.2\S60_3rd_FP1\
    1>* C:\Symbian\9.2\S60_3rd_FP1\\epoc32\tools\mifconv.exe \Symbian\9.2\S60_3rd_FP1\Epoc32\data\z\resource\apps\MovingBall_0xE14A45B8.mif /FC:\Users\Wilken\Downloads\MovingBall_Source_Codes\MovingBall\gfx\MovingBall.miflist
    1>MifConv version 1.11 build (39).
    1>Reading source list file: C:\Users\Wilken\Downloads\MovingBall_Source_Codes\MovingBall\gfx\MovingBall.miflist
    1>Checking: ..\gfx\qgn_menu_MovingBall.svg
    1>Choosing...
    1>Convert files...
    1>.
    1>Loading mif icons...
    1>Loading file: \Symbian\9.2\S60_3rd_FP1\epoc32\winscw\c\system\temp\s3rc.tmp\.._gfx_qgn_menu_MovingBall.svgb
    1>Writing mif: \Symbian\9.2\S60_3rd_FP1\Epoc32\data\z\resource\apps\MovingBall_0xE14A45B8.mif
    1>* Creating makefile for platform GCCE
    1>EpocRoot =
    1>* C:\Nokia\Tools\Carbide_vs30\makmake.bat \Users\Wilken\Downloads\MovingBall_Source_Codes\MovingBall\group\MovingBall GCCE
    1>The process tried to write to a nonexistent pipe.
    1>initialiseConfig: GCCE
    1> perl -S ecopyfile.pl "\Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Users\Wilken\Downloads\MovingBall_Source_Codes\MovingBall\group\MovingBall\GCCE\MovingBall_0xE14A45B8.rsg" "\Symbian\9.2\S60_3rd_FP1\EPOC32\INCLUDE\MovingBall_0xE14A45B8.RSG"
    1>* Running build action: build
    1>EpocRoot =
    1>* C:\Nokia\Tools\Carbide_vs30\make.bat -f C:\Users\Wilken\Downloads\MovingBall_Source_Codes\MovingBall\group\MovingBall.GCCE UREL
    1>make: Nothing to be done for `UREL'.
    1>* Creating install file at C:\Users\Wilken\Downloads\MovingBall_Source_Codes\MovingBall\sis\MovingBall_S60_3_X_v_1_0_0.sis
    1>EpocRoot = \Symbian\9.2\S60_3rd_FP1\
    1>* C:\Symbian\9.2\S60_3rd_FP1\\epoc32\tools\makesis.exe C:\Users\Wilken\Downloads\MovingBall_Source_Codes\MovingBall\sis\MovingBall_S60_3_X_v_1_0_0.pkg
    1>Processing C:\Users\Wilken\Downloads\MovingBall_Source_Codes\MovingBall\sis\MovingBall_S60_3_X_v_1_0_0.pkg...
    1> Error : Cannot find file : $(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\MovingBall_0xE14A45B8.exe
    1>C:\Users\Wilken\Downloads\MovingBall_Source_Codes\MovingBall\sis\MovingBall_S60_3_X_v_1_0_0.pkg(32) : error: file I/O fault.
    1>ERROR: RCMake failed: (Makesis): makesis exited with result 1. (Reason: Incorrect function.)
    1>Project : error PRJ0019: A tool returned an error code from "Performing Makefile project actions"
    1>Build log was saved at "file://c:\Users\Wilken\Downloads\MovingBall_Source_Codes\MovingBall\Rel_S60_31_GCCE\BuildLog.htm"
    1>MovingBall - 2 error(s), 0 warning(s)
    Unset build parameters for Rel_S60_31_GCCE
    I appreciate the help,

    Kenneth Williams

  2. #2
    Registered User
    Join Date
    Dec 2005
    Posts
    1,236

    Re: Problems getting movingball sample to work

    Hi,

    What are the capabilities you have given, did you check what accelerometer libraries capabilities are in readme. Then add them to your mmp. Then start compiling...
    Regards,
    Sriky

  3. #3
    Registered User
    Join Date
    Jun 2006
    Location
    India
    Posts
    1,043

    Re: Problems getting movingball sample to work

    Hi,
    It seems that the makesis is not able to find your application exe itself while trying to create the sis file. First check whether your exe in there or not.You can look for it in \epoc32\release\$(Platform)\$(Target)\(yourapp).exe.
    Also I noticed that you are using the absolute path for your SDK, that is not a problem but it is normally a good practice to substitute your working epoc to a virtual drive like
    C:\Symbian\9.2\S60_FP1\ to something like x: .
    Maximus
    S60 Developer
    Impossible is nothing

  4. #4
    Super Contributor
    Join Date
    May 2003
    Location
    Vancouver, Canada
    Posts
    985

    Re: Problems getting movingball sample to work

    I would suggest looking at the verbose log file, c:\Users\Wilken\Downloads\MovingBall_Source_Codes\MovingBall\Rel_S60_31_GCCE\BuildLog.htm.

    It may give some hints there.
    Antony Pranata
    http://www.antonypranata.com/
    http://www.s60tips.com/

  5. #5
    Super Contributor
    Join Date
    Nov 2004
    Location
    Wiltshire, UK
    Posts
    3,644

    Re: Problems getting movingball sample to work

    This example was designed with carbide.c++ and so I don't believe carbide.vs supports the replacable parameters in the pkg file as Carbide.c++ runs a make script to preprocess the pkg file to remove all the $(whatever) fields and replace them with the correct values then build the application
    Last edited by Paul.Todd; 2008-09-18 at 13:03.
    Download Symbian OS now! [url]http://developer.symbian.org[/url]

  6. #6
    Registered User
    Join Date
    Sep 2008
    Posts
    2

    Re: Problems getting movingball sample to work

    I replaced all of the $() with the actual paths and everything built just fine.

    Thanks!!!

    Ken

Similar Threads

  1. Workaround for browser control api problems on N95 8gb and N82
    By shrosenzwe in forum Symbian Networking & Messaging (Closed)
    Replies: 6
    Last Post: 2009-05-29, 12:46
  2. Problems getting Nokia 32 to work AT ALL!
    By steveeeee in forum Nokia M2M
    Replies: 1
    Last Post: 2004-01-14, 17:17
  3. WAV format, sample rate etc for Series 60 (3650 and 7650)
    By marcilgen in forum Mobile Java Media (Graphics & Sounds)
    Replies: 1
    Last Post: 2003-12-09, 20:24
  4. WAV format, sample rate etc for Series 60 (3650 and 7650)
    By marcilgen in forum Mobile Java General
    Replies: 0
    Last Post: 2003-12-09, 19:03
  5. Why my "Socket" sample can't work??
    By nfx in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2002-12-10, 13:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×