×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Sep 2008
    Posts
    6

    Unable to build the application while using javax.xml.parsers.*;

    Hi i am new to this domain.
    If I import below classes i am unable to build the application.

    import javax.xml.parsers.DocumentBuilder;
    import javax.xml.parsers.DocumentBuilderFactory;
    import org.w3c.dom.Document;
    import org.w3c.dom.Element;

    while building iam getting
    ....
    cannot find symbol
    symbol : class DocumentBuilder
    ......
    cannot find symbol
    symbol : class Document
    ......
    cannot find symbol
    symbol : class Element

    I am using Netbeans 5.5, J2MEpolish-2.0.2.jar and Jdk 1.5.
    For avoiding these errors I added the xmlParsersAPI-2.6.2.jar by selecting applicaton properties --> Libraries & Resources. Still I am getting the same errors.

    Please suggest me any solution. Thanks in advance for your reply.

    Regards
    Sunil.G

  2. #2
    Nokia Developer Expert
    Join Date
    Jun 2005
    Posts
    923

    Re: Unable to build the application while using javax.xml.parsers.*;

    I don't think your environment is set correctly. You need NetBeans Mobility Pack, which comes with all J2ME APIs, including JSR 172 - Web Services API. It seems like you're trying to use J2SE APIs in your code.

    Daniel

  3. #3
    Registered User
    Join Date
    Sep 2008
    Posts
    6

    Re: Unable to build the application while using javax.xml.parsers.*;

    Thanks dcrocha for your reply.

Similar Threads

  1. Unable to install a protected application from an untrusted application supplier
    By manjunaths in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 13
    Last Post: 2012-01-26, 16:31
  2. unable to run application problem
    By connman in forum Mobile Java General
    Replies: 2
    Last Post: 2007-11-22, 09:48
  3. Application installed but i am unable to open it
    By ms_sarwar1 in forum Symbian
    Replies: 2
    Last Post: 2007-10-29, 16:53
  4. build application with library
    By cmshop in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2005-10-05, 07:04
  5. "abld build error" emulator dont show application
    By jaskakei in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2005-05-09, 23:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×