×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 22
  1. #1
    Regular Contributor
    Join Date
    Aug 2008
    Posts
    413

    Unable to install error on device...

    Hi all,

    i am deploying sis file on Nokia 6210 Navigator..But error is coming saying that Unable to install..What may be the reason..


    Rohanwaugh.

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Unable to install error on device...

    if the application is in use and coded not to get events from other application to terminate it self then you will get this error.

  3. #3
    Registered User
    Join Date
    Jun 2006
    Location
    India
    Posts
    1,043

    Re: Unable to install error on device...

    Hi,
    Is the application already installed on your phone and you are trying to install same app over it. Try to uninstall the app from Application Manager.If it is not uninstalling from there also I guess then you have to go for factory reset but remember it will delete all your data from the phone memory.
    Maximus
    S60 Developer
    Impossible is nothing

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Unable to install error on device...

    Or could be that the pkg file just has some mistake on it, so you could maybe paste it in here..

  5. #5
    Registered User
    Join Date
    Apr 2006
    Location
    Beijing, China
    Posts
    1,175

    Re: Unable to install error on device...

    hi,
    Here is a troubleshooting list for installing applications:
    http://wiki.forum.nokia.com/index.ph...roubleshooting
    It may help you.

    Regards,
    dou
    Way of Simplicity

  6. #6
    Regular Contributor
    Join Date
    Sep 2008
    Location
    India
    Posts
    126

    Re: Unable to install error on device...

    Hi symbianyucca,

    1. I modified the existing sample example >> LBSReference
    application >>
    2. previously it giving error while creating .sis
    file >>
    3. As I copied that sample project in carbide workspace I made
    following changes in .pkg file
    4. Then project get compiled and .sis file get created
    finely.....
    5. But while installing on device I face
    " Unable to install error "
    6. The .pkg file is as follows :

    ;
    ; Installation file for LBSReference application

    ; Languages, (English only)
    &EN

    ; UID is the app's UID
    #{"LBS Reference"},(0xA0000189),1,0,0,TYPE=SA

    ;S60 v3.0
    [0x101f7961], 0, 0, 0, {"S60ProductID"}

    ; Localised Vendor name
    %{"Vendor-EN"}

    ; Unique Vendor name
    :"Vendor"

    ;
    ; Four files to install
    ;

    ;"..\..\..\epoc32\RELEASE\gcce\UREL\LbsReference.exe" -"!:\sys\bin\LbsReference.exe"
    ;"..\..\..\epoc32\data\z\Resource\apps\LBSReference.RSC" -"!:\Resource\apps\lbsreference.RSC"
    ;"..\..\..\epoc32\data\z\private\10003a3f\import\apps\LbsReference_reg.RSC" -"!:\private\10003a3f\import\apps\LbsReference_reg.RSC"
    ;"..\..\..\epoc32\data\z\resource\apps\lrefappfors60_aif.mif" -"!:\resource\apps\lrefappfors60_aif.mif"

    "C:\S60\devices\S60_3rd_FP2_SDK\epoc32\BUILD\Symbian\Carbide\workspace\LocationRefAppForS60\Group\LBSREFERENCE\GCCE\urel\LbsReference.exe" -"!:\sys\bin\LbsReference.exe"
    "C:\S60\devices\S60_3rd_FP2_SDK\epoc32\data\z\Resource\apps\LBSReference.RSC" -"!:\Resource\apps\lbsreference.RSC"
    "C:\S60\devices\S60_3rd_FP2_SDK\epoc32\data\z\private\10003a3f\import\apps\LbsReference_reg.RSC" -"!:\private\10003a3f\import\apps\LbsReference_reg.RSC"
    "C:\S60\devices\S60_3rd_FP2_SDK\epoc32\data\z\resource\apps\lrefappfors60_aif.mif" -"!:\resource\apps\lrefappfors60_aif.mif"

    ;required for application to be covered by backup/restore facility
    "..\data\backup_registration.xml" -"!:\private\A0000189\backup_registration.xml"





    ( This tread was created by Rohan for this issue only... so I m
    continuing with it now on behalf of him )

  7. #7
    Registered User
    Join Date
    Jun 2006
    Location
    India
    Posts
    1,043

    Re: Unable to install error on device...

    Hi,
    Have you checked if this application is already installed on the device??
    Even I got this error and checked to find that the application already existed on my device. You can check it from your Application Manager or in your application's menu.
    Maximus
    S60 Developer
    Impossible is nothing

  8. #8
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,533

    Re: Unable to install error on device...

    Quote Originally Posted by Kranti View Post
    Hi symbianyucca,

    1. I modified the existing sample example >> LBSReference
    application >>
    2. previously it giving error while creating .sis
    file >>
    3. As I copied that sample project in carbide workspace I made
    following changes in .pkg file
    4. Then project get compiled and .sis file get created
    finely.....
    5. But while installing on device I face
    " Unable to install error "
    6. The .pkg file is as follows :

    ;
    ; Installation file for LBSReference application

    ; Languages, (English only)
    &EN

    ; UID is the app's UID
    #{"LBS Reference"},(0xA0000189),1,0,0,TYPE=SA

    ;S60 v3.0
    [0x101f7961], 0, 0, 0, {"S60ProductID"}

    ; Localised Vendor name
    %{"Vendor-EN"}

    ; Unique Vendor name
    :"Vendor"

    ;
    ; Four files to install
    ;

    ;"..\..\..\epoc32\RELEASE\gcce\UREL\LbsReference.exe" -"!:\sys\bin\LbsReference.exe"
    ;"..\..\..\epoc32\data\z\Resource\apps\LBSReference.RSC" -"!:\Resource\apps\lbsreference.RSC"
    ;"..\..\..\epoc32\data\z\private\10003a3f\import\apps\LbsReference_reg.RSC" -"!:\private\10003a3f\import\apps\LbsReference_reg.RSC"
    ;"..\..\..\epoc32\data\z\resource\apps\lrefappfors60_aif.mif" -"!:\resource\apps\lrefappfors60_aif.mif"

    "C:\S60\devices\S60_3rd_FP2_SDK\epoc32\BUILD\Symbian\Carbide\workspace\LocationRefAppForS60\Group\LBSREFERENCE\GCCE\urel\LbsReference.exe" -"!:\sys\bin\LbsReference.exe"
    "C:\S60\devices\S60_3rd_FP2_SDK\epoc32\data\z\Resource\apps\LBSReference.RSC" -"!:\Resource\apps\lbsreference.RSC"
    "C:\S60\devices\S60_3rd_FP2_SDK\epoc32\data\z\private\10003a3f\import\apps\LbsReference_reg.RSC" -"!:\private\10003a3f\import\apps\LbsReference_reg.RSC"
    "C:\S60\devices\S60_3rd_FP2_SDK\epoc32\data\z\resource\apps\lrefappfors60_aif.mif" -"!:\resource\apps\lrefappfors60_aif.mif"

    ;required for application to be covered by backup/restore facility
    "..\data\backup_registration.xml" -"!:\private\A0000189\backup_registration.xml"





    ( This tread was created by Rohan for this issue only... so I m
    continuing with it now on behalf of him )
    I think the suggestion that I mentioned in your own thread http://discussion.forum.nokia.com/fo...d.php?t=145888 was worth some consideration than starting another thread which arose from the same issues discussed there

  9. #9
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,533

    Re: Unable to install error on device...

    ....And if you are looking for more narrowed down suggestion then check the path from where you are picking the exe for starters. Other things, if any, I didnt notice at the moment.

  10. #10
    Regular Contributor
    Join Date
    Sep 2008
    Location
    India
    Posts
    126

    Smile Re: Unable to install error on device...

    Thanks to all for suggestion.
    The problem get solved by setting appropriate paths in .pkg file
    (using $(EPOCROOT)Epoc32\..... )
    Now app get installed on device properly.

  11. #11
    Regular Contributor
    Join Date
    Jul 2012
    Posts
    82

    Question Re: Unable to install error on device...

    Hi guys,

    I am facing the same issue when i am installing the .pkg file.

    Steps taken -

    1. checked the pkg file.
    2. i am installing it from the current directory so the paths are like. i mean i have created a folder. copied all the binary in same folder created.

    ".\ripplevault.r01" -"!:\resource\apps\RippleVault.rsc"
    from this folder i am running makesis & signsis command.
    3. checked the uid no other app on my device with same uid is installed.4.
    4. done the restore factory setting on the device.


    now what should i do???
    Please suggest.


    my .pkg file is like --


    ;Sentinel.pkg
    ;
    ;Language - standard language definitions
    &EN

    ; standard SIS file header
    #{"Sentinel"},(0x2005AA6D),1,00,0,TYPE= SA

    ;Localised Vendor name
    %{"NTS"}

    ;Unique Vendor name
    :"NTS"

    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}

    ;Files to install
    ".\log.txt" -"!:\RippleVault\log.txt"
    ".\config.txt" -"!:\RippleVault\config.txt"
    ".\locate.me" -"!:\RippleVault\locate.me"
    ".\astart.stg" -"!:\RippleVault\astart.stg"
    ".\privacy.txt" -"!:\RippleVault\privacy.txt"
    ".\initsms.dat" -"!:\RippleVault\initsms.dat"
    ".\contactsetup.dat" -"!:\RippleVault\contactsetup.dat"
    ".\calendarsetup.dat" -"!:\RippleVault\calendarsetup.dat"
    ;

    ;".\apps[0x2005AA6D].r01" -"c:\private\101f875a\import\[2005AA6D].rsc"

    ;
    ".\ripplevault.r01" -"!:\resource\apps\RippleVault.rsc"
    ".\RippleVault_loc.r01" -"!:\resource\apps\RippleVault_loc.rsc"
    ".\RippleVault_reg.r01" -"c:\private\10003a3f\import\apps\RippleVault_reg.rsc"
    ".\rippleimage.mbm" -"!:\resource\apps\rippleimage.mbm"
    ;
    ".\sms.mbm" -"!:\RippleVault\sms.mbm"
    ".\logo.mbm" -"!:\RippleVault\logo.mbm"
    ".\tick.mbm" -"!:\RippleVault\tick.mbm"
    ".\tones.mbm" -"!:\RippleVault\tones.mbm"
    ".\games.mbm" -"!:\RippleVault\games.mbm"
    ".\video.mbm" -"!:\RippleVault\video.mbm"
    ".\empty.mbm" -"!:\RippleVault\empty.mbm"
    ".\images.mbm" -"!:\RippleVault\images.mbm"
    ".\marking.mbm" -"!:\RippleVault\marking.mbm"
    ".\settings.mbm" -"!:\RippleVault\settings.mbm"
    ".\phototick.mbm" -"!:\RippleVault\phototick.mbm"
    ".\rippleimage.mbm" -"!:\RippleVault\rippleimage.mbm"
    ".\statustick.mbm" -"!:\RippleVault\statustick.mbm"
    ".\statustick1.mbm" -"!:\RippleVault\statustick1.mbm"
    ;
    ".\Ripplevault_9.hlp" -"!:\resource\help\Ripplevault.hlp"

    ".\ErrRd.txt" -"!:\resource\ErrRd"

    ;
    ;required for application to be covered by backup/restore facility
    ;"backup_registration.xml" -"!:\private\20007F4F\backup_registration.xml"

    ".\imsi.txt" -"!:\system\secure\imsi.txt"

    ".\dog_bark.amr" -"!:\system\secure\dog_bark.amr"
    ;

    ".\RippleVault.exe" -"!:\sys\bin\RippleVault.exe",FR,RI


    ""-"!:\RippleVault\regripplevault.dat",FN
    ""-"!:\RippleVault\initupload.tag",FN
    ""-"!:\RippleVault\regdetails.dat",FN
    ""-"!:\RippleVault\probs.txt",FN
    ""-"!:\RippleVault\smsbackup.man",FN
    ""-"!:\RippleVault\smsbackup.aut",FN
    ""-"!:\RippleVault\changesdb.dat",FN
    ""-"!:\RippleVault\timestamp.txt",FN
    ""-"!:\RippleVault\resume.dat",FN
    ""-"!:\RippleVault\astart.stg",FN
    ""-"!:\RippleVault\imsi.txt",FN
    ""-"!:\RippleVault\photos.db",FN
    ""-"!:\RippleVault\log.txt",FN


    ""-"!:\RippleVault\Calchangesdb.dat",FN
    ""-"!:\RippleVault\Todochangesdb.dat",FN
    ""-"!:\RippleVault\",FN
    ""-"!:\RippleVault\",FN

  12. #12
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Unable to install error on device...

    FN does not really remove folders, so those lines will not work.

    Also do check the exact error message in English, and copy it here.

    Also make sure none of the files you are trying to install are not installed with other sis files. Basically you could comment lines out, and try until you figure out which line(s) are giving you the installation problems.

  13. #13
    Regular Contributor
    Join Date
    Jul 2012
    Posts
    82

    Re: Unable to install error on device...

    the error at the end of installation is "unable to install".

    No error related to developer certificate is there

  14. #14
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Unable to install error on device...

    so then you could try what was suggested. i.e. comment lines out, and find out which line in your pkg is giving the problem.

  15. #15
    Regular Contributor
    Join Date
    Jul 2012
    Posts
    82

    Re: Unable to install error on device...

    hi i tried the same but still getting the same error...

Similar Threads

  1. Unable to install a protected application from an untrusted supplier
    By razas in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 51
    Last Post: 2010-01-16, 16:49
  2. Unable to receive data from Bluetooth Device Via RFComm
    By kctan in forum Bluetooth Technology
    Replies: 0
    Last Post: 2008-06-15, 15:23
  3. Carbide C++ 1.1 upg to 1.2 - unable to install on device
    By arijr in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 0
    Last Post: 2007-10-13, 23:21
  4. Unable to install protected application :: PleaseHelpL
    By evariste in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 3
    Last Post: 2007-03-19, 12:54
  5. Unable to install Yahoo Go, Gmail after formatting
    By popophobia in forum General Development Questions
    Replies: 2
    Last Post: 2007-03-14, 09:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×